LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2008, 06:12 PM   #1
7mza
Member
 
Registered: May 2008
Location: Jordan
Distribution: use fedora but prefer Slackware
Posts: 98

Rep: Reputation: 15
install grub


hello guyz ,
it`s gaves me these error when am trying to boot slackware

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel Panic - not syncing: VFS Unable to mount root fs on unknown-block(0,0)

and my grub.conf is :

boot=/dev/hda
default=2
timeout=5
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title install slackware
root (hd0,0)
kernel /boot/vmlinuz ro root=/dev/hda1

Last edited by 7mza; 08-31-2008 at 09:09 PM.
 
Old 09-01-2008, 12:06 AM   #2
czarr
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 36

Rep: Reputation: 15
i suppose the problem is in the "root=/dev/hda1" part. hda is the name of the device, it could also be sda. the number refers to the partion. You may want to simplify your config for now until you get this sorted out. heres what mine looks like:
Code:
title  Arch Linux  [/boot/vmlinuz26]
root   (hd0,1)
kernel /vmlinuz26 root=/dev/sda3 ro
initrd /kernel26.img
 
Old 09-01-2008, 07:27 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
What is the purpose of "boot=/dev/hda" at the beginning of the file?

Also, "ro" typically comes after the root= statement in the kernel line---like so:
kernel /boot/vmlinuz root=/dev/hda1 ro

Finally, be sure that your kernel is actually named "vmlinuz". I always make a soft link to do this.
 
Old 09-01-2008, 09:41 AM   #4
7mza
Member
 
Registered: May 2008
Location: Jordan
Distribution: use fedora but prefer Slackware
Posts: 98

Original Poster
Rep: Reputation: 15
oky i change my grub.conf like this

title install slackware
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro


but it give me these errors when am boot slackware :

init : illgel run level : root =/dev/hda1
kernel panic - not syncing : attempted to kill init !

what i have to do ?
 
Old 09-01-2008, 11:42 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Did you try sda instead of hda (as suggested by czarr)?

also, I just noticed the space in the title--I think that may be causing problems. Try changing it to "title slackware" or "title install_slackware" (The clue is the error message--it was looking for a runlevel and found the root statement. Makes no sense)
 
Old 09-01-2008, 11:49 AM   #6
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
pixellany look at the default number in his first post, you are assuming his slack is on sda1. 7mza if you can boot to a terminal on a live cd type 'fdisk -ln' as root and post us the results here.

Last edited by Larry Webb; 09-01-2008 at 11:53 AM.
 
Old 09-01-2008, 11:53 AM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by Larry Webb View Post
pixellany look at the default number in his first post, you are assuming his slack is on sda1
First post said hda1--I was following czarr's suggestion that it maybe should be sda1
 
Old 09-01-2008, 11:57 AM   #8
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
I am talking about his default set to number two which means he has a least two distros in the menu list or he has changed the number on default. I worked one of these the other day that a guy had two drives and I did not find that out till after five posts and the distro he was having problems was on the second hd.
 
Old 09-01-2008, 12:10 PM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Ooooops!! OK, I'm a little slow today.

But default 0 means #1, n'est-ce pas?

All along, I have assumed that the issue was with the configuration for Slackware, and that OP knew to select the right thing from the boot menu.....

7mza;
If you're still with us, give us the output of:
fdisk -l (run this as root---sometimes needs to be /sbin/fdisk -l
all entries in /boot/grub/menu.lst
 
Old 09-01-2008, 04:20 PM   #10
7mza
Member
 
Registered: May 2008
Location: Jordan
Distribution: use fedora but prefer Slackware
Posts: 98

Original Poster
Rep: Reputation: 15
Cool

thnx for your help guys , yeah Larry Webb , u r right i have other distros ( windows , centos ) coz i had 2 HD one of them has Slackware and other has (Windows & CentOs) but am working now on 1st HD that has Slackware and it dosnt matter what the default number coz i choose my distros manual and c my fdisk -ln and fdisk -ln:

root@ubuntu:~# fdisk -ln
fdisk: invalid option -- n

Usage: fdisk [-b SSZ] [-u] DISK Change partition table
fdisk -l [-b SSZ] [-u] DISK List partition table(s)
fdisk -s PARTITION Give partition size(s) in blocks
fdisk -v Give fdisk version
Here DISK is something like /dev/hdb or /dev/sda
and PARTITION is something like /dev/hda7
-u: give Start and End in sector (instead of cylinder) units
-b 2048: (for certain MO disks) use 2048-byte sectors





root@ubuntu:~# fdisk -l

Disk /dev/hdd: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdd1 * 1 2432 19535008+ 83 Linux
/dev/hdd2 2433 4865 19543072+ f W95 Ext'd (LBA)
/dev/hdd5 2433 3647 9759456 83 Linux
/dev/hdd6 3648 4741 8787523+ 83 Linux
/dev/hdd7 4742 4865 995998+ 83 Linux
 
Old 09-01-2008, 05:24 PM   #11
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
I am sorry for the typo error, it should have been fdisk -lu but fdisk -l works also. The fdisk -l you are showing is what your bios shows to boot 4th and in order to boot from it you would have to have

root (hd3,X) the 'X' being the partition number -1 that you wanted to boot.

You need to do the fdisk -l from a live cd and not an installed distro.
 
Old 09-01-2008, 05:54 PM   #12
7mza
Member
 
Registered: May 2008
Location: Jordan
Distribution: use fedora but prefer Slackware
Posts: 98

Original Poster
Rep: Reputation: 15
sorry Larry Webb i didnt understand what u mean by " you would have to have root (hd3,X) " i just have one HD so it would be like root(hd0,X)

oky i change my kernel now and my grub.conf like this

title slackware
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-53.1.13.el5 root=/dev/hdd1 ro

will reboot now and c what happen

Last edited by 7mza; 09-01-2008 at 06:50 PM.
 
Old 09-01-2008, 06:22 PM   #13
7mza
Member
 
Registered: May 2008
Location: Jordan
Distribution: use fedora but prefer Slackware
Posts: 98

Original Poster
Rep: Reputation: 15
not work . i think i have to mount something on fstab ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub error 17, and wont reinstall using grub-install! chiefreborn Linux - General 6 06-06-2007 10:29 AM
Grub - Does fedora automatically install a bootloader like grub? or... mitchell7man Linux - Software 10 05-09-2007 10:49 AM
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc. dissolved soul Ubuntu 2 01-13-2007 12:55 PM
Need to (re)install GRUB: fedora c4 rescue cd (and GRUB) unable to see the harddisk whencat Fedora 4 03-05-2006 02:01 PM
Grub 0.97 issues on slackware - grub-install is very slow, & updating menu.lst fails dieyouspammer Linux - Software 1 02-27-2006 01:06 PM


All times are GMT -5. The time now is 06:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration