LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2003, 12:36 AM   #1
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Install Fluxbox


I've had SuSE 8.1 installed for about a week. Can anyone pretend they're explaining something to a child and tell me how to install Fluxbox and get it in the sessions list at the graphical login? I've searched this forum and several others. People are talking about writing scripts and editing things with certain tools that I know nothing about. I downloaded the tarball and source.rpm.
 
Old 01-02-2003, 03:28 AM   #2
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
Here's the instructions for installing Fluxbox :

1 -
tar -xvzf fluxbox*
2 -
cd fluxbox*
3 -
Run the configure script :
Quote:
./configure
then,
Quote:
make
finally,
Quote:
make install
4 -
If you're using GDM as a graphical login, create a new file called fluxbox in /etc/X11/gdm/Sessions .
Then, you have to write in it the path of Fluxbox :
/usr/local/bin/fluxbox
5 -
Save and close the file.

6-
chattr +i fluxbox

I don't know how to add sessions in other login managers like kdm or xdm

Hope that helps,
hfawzy
 
Old 01-02-2003, 04:33 AM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Cool, nice instructions

fyi kdm uses the settings from xdm.
 
Old 01-02-2003, 06:06 AM   #4
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
I'm stuck in step 4. KDM does use xdm, but once I get to file:/etc/X11/xdm there's no Session directory. There's a bash Xsession file, but running that just logs me out and bring graphical login back up.
 
Old 01-02-2003, 06:32 AM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Nah, if you are using kdm you create an entry in:
/etc/X11/wmsession.d

Mine looks like this in Mandrake:
Code:
root@masterc:/etc/X11/wmsession.d# ls
01KDE  02GNOME  03WindowMaker  04Enlightenment  05blackbox  06XFce  16fluxbox
And if I open up the text file 16fluxbox it looks like this:
Code:
root@masterc:/etc/X11/wmsession.d# cat 16fluxbox
NAME=FluxBox
ICON=fluxbox.png
EXEC=/usr/X11R6/bin/startfluxbox
DESC=A Light and nice looking window manager
SCRIPT:
exec /usr/X11R6/bin/startfluxbox
And then:
Code:
root@masterc:/usr/X11R6/bin# cat startfluxbox
/usr/X11R6/bin/bsetroot -solid Black
exec /usr/X11R6/bin/fluxbox
root@masterc:/usr/X11R6/bin#
HTH

Cool
 
Old 01-02-2003, 06:45 AM   #6
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
No /etc/X11/wmsession.d

file:/etc/X11

dirs:
fs
kd3
lbproxy
proxymngr
rstart
susewm
twm
xdm
xinit
xkb
xserver
xsm

textfiles:
qtrc
XF86Config
X86Config.saxsave
Xmodmap
Xmodmap.remote
 
Old 01-02-2003, 07:00 AM   #7
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
I searched for that file and it doesn't exist.
 
Old 01-02-2003, 07:04 AM   #8
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
Umm okay. I saw fluxbox in the list of sessions at login and chose it. It works fine. I don't understand how I didn't have to do anything and everyone else had to create and edit files. Weird.

Thanks for your help anyhow guys! I appreciated it.
 
Old 01-02-2003, 07:08 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
.... Hmmm ....

So:
updatedb &&
locate wmsession.d

Brought up nothing, and the directory is non-existent. Very odd indeed. I can only guess it's not KDM you are using? You don't have gdm there either though? How odd indeed. Can you post here what's in your xdm directory?

To paste from a terminal:
highlight the text to be posted, click inside the browser, and then press the middle button to paste the highlighted information.

Cool
 
Old 01-02-2003, 07:10 AM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64


It probably depends on what file version of flux you install. If it's a SuSE specifc rpm I'd think that it might create the necessary entries for you. But it looks like it wasn't one, yet it still worked. SuSE really does a decent job at doing things for you. This can be good, or bad, depending on how you look at things.

At least you've got it running! Flux rocks

Cool
 
Old 01-02-2003, 07:22 AM   #11
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
snocked@linux:/etc/X11/xdm> ls
BackGround RunChooser Xresources Xsetup chooser xdm-errors
GiveDevices TakeDevices Xservers Xstartup pixmaps xdm-pid
README.SuSE Xaccess Xservers.fs Xwilling sys.xsession
README.security Xreset Xsession authdir xdm-config
 
Old 01-02-2003, 07:31 AM   #12
macewan
Senior Member
 
Registered: Jan 2002
Distribution: Ubuntu, Debian
Posts: 1,055
Blog Entries: 1

Rep: Reputation: 45
just switch to using gdm - it's easier
 
Old 01-14-2003, 06:43 PM   #13
mp-
LQ Newbie
 
Registered: Jan 2003
Posts: 2

Rep: Reputation: 0
How do I switch to gdm?
 
Old 01-14-2003, 07:34 PM   #14
macewan
Senior Member
 
Registered: Jan 2002
Distribution: Ubuntu, Debian
Posts: 1,055
Blog Entries: 1

Rep: Reputation: 45
what distro are you using?
 
Old 02-01-2003, 06:09 PM   #15
Panorama
LQ Newbie
 
Registered: Feb 2003
Location: Canada
Distribution: RedHat 8.0
Posts: 1

Rep: Reputation: 0
Sorry to bring this up but I'm a newb at this. I have RedHat 8.0 installed and when I try to configure it I get:

Code:
[root@localhost fluxbox-0.1.14]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/Admin/Duvien/Downloads/LinuxShell/fluxbox/fluxbox-0.1.14/missing: Unknown
`--run' option
Try `/home/Admin/Duvien/Downloads/LinuxShell/fluxbox/fluxbox-0.1.14/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
[root@localhost fluxbox-0.1.14]#
Can anyone help me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox Install Fenix11 Mandriva 12 05-17-2005 07:26 PM
How do I install fluxbox? DeadPenguin Linux - Newbie 3 11-18-2004 08:24 AM
Fluxbox: Enabling KDE using package install of fluxbox underline Linux - Software 0 12-27-2003 11:11 AM
cant install fluxbox jakesh Linux - Software 9 12-08-2003 07:58 AM
fluxbox install chrismiceli Linux - Software 3 06-11-2003 11:00 PM


All times are GMT -5. The time now is 02:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration