LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2013, 05:15 AM   #1
manuce
Member
 
Registered: Nov 2012
Posts: 48

Rep: Reputation: Disabled
Install Centos issue: in httpd and ftpd can't find install.img


Hello,

I am following on the Asghar Ghori's book for RHCSA and RHCE exam.

Scenario : I am using default KVM to setup a virutal machine through ftpd or httpd setup:

I setup the httpd and ftpd ,put correct selinux context and Iptable entries check the files by opening them in the browser and the seems to be in there. I am copying the setup files under /var/www/html/rhel6/cdrom for httpd and /var/ftp/rhel6/cdrom.

but it always hangs in the VM installation when its trying to find install.img and gives can't retrieve install.img

I only once had a luck for which I have no fixed explanation. I turned off the IPTABLES completely and it picked up the images but later it didn't even if I turn on/off the iptables, I even set the selinux on permissive but still same error. I have checked on the internet and some people say they tried same thing with Scietific linux and it went out smoothly without any problem and its can be a bug with Centos. This is kinda getting frustrating as I am not getting anywhere with this. Will be thankful for your help.

Cheers-M

Last edited by manuce; 05-24-2013 at 05:16 AM.
 
Old 05-24-2013, 11:49 AM   #2
manuce
Member
 
Registered: Nov 2012
Posts: 48

Original Poster
Rep: Reputation: Disabled
anyone plz before I start pulling my hairs off
 
Old 05-25-2013, 05:56 AM   #3
bloodstreetboy
Member
 
Registered: May 2012
Posts: 198
Blog Entries: 3

Rep: Reputation: 37
Have you installed these packages on your centOS
Quote:
$ yum install kvm libvirt libvirt-python python-virtinst
1) Configure a bridge (Debian/Ubuntu or Red Hat/Fedora) to use a single network interface for all your virtual machines.

2) Create the virtual machine (a RHEL 5 virtual machine in this example): virt-install --name=guest_name --arch=x86_64 --vcpus=1 --ram=512 --os-type=linux --os-variant=rhel5 --hvm --connect=qemu:///system --network bridge:br0 --cdrom=/var/lib/libvirt/images/rhel5-x86_64.iso --disk path=/mnt/virtual_machines/guest_name.img,size=20 --accelerate --vnc --noautoconsole --keymap=es
Explanation of the params:
name: name of the guest.
arch: architecture of the guest.
vcpus: number of CPUs assigned to the guest.
ram: MB of RAM assigned to the guest.
os-type and os-variant: available options can be checked using man virt-install.
hvm: use full virtualization.
connect: connect to the hypervisor.
network bridge: the bridge to use for the guest.
cdrom: the ISO of the operating system to install.
disk path=x,size=y: path and size of the image file for the guest.
accelerate: make use of the KVM acceleration capabilities if available.
vnc: export a virtual console over VNC to the guest.
noautoconsole: Don’t automatically try to connect to the guest console.
keymap: keyboard layout for the VNC console

3) Use a VNC client to connect to the guest (port 5900 or 5901 if you already have a VNC server listening on port 5900) and install the operating system.
 
Old 05-25-2013, 12:23 PM   #4
Armann
Member
 
Registered: May 2013
Location: Iceland
Distribution: RHEL/CentOS
Posts: 32

Rep: Reputation: Disabled
Did you enable nat ?

net.ipv4.ip_forward = 1
In /etc/sysctl.conf

Last edited by Armann; 05-25-2013 at 12:27 PM.
 
Old 05-25-2013, 12:26 PM   #5
Armann
Member
 
Registered: May 2013
Location: Iceland
Distribution: RHEL/CentOS
Posts: 32

Rep: Reputation: Disabled
Forgot, if it's not enabled write sysctl -p to make it active after you changed the value to 1.
 
Old 05-25-2013, 07:34 PM   #6
manuce
Member
 
Registered: Nov 2012
Posts: 48

Original Poster
Rep: Reputation: Disabled
Armann you are Genious! absolutely it worked liked a charm. Thank you so much Armann impressive stuff
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 5 install issue:: install stops at "running /sbin/loader " linuxandtsm Linux - Newbie 2 07-13-2012 12:15 AM
Cant install Virtual machine in CentOS 6 Cannot find package qemu-kvm in yum install linux_rhca Linux - Newbie 4 10-19-2011 06:37 AM
CentOS Install Issue athomas Linux - Software 1 07-06-2010 03:41 PM
Ubuntu as frugal install, iso install, img install? impossible? nooby Ubuntu 15 08-22-2008 06:49 AM
anaconda can't find minstg2.img on guest install kmccrory Fedora - Installation 0 02-14-2007 09:53 AM


All times are GMT -5. The time now is 10:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration