LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2008, 08:16 AM   #1
zakir_123
LQ Newbie
 
Registered: May 2008
Posts: 7

Rep: Reputation: 0
install apt-get


i am trying to install apt in my centos 5.
wget http://apt-rpm.org/releases/apt-0.5.15lorg3.tar.bz2
tar -vxf apt-0.5.15lorg3.tar.bz2
cd apt-0.5.15lorg3
./configure
then i get this error msg
configure: error: Can't find rpmlib.h
any idea why?
 
Old 06-03-2008, 08:33 AM   #2
lucazorzi
Member
 
Registered: Jul 2006
Location: Italy
Distribution: Ubuntu 11.04, Debian, OS X
Posts: 71

Rep: Reputation: 16
Maybe you need RPM's developmente headers.
 
Old 06-03-2008, 09:18 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,682

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
The package name is 'rpm-devel'

Rgds
 
Old 06-04-2008, 12:59 AM   #4
zakir_123
LQ Newbie
 
Registered: May 2008
Posts: 7

Original Poster
Rep: Reputation: 0
thank you knudfl
i have installed apt. but i get this error
E: Could not open file /etc/apt/rpmpriorities - open (2 No such file or directory)
E: could not open package priority file /etc/apt/rpmpriorities
 
Old 06-04-2008, 01:11 AM   #5
uncle_philip
Member
 
Registered: Apr 2008
Location: sydney
Distribution: centos5.2
Posts: 50

Rep: Reputation: 15
if you are under Centos5,
wget http://apt.sw.be/packages/apt/apt-0.5.....
and
wget http://dag.wieers.com/rpm/packages/rpmforge-release/.....
... means, I forgot the name.
Then, install that 2 files, you will be fine.
 
Old 06-04-2008, 09:08 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,682

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
The first link #5 didn't work for me, found another :
http://rpm.pbone.net/index.php3/stat....i386.rpm.html
(One of the links on this site works)

P.S.If these files are asked for, an empty file will do:
(usr)/sbin/update-rc.d
/var/lib/dpkg/status
/var/lib/dpkg/available

Last edited by knudfl; 06-04-2008 at 09:15 AM. Reason: PS
 
Old 06-05-2008, 07:25 AM   #7
zakir_123
LQ Newbie
 
Registered: May 2008
Posts: 7

Original Poster
Rep: Reputation: 0
once again thankx knudfl
u r my hero.
by d way this link works
ftp://ftp.pbone.net/mirror/dag.wieer....test.i386.rpm

now i have que.
one of my server was configured by another person. in that sever LAMP install. server's os is centos and squid is also installed + php - 5.2.

if i apt-get install php5 libapache2-mod-php5. will it delete my previous php and install new php ?

oh no
i get E: Couldn't find package apache2
when
apt-get install apache2 php5 libapache2-mod-php5

Last edited by zakir_123; 06-05-2008 at 07:39 AM.
 
Old 06-05-2008, 09:11 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,682

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
Package name is httpd, example shown :
CentOS 5 httpd-2.2.3-11.el5_1.centos.3.i386.rpm
is from
http://rpm.pbone.net/index.php3/stat....i386.rpm.html

Rgds
P.S.: I also wondered, why not "apache", but "httpd"

Last edited by knudfl; 06-05-2008 at 09:13 AM.
 
Old 06-05-2008, 10:42 AM   #9
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
Any particular reason you are not using yum?
 
  


Reply

Tags
apt-get, centos5


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there knoppix-like distro, that we can: apt-get update; apt-get install programs ? frenchn00b Linux - Distributions 7 04-28-2008 02:06 PM
LXer: Apt-get remove SUSE; apt-get install Etch LXer Syndicated Linux News 0 05-26-2007 07:46 PM
Question about 'apt-get upgrade' versus 'apt-get install' eur0dad Red Hat 8 07-16-2006 05:41 PM
apt-get install not working / apt-get update is ok remy215 Debian 2 10-01-2005 07:02 PM
knoppix 3.4 and no apt-setup how to fix info install apt-file + base-config maximalred Debian 0 10-16-2004 06:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration