LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2013, 03:07 PM   #1
masca4
LQ Newbie
 
Registered: Feb 2013
Posts: 3

Rep: Reputation: Disabled
Instalation process dont get GCC-4.5.7


I am trying to make and make install a program but it is giving me the following eror:
[lucas@lucas sparsePregraph]$ make
pregraph_sparse_63mer.v1.0.3 cleaning done.
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc build_graph.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc build_edge.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc multi_threads.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc build_preArc.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc pregraph_sparse.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc io_func.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc global.cpp
/bin/sh: line 1: /opt/blc/gcc-4.5.0/bin/gcc: Arquivo ou diretório não encontrado
Error in command: /opt/blc/gcc-4.5.0/bin/gcc -c -O4 -fomit-frame-pointer -D_63MER_ -m64 -I./inc convert_soapdenovo.cpp
make: /opt/blc/gcc-4.5.0/bin/gcc: Comando não encontrado
make: ** [pregraph_sparse] Erro 127

I already have the GCC-4.7.2 installed, which can also work.

[lucas@lucas bin]$ ls
c++ g++ gcc-ranlib gpg-error-config libgcrypt-config x86_64-unknown-linux-gnu-g++ x86_64-unknown-linux-gnu-gcc-nm
cc gcc gcov hmac256 pth-config x86_64-unknown-linux-gnu-gcc x86_64-unknown-linux-gnu-gcc-ranlib
cpp gcc-ar gfortran ksba-config r223 x86_64-unknown-linux-gnu-gcc-4.7.2 x86_64-unknown-linux-gnu-gfortran
dumpsexp gcc-nm gpg-error libassuan-config x86_64-unknown-linux-gnu-c++ x86_64-unknown-linux-gnu-gcc-ar

Can I indicate the path to the program be installed? How can I do that? Is there any other way to make it work?

Thanks
 
Old 02-22-2013, 03:32 PM   #2
millgates
Member
 
Registered: Feb 2009
Location: 192.168.x.x
Distribution: Slackware
Posts: 840

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Does compiling other programs work? It seems that make is looking for gcc in the wrong place.
What is the output of
Code:
which gcc
Also, you can look in the Makefile. There should be something like (near the top of the file)

Code:
CC=[something]
You can try changing it to match your system.
Also, I don't know what program you are trying to compile, so maybe it is looking for a specific compiler in a specific place for a reason.
 
Old 02-22-2013, 03:37 PM   #3
masca4
LQ Newbie
 
Registered: Feb 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
which gcc

[lucas@lucas ~]$ which gcc
/usr/bin/gcc
[lucas@lucas ~]$

The program I am trying to install needs GCC-4.4.0 or superior, Ive just installed GCC-4.7.2.
 
Old 02-22-2013, 03:38 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
it looks like that makefile is calling 4.5
or
the symbolic link "gcc" and "CC" are pointing to the wrong version

please post the output of
Code:
gcc -v
and check the links
--- all these might be links to the real version --
c++ g++ cc gcc gcov cpp


also what operating system is this and it's version

you can have many different versions of gcc installed
i have
gcc 3.4, gcc 4.1 gcc 4.3 and gcc 4.7

yes i am lazy and sometimes it is just easier to use an older version of gcc than hack the source code
 
Old 02-22-2013, 03:47 PM   #5
masca4
LQ Newbie
 
Registered: Feb 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
the output of gcc -v

[lucas@lucas ~]$ gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC)

I also have installed GCC-4.7.2 at /home/lucas/gnu/bin, anthis GCC should work.

I am using CentOS 6.2
 
Old 02-22-2013, 04:14 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
Quote:
/home/lucas/gnu/bin
that is not where you install it
please use YUM
it will install ALL needed dependencies and install it to the correct location

also CentOS 6.2 is unsupported !!!
please upgrade to the only 6 version that is supported
CentOS 6.3
Code:
su -
yum --releaseserver=6.3 upgrade
the centos6.2 repos are DEAD


then
Code:
su -
yum search gcc
that will output what is in the repos that you have installed
you also need a LOT of other things besides just gcc
you NEED the whole suite of tools that gcc needs to work
Code:
su -
yum grouplist
---- will output a list of "software groups "---
yum groupinstall "Development Tools"
then after that we can look into any needed extra software
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i dont have gcc on linux!!!!!! baxzius Linux - Newbie 2 02-09-2010 09:16 PM
why gcc make warning message dont show color font? wwqly12 Linux - Software 2 03-19-2009 05:55 PM
Fedora 9. Problem with an instalation process vsp Linux - Newbie 4 08-15-2008 09:43 AM
Dont understand how to install kernel development packages and gcc Hollomankilla Linux - Newbie 3 10-23-2007 12:21 AM
Instalation Process tauhshi Mandriva 28 12-21-2005 08:45 PM


All times are GMT -5. The time now is 12:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration