LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-20-2004, 03:48 AM   #1
sjoe
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 8.0 2.4.20-28.8
Posts: 6

Rep: Reputation: 0
Init-level 5 but X11 don't start [SOLVED]


My HD got full and when rebooting X11 couldn’t start. After a while I got a message that my display was disabled.

After removing temporary files I can reboot without problem, but I only get to login prompt, no X is started. But running startx works fine.

How can I get X to start without having to login and run startx?

Thanks

/Sven

Last edited by sjoe; 09-20-2004 at 08:05 AM.
 
Old 09-20-2004, 04:50 AM   #2
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
Hi Sven

Maybe the settings was changed when your HDD got full? If root issues the command:
/sbin/runlevel
does it say 3 then? If so, root should edit the file
/etc/inittab
Look for this line:
id:3:initdefault:
and change 3 to 5

Good luck!
Martin
 
Old 09-20-2004, 04:54 AM   #3
theonebeyond
Member
 
Registered: Aug 2004
Location: Germany
Distribution: Slackware 10.0
Posts: 258

Rep: Reputation: 30
Are you running slackware? because in slackware it is runlevel 4 ....
 
Old 09-20-2004, 05:29 AM   #4
sjoe
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 8.0 2.4.20-28.8
Posts: 6

Original Poster
Rep: Reputation: 0
/sbin/runlevel shows 5.
And I'm using Redhat 8.0.

More ideas?
 
Old 09-20-2004, 06:00 AM   #5
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
try "startx" - does it load your GUI?
 
Old 09-20-2004, 06:46 AM   #6
sjoe
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 8.0 2.4.20-28.8
Posts: 6

Original Poster
Rep: Reputation: 0
Yes, startx works fine, X is started as usually, no errors.

But I want it to start automatically.

I'm beginning to suspect that something has been removed from /etc/rc5.d. What need to be there to start X? Is there a utility to configure X manually?
 
Old 09-20-2004, 07:05 AM   #7
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,937

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
Do as MartinN said: Edit your /etc/inittab and put "5" at the line initdefault
 
Old 09-20-2004, 07:24 AM   #8
sjoe
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 8.0 2.4.20-28.8
Posts: 6

Original Poster
Rep: Reputation: 0
My initdefault IS 5. Still X11 is not starting. And no errors. And startx works fine!
 
Old 09-20-2004, 07:46 AM   #9
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
I haven't seen this problem myself, but we could start trying to figure it out. Are you familiar with the command line and editing configuration files? Things will be a lot easier if you have at least a little experience in that.

There should be a section like this in your /etc/inittab file:
Code:
# Run xdm in runlevel 5
# xdm is now a separate service
x:5:respawn:/etc/X11/prefdm -nodaemon
This means that init will restart the script file /etc/X11/prefdm whenever it exits. Do you have a section like that in inittab?

By the way, one of my machines is running RedHat 8, so your scripts should look pretty much like mine.

Martin
 
Old 09-20-2004, 08:05 AM   #10
sjoe
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 8.0 2.4.20-28.8
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you MartinN!

After the X11 faild to start I tried to edit inittab and chage initdefault to 3, but it turned out that I had changed the x-line in stead of id-line!

So after returning the x-line to 5 everything works fine!

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/X11/xinit/.Xmodmap; run level 4 won't init script Potatopopper Slackware 5 11-27-2005 07:37 PM
changing init level h3htimo Linux - Newbie 5 10-24-2005 11:05 PM
Different Resolution init level 3 ? utw-mephisto Red Hat 4 06-19-2005 06:38 AM
init level 5 for remote X but not local gw1500se Mandriva 0 05-31-2004 02:54 PM
init level settings rufius Linux - General 1 04-29-2003 06:57 PM


All times are GMT -5. The time now is 06:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration