LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-04-2012, 05:17 AM   #1
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Rep: Reputation: Disabled
INIT: Id "x" respawning too fast: disabled for 5 minutes error in centos and GUI not


well i removed perl first and after that i restarted the system......it then goes into that black login screen which say INIT: Id "x" respawning too fast: disabled for 5 minutes

i then pressed "ENTER" button then it asked for login and password and then again installed perl and then updated...now it isnt going to the GUI screen at all and gives the same error..

Can anyone help me please?
 
Old 01-04-2012, 06:22 AM   #2
singhjc
Member
 
Registered: Nov 2010
Location: Moradabad
Distribution: Redhat,Centos
Posts: 31

Rep: Reputation: 1
Hi i think that there is some problem with your X server which is not allowing to init 5 for create the session for GUI, well take your system restart and boot with run level 1 and first check disk file system for all partitions.
#df -h

if it is ok then check /tmp for gconfid-root permission should be 700 for it if is not then change for 700 after that check you /etc/X11/xorg.conf for any misconfiguration and then
after accomplish this type command like on prompt.

#startx ( for gui mode)

if it works that very good if problem is still persist then
past the error message as well as gdm.conf and xorg.conf from /etc/X11

Last edited by singhjc; 01-04-2012 at 06:24 AM.
 
Old 01-04-2012, 10:39 PM   #3
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
well my gdm was missing so dats y it was giving that error,but after installing it it is giving the following error:

GDM: Xserver not found: /usr/bin/Xorg/ : 0 -br 0 -auth /var/gdm/ : 0 . Xauth -n 0listen tcp v17
Error: Command could not be executed:
Please install the X server or correct GDM conf and restart GDM.

Well in the /etc/X11 directory,i don't have gdm.conf file and i did check gconfid-root but i didnt know wat was wrong..

and how to change the runlevel because inittab is missing in /etc directory....can u please help me to proceed from here...

Last edited by SarahGurung; 01-04-2012 at 10:51 PM.
 
Old 01-04-2012, 11:25 PM   #4
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
well Xorg package was missing...now i installed it so i am getting the GUI login now but the problem is when i login full display isnt there i.e i have firefox open on its own n dat too it's really small and a terminal is open as well...

rest of the options arent there...what could be missing?

Please help me it's really important for me..
 
Old 01-05-2012, 02:05 AM   #5
singhjc
Member
 
Registered: Nov 2010
Location: Moradabad
Distribution: Redhat,Centos
Posts: 31

Rep: Reputation: 1
Hi,


Are you able to login through ALT+CTRL+F1 if yes then check both file inittab and gdm.conf

if not present then arrange both files from any other same configuration system pendrive
because both are universal files and attached your pendrive to your system which is having issue and type the command like.

# fdisk -l for determine the pen drive device name it will be in fat extension and then mount it

# mount -t vfat /dev/sdc1 /mnt

device name can be changed here do accordingly and after that type the command like
# cd /mnt
# ls -l

if both files present here then type the command like

# cp inittab /etc
# cp gdm.conf /etc/X11/gdm
check both files are laying down in desire location check it one by one if yes then unmount your pendrive

#umount /mnt ....entr

ten reboot your system and check for the solution.

Last edited by singhjc; 01-05-2012 at 02:16 AM. Reason: as
 
Old 01-05-2012, 02:48 AM   #6
singhjc
Member
 
Registered: Nov 2010
Location: Moradabad
Distribution: Redhat,Centos
Posts: 31

Rep: Reputation: 1
if above technic doesn't work and system not getting boot then install Centos on any other system for temprarlly and arrange both files in to your pen drive and attached your pendrive to your system first which is having issue then boot your system with Centos cd it will provide you screen there you can type the command like
boot: linux rescue
loading vmlinuz...............................................
loading initrd.img............................................

choose language >> english .....>> choose keyboard >> us keyborad >> check media>> skip...
do you want networking >> no and after that it will provide you # prompt first of all determine / is mount on which device by blkid or e2label
# e2label /dev/sda1 one by one for search the root prtition /
when you got it then create a directoty

# mkdir /centos ...entr

# mount -t ext3 /dev/sda1 /centos ...entr
( for example we have to search and mount /device name on /centos directory)

after that check for pendrive device name as above and create another directory and mount the pen drive
#fdisk -l ( determine the pen drive device name)

#mkdir /abc
#mount -t vfat /dev/sdd1 /abc ...entr
#cd /abc
check both files and paste on by one

# cp inittab /centos/etc....enter
# cp gdm.conf /centos/etc/X11/gdm...entr

after that check both files and confirm that both files must be present in destination and that check
#pwd
/abc
#cd .. entr
#umount /abc

type

# exit..
it wiil go for reboot then check it again

thatnks &Regards
Singhjc

Last edited by singhjc; 01-05-2012 at 02:51 AM. Reason: a
 
Old 03-30-2012, 04:15 PM   #7
hokie1999
LQ Newbie
 
Registered: Feb 2011
Posts: 20

Rep: Reputation: 0
respawning issue

Hello, all, I'm running Oracle Enterprise Linux 5 4 on a HP Proliant BL 460C platform.

I have two servers: the good and the bad. They are 99 percent configured the same. Both run in run level 5. The problem with the bad server is I get a "INIT Id (X) respawning too fast message" on boot and it hangs there. A startx will fix this but I want x windows and the desktop to start on boot. It worked until last night. Don't know what changed. Processor utilization, memory, drive space are all low.

I noticed this on the good server

[zzcdill@good ]$ ps -ef | grep gdm
root 8000 1 0 Mar29 ? 00:00:00 /usr/sbin/gdm-binary -nodaemon
root 8100 8000 0 Mar29 ? 00:00:00 /usr/sbin/gdm-binary -nodaemon
root 8102 1 0 Mar29 ? 00:00:00 /usr/libexec/gdm-rh-security-token-helper
root 8103 8100 0 Mar29 tty7 00:00:00 /usr/bin/Xorg :0 -br -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
gdm 8147 8100 0 Mar29 ? 00:00:00 /usr/libexec/gdmgreeter


This is not present on the bad server. Both /etc/inittabs are identical (here's a critical entry: x:5:respawn:/etc/X11/prefdm -nodaemon ) as are /etc/X11/xorg.conf and the /etc/X11/prefdm script.

On both servers, there is no "/etc/init.d/gdm" but the package gdm-2.16.0-56.el5 is present on both and the binary /usr/sbin/gdm is present on both.

/var/log/messages notes the respawn but little else. /var/log/gdm/:0.. doesn't say much.

Any thoughts on where to go with this? How does gdm start if it's not a /etc/init.d service?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
INIT: Id "a02" Respawning too fast; disabled for 5 minutes specialblend Red Hat 4 03-29-2011 05:51 PM
host339384 init: Id "T1" respawning too fast: disabled for 5 minutes centosfan Linux - General 2 08-19-2009 06:06 PM
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 08:18 PM
FC7 with XEN : init: Id "x" respawning too fast: disabled for 5 minutes erikjan Fedora - Installation 0 07-11-2007 04:08 PM
INIT:Id "x" respawning too fast: disabled for 5 minutes problem satimis Red Hat 4 07-22-2004 07:03 AM


All times are GMT -5. The time now is 09:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration