LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-02-2004, 11:10 PM   #1
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Rep: Reputation: 15
INIT: Id "X" respawing too fast: disabled for 5 minutes


I got a problem. I did some update's and every thing went well but later that night the power went out and when it come on it boots up and says

INIT: Id "X" respawing too fast: disabled for 5 minutes

every 5 minutes it says the same thing. how do I run the X config again I can get to a command line. what is the command and where is it at.

I running Fedora core release 3 (Heidelberg) Kernel 2.6.9-1.681_FC3 on an i686

What should I do to get this fixed?
 
Old 12-03-2004, 12:07 AM   #2
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Try running "X -configure", that'll generate a config file for you... providing X is in your path, of course. If it isn't... I think it's usually in /usr/X11R6/bin

Hope this helps.
 
Old 12-03-2004, 06:03 PM   #3
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Original Poster
Rep: Reputation: 15
I tried using X -configure and it tried running and told me what lines in my /root/xorg.conf.new file to edit so i did. after that I run it again and it started up to a blank black screen.

I had to use the reset button to get out of it.

I have never had linux act like this over the power going out. What changed with this version?

I don't know what else to do!
 
Old 12-03-2004, 06:15 PM   #4
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Hmmmm... Are you sure it was the power going out and not the updates that is causing X to not work?

You might want to try copying your xorg.conf.new file over the old one (cp xorg.conf.new /etc/X11/xorg.conf) so that the respawning X will load it automatically. I'm not sure, but I'm thinking that maybe X isn't starting up properly (black screen) because you already have it running (the respawning process).

Also, if that was the case, "X -configure" might not have detected things properly... (I remember something similar happening to me at one time). So, if there's a way to do so, you may want to boot into a login shell instead of X as it might make troubleshooting / fixing the problem easier.

By the way, I'm not sure how unresponsive your computer was at the time of the latest crash, but usually, when X stops working properly, you can force it to exit (or in your case, restart) with Ctrl+Alt+Backspace without having to reboot your computer.
 
Old 12-03-2004, 09:36 PM   #5
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Original Poster
Rep: Reputation: 15
OK I edited my inittab file so my Box will boot in run level 3.
and I copied the /root/xorg.conf.new to /etc/X11/xorg.conf.new I also copted it to /X11/xorg.conf just in case.

when I run the command startx I get this error:

hostname unknown host

Xauth: error while loading shared libraries: libXmuu.so.1: cannot open shared object file: no such file or directory

Xauth: error while loading shared libraries: libXmuu.so.6:
cannot open shared object file: no such file or directory


What do I do now?
 
Old 12-03-2004, 09:47 PM   #6
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Try "locate libXmuu" and post the results. Run "updatedb" (as root) first, if necessary, to build the locate database.
 
Old 12-03-2004, 10:25 PM   #7
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Original Poster
Rep: Reputation: 15
/usr/X11R6/lib/libXmuu.so.1

I deleted xorg.conf and xorg.conf.new and run X -configure after that I had to edit the file /root/xorg.conf.new manualy when I was done I run X -config /root/xorg.conf.new and the screen went blank with a X for the mouse. The mouse can be moved around but Gnome never did load I also copied /root/xorg.conf.new to /etc/X11/xorg.conf but when I run startx I get the same error.

Last edited by aaronruss; 12-03-2004 at 10:27 PM.
 
Old 12-03-2004, 10:34 PM   #8
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
"X -config /root/xorg.conf.new" only runs the X server, it doesn't startup gnome. However, the fact that the X cursor comes up means that it's working fine. If you want to test it without overwriting your old file, try this:

/usr/X11R6/bin/xinit /usr/bin/gnome-session -- /usr/X11R6/bin/X -config /root/xorg.conf.new

Change the paths if yours are different.

That should run gnome after X starts up with your new config file.

EDIT: Corrections made.

Last edited by zhangmaike; 12-03-2004 at 10:39 PM.
 
Old 12-03-2004, 11:00 PM   #9
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Original Poster
Rep: Reputation: 15
I tried running /usr/X11R6/bin/xinit /usr/bin/gnome-session --

and got this error:

Xinit: error while loading shared libraries: libX11.so.6:
cannot open shared object file: no such file or directory

I located it at /usr/X11R6/lib/libX11.so.6

Remember I can only get X to come up now by running /usr/X11R6/bin/X -config /root/xorg.conf.new

startx gives errors:

Xauth: error while loading shared libraries: libXmuu.so.1: cannot open shared object file: no such file or directory

Xauth: error while loading shared libraries: libXmuu.so.6:
cannot open shared object file: no such file or directory
 
Old 12-03-2004, 11:16 PM   #10
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Hmmm... Since you have the library and X insists that it can't find it, maybe the path variable isn't set right? Try running:

echo $LD_LIBRARY_PATH

and post the result from that.
 
Old 12-03-2004, 11:32 PM   #11
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Original Poster
Rep: Reputation: 15
OK I used YUM to update from the command line and it updated a lot of xorg stuff xorg-lib was one of them.

after that I rebooted and my box come up in runlevel 5. I did not change it to that level I had it in 3 it change on its own after the updates. the splash screen come up showing the bar loading the box froze. I had to reset it and noticed the next time it froze the last thing loaded was

starting HAL daemon OK
after that it locked up

It does not give me an option for text mode. How can I get it back to runlevel 3 so I can get the info you asked for?
 
Old 12-03-2004, 11:41 PM   #12
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Now that X starts up by itself, the info I wanted is irrelevant - the libraries are apparently being loaded.

Unfortunately, at this point, I don't have any more advice to give since I do not use Fedora myself, I use Slackware.... so anything Fedora specific is alien to me.

If you want to get back into runlevel 3, you'll have to edit inittab like you did before. Since Fedora is locking up, you might need to use a boot disk to do that...

Perhaps you should post in the Fedora forum.

http://www.linuxquestions.org/questi...php?forumid=35

They can probably be of greater help.
 
Old 12-03-2004, 11:48 PM   #13
aaronruss
Member
 
Registered: Mar 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Thanks For all your help.
 
Old 12-04-2004, 07:49 AM   #14
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
With Fedora you can use the install CD to boot up in rescue mode. After ISOLINUX comes up and you get to the initial screen enter linux rescue at the boot prompt. It will then ask you for your language and search for your Linux installation. Once it finds the installation it will mount to /mnt/sysimage. The rescue mode then puts you into a shell. At this point you are running as root and have a stripped down version of linux where you can run several utilities, even rpm. This will allow you to change /mnt/sysimage/etc/inittab so the next time you boot it will go to the command line. While in rescue you can also chroot /mnt/sysimage /bin/bash to set your root directory to its normal place.

Now for the bad news, I made some updates to my RedHat 7.3 system a while back and ran into the same problem you did with the respawning too fast: disabled for 5 minutes. I also recall seeing the error on libXmuu.so.1. My upgrade was from glibc 2.2 to glibc 2.3 which involved about 7 packages. I did this because I wanted to upgrade another package which had dependencies on the newer version of glibc. Things were fine until I rebooted and X had issues.

These updates also had an effect on rpm causing it to segfault when I would execute an update or install. I tried using rescue mode to put the packages I had upgraded back to their original version. However, after endless googles and repair attempts I never did get things working again. As a final solution I ended up performing a reinstall. I seriously hope you have better luck than I did. Looking back I should have known better since any applications with ties to glibc 2.2 would end up malfunctioning without remorse.

Bill

Last edited by wmakowski; 12-04-2004 at 07:51 AM.
 
Old 12-04-2004, 03:22 PM   #15
fortezza
Member
 
Registered: Mar 2003
Location: Colorado
Distribution: Fedora Core 4
Posts: 297

Rep: Reputation: 30
I have this problem when I update the kernel via Yum but forget to reinstall the NVidia drivers before rebooting. Here are a few related tips:

After X is disabled for 5 minutes, you can login as root and reinstall NVidia Drivers to match your new kernel ( assuming this is the problem )

If you can not get to the command prompt in the default terminal, try pressing and holding <ctrl> and <alt> keys simultaneously, and then press and release the <f2> key. This will switch you to the second terminal session ( by default Fedora runs 6 terminal sessions, keys <F1>-<F6> , and maps the X Server started in each terminal to the terminal Function key Number + 6, so if you type "startx" in terminal 1, <ctrl>+<alt>+<F7> will switch you to that X Server window )

At the command line, as root, you can type "init 3" or "/sbin/init 3" to switch to run level 3. To make this the default runlevel, edit "/etc/inittab" file so that the default run level is 3.

If you want to change the graphics driver ( module ) XServer uses., you can edit ( for Xorg ) "/etc/X11/xorg.conf" driver section to change driver it loads. The generic Nvidia drive module name is "nv", which you have to manually change to read "nvidia" to us NVidia's closed source driver.



Hopefully some of this is useful, I do not know the cause of the problem, but if you use an Nvidia card, most like this will help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 07:18 PM
RH9 INIT: ID "x" respawning too fast: disabled for 5 minutes valimare Linux - Newbie 4 02-16-2007 04:53 AM
INIT: Id "x" respawing too fast: disabled for 5 minutes ukrainet Linux - Newbie 4 11-19-2004 11:33 PM
INIT: Id "x" respawning too fast: disabled for 5 minutes" Lego3 Linux - Software 0 06-16-2004 08:01 AM
"x" respawing to fast disabled for 5 minutes cookiemonster Linux - Software 1 06-10-2002 10:28 PM


All times are GMT -5. The time now is 04:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration