LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-17-2008, 11:05 AM   #16
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54

Let's try to confuse you further then. Boot normally without livecd and type this in a terminal:
sudo sed -i '/timeout/s/=/\ /' /boot/grub/grub.conf

Same thing for the default line would be:
sudo sed -i '/^default/s/=/\ /' /boot/grub/grub.conf

If you don't use sudo, become root first with "su -".
If you don't have sed, try to figure out which editor linpus uses for console. Try pico, editor, mcedit, vi, or type "apropos editor" to see what the system gives you.
 
Old 07-17-2008, 11:07 AM   #17
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
oh, but my external cdrom is not attached to my laptop and its also empty, is that possible not to have a menu.lst or grub.conf in my system?

Last edited by jundcb; 07-17-2008 at 11:09 AM.
 
Old 07-17-2008, 11:09 AM   #18
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Well, where did you find the stuff you pasted in your first post unless in grub.conf or menu.lst?
 
Old 07-17-2008, 11:31 AM   #19
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
oh yeah, getting confused already lol, well i have grub.conf since i can see it if i type

mkdir linpus
sudo mount -t ext3 /dev/hdc1 linpus
cat linpus/boot/grub/grub.conf

but i cant edit it
 
Old 07-17-2008, 11:47 AM   #20
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Still on the live-cd I take it.
Is the mounted partition actually writable. Type "mount" and see if there's an "rw" after the line.
If not, type "sudo mount -o remount,rw -t ext3 /dev/hdc1 linpus".
Then type/paste in: sudo sed -i '/timeout/s/=/\ /' linpus/boot/grub/grub.conf
Or check which editor the live-cd comes with. Try "editor" for starters.
 
Old 07-17-2008, 11:49 AM   #21
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
im not on the livecd, im doing this in linpus
 
Old 07-17-2008, 11:52 AM   #22
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Now I got confused by this then:
Quote:
Originally Posted by jundcb View Post
mkdir linpus
sudo mount -t ext3 /dev/hdc1 linpus
cat linpus/boot/grub/grub.conf
So, can you find an editor for the console?
 
Old 07-17-2008, 12:18 PM   #23
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
im just going to used the livecd, it'll save us all the trouble lol
 
Old 07-17-2008, 12:27 PM   #24
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
i removed the = from timeout but the boot menu is still at 4 seconds
 
Old 07-17-2008, 12:42 PM   #25
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Quote:
mkdir linpus
sudo mount -t ext3 /dev/hdc1 linpus
cat linpus/boot/grub/grub.conf
That means you may have an installation of linpus on /dev/hdc1.
But you are definitely not running that installation - from what you posted earlier.

You can edit /boot/grub/grub.conf on /dev/hdc1 as much as you like - as long as you are not booting from that partition it will be in vain.

How do you boot - how do you know what you boot.
How did you get your linpus installed?
I only have a copy of linpus.live and it does have no option to install it to hd.
 
Old 07-17-2008, 12:53 PM   #26
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
it was pre installed on my lappy when i got it, i made a partition then installed xp, after that i used supergrub to get my boot menu but couldnt get it to work so i had to manual install grub to get my boot menu
 
Old 07-17-2008, 01:23 PM   #27
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
...and how did you install grub?
From the output of "mount" one can only conclude that there is no harddrive mounted from which you are running your OS.
It looks exactly like the live cd.
One can see that /media/disk is the mountpoint for /dev/hdc2 - which could be your windows partition.

...which is not an easy thing to do - windows is difficult to install on anything other than the first partition of the first drive.
/dev/hdc is indicating that the drive is the secondary master AFAIK
Where is your primary master ( /dev/hda )?

From a live-cd I'd check which partition is which...
fdisk -l
and check the boot order in the BIOS

very confusing - you need a structured approach starting with the very simple
 
Old 07-17-2008, 02:16 PM   #28
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
sudo grub
root (hd0,0)
setup (hd0)
quit

thats what i used for the manual install

i also booted from a livecd, went to applications-accessories opened a terminal and typed fdisk -l but nothing happens


i booted in linpus and typed fdisk -l

Disk /dev/hdc: 40.0 GB, 40000536576 bytes
255 heads, 63 sectors/track, 4863 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 2432 19535008+ 83 Linux
/dev/hdc2 2433 4863 19527007+ c W95 FAT32 (LBA)

Last edited by jundcb; 07-17-2008 at 02:43 PM.
 
Old 07-17-2008, 02:56 PM   #29
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
also used supergrub and saw that my linux is hda1 and windows hda2
 
Old 07-17-2008, 03:08 PM   #30
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Let's see grub.conf again then. While having normally booted into the hd install paste here output of "cat /boot/grub/grub.conf". And don't mount anything, just type the command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i want to increase system boot time adam_blackice Fedora 4 09-10-2006 05:22 PM
Fresh Install Of Distr From Network - Boot Menu, Need to pull up a menu of OS dist to SupermanInNY Linux - Distributions 0 01-22-2006 12:48 PM
XP/Fedora dual boot timeout alaneh Fedora 2 08-08-2005 10:17 PM
change the timeout on boot billb Linux - General 7 12-25-2004 10:40 PM
Increase boot times: have hotplug run in background? r_jensen11 Slackware 4 09-18-2004 08:33 AM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration