LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-16-2008, 02:51 PM   #1
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Rep: Reputation: 15
increase timeout value boot menu


hi, im a newbie in linux and im trying to increase the timeout value in my boot menu but cant seem to get it, im running a dual boot of linpus linux and winxp. heres what ive done

booted using livecd and then opening a terminal and typed

mkdir linpus
sudo mount -t ext3 /dev/hdc1 linpus
sudo nano linpus/boot/grub/grub.conf

default=0
timeout=10
splashimage=(hd0,0) /boot/grub/splash.xpm.gz
#hiddenmenu

title linpus linux lite
rootnoverify (hd0,0)
kernel /boot/bzimage changes=/dev/hdc1 root=/dev/ram0 rw max_loop=255 init=linuxrc selinux=0 vga=0x311 splash=silent quiet loglevel=1 console=tty1 load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=14000 from=/dev/hdc1 acpi=force ide0=noprobe ide2=noprobe ide3=noprobe lang=en
initrd /boot/initrd.gz

title linpus linux lite(rescue)
rootnoverify (hd0,0)
kernel /boot/bzimage changes=/dev/hdc1 root=/dev/ram0 rw max_loop=255 init=linuxrc selinux=0 vga=0x311 splash=silent quiet loglevel=1 console=tty1 load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=14000 from=/dev/hdc1 acpi=force ide0=noprobe ide2=noprobe ide3=noprobe lang=en
initrd /boot/initrd.gz

title windows os
rootnoverify (hd0,1)
chainloader +1

ive tried adding a # before the timeout, as i understand this will disable the timeouts but it still boots after 4 seconds

ive changed the timeout value to 30 and 900 but it still gives me only 4 seconds before booting to linpus

as of now the timeout value is at 10 but it still boots after 4 seconds

am i doing it right? any other solutions? ty
 
Old 07-16-2008, 02:57 PM   #2
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
Linpus uses KDE. In your control center, there should be an option to edit the boot manager.
 
Old 07-16-2008, 03:24 PM   #3
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
:~$grep timeout /boot/grub/menu.lst|grep -v "#"
timeout 10

There is no "=" between the word timeout and the number.
 
Old 07-16-2008, 03:27 PM   #4
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
grub configuration file's named /boot/grub/menu.lst, and you're able to edit it from your linpus installation, without a booting in live-cd.
 
Old 07-16-2008, 03:37 PM   #5
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Since he has already edited the configuration file, one would think he knows what it's called.
Alas, good point about the not needed live-cd.
 
Old 07-16-2008, 03:56 PM   #6
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
i dont really know what im doing, someone just taught me that from another forum and from googling it. so i dont know what its called. someone told me that i dont have a menu.lst and i have a grub.conf instead. i'll try to remove the =
 
Old 07-16-2008, 07:56 PM   #7
shridhar005
Member
 
Registered: Jul 2008
Posts: 90

Rep: Reputation: 17
Login as root .Then edit the grub file as
Quote:
/etc/grub/grub.conf
.
from here change the time value,.
 
Old 07-17-2008, 02:28 AM   #8
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Another way to confuse jundcb further... It's /boot/grub/grub.conf.
 
Old 07-17-2008, 02:43 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
I might not change the /etc/grub.conf file. It is a link to /boot/grub/grub.conf and it is always better to change the file directly than through the link.
 
Old 07-17-2008, 08:57 AM   #10
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
how do u edit the installation inside linpus?

ive tried

sudo nano /boot/grub/grub.conf
su
nano /boot/grub/grub.conf

but it tells me command not found

tried

alt+f2 kdesu kate /boot/grub/grub.conf and kdesu mousepad /boot/grub/grub.conf

it says command failed to run
failed to execute child process "kdesu" (no such file or directory)

also tried

gksu mousepad /boot/grub/grub.conf

tells me that using that command gives me root user privileges without the need for a password due to my systems setup, after closing that box nothing happens, i tried checking the box do not show this message again after that when i typed gksu mousepad /boot/grub/grub.conf nothing happens
 
Old 07-17-2008, 09:32 AM   #11
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
I'd recommend going the same way you already walked - boot the live cd and do the same as you did before to edit that file.
Not the most elegant - but you know how you did it...

There is no "=" in the "default" nor in the "timeout" statements (...should not be...).
default 0
timeout 30
 
Old 07-17-2008, 09:35 AM   #12
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
thx jomen, i was hoping to do it inside linpus so that i can learn some more about linux
 
Old 07-17-2008, 09:46 AM   #13
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
mount
ls -al /boot
ls -al /boot/grub

you should see the file grub.conf (or: menu.lst) - if not then I don't know furter - if you do:

vi /boot/grub/grub.conf

(hit "i" to get to edit mode - hit escape followed by :wq to save the file)

sudo mousepad should work too
 
Old 07-17-2008, 10:18 AM   #14
jundcb
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Original Poster
Rep: Reputation: 15
this is what i got

[linpus@LINPUS ~]$ mount
tmpfs on / type tmpfs (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hdc2 on /media/disk type vfat (rw,noexec,nosuid,nodev,utf8,shortname=winnt,uid=500)
[linpus@LINPUS ~]$ ls -al /boot
total 84
drwxr-xr-x 9 root root 4096 Jul 12 20:05 .
drwxr-xr-x 44 root root 4096 Jul 17 17:36 ..
drwxr-xr-x 2 root root 4096 Apr 18 07:13 .base
drwxr-xr-x 4 root root 4096 Jun 3 07:54 boot
drwxr-xr-x 14 root root 4096 Jul 17 17:36 changes
-r--r--r-- 1 root root 704 Mar 21 04:46 COPYRIGHT
drwxrwxrwt 6 linpus linpus 4096 Jul 12 21:01 data
-rw-r--r-- 1 root root 17992 Jul 23 2007 GPL
drwxr-xr-x 7 root root 4096 Jun 3 08:01 images
-rw-r--r-- 1 root root 389 Jul 23 2007 LICENSE
-rw-r--r-- 1 root root 243 Jul 23 2007 livecd.sgn
drwx------ 2 root root 16384 Jun 3 07:52 lost+found
drwxr-xr-x 2 root root 4096 Apr 10 23:50 manual
-rw-r--r-- 1 root root 232 Mar 21 05:01 README
-rw-rw-rw- 1 root root 0 Apr 18 07:13 .update.log

[linpus@LINPUS ~]$ ls -al /boot/grub
ls: /boot/grub: No such file or directory
 
Old 07-17-2008, 10:50 AM   #15
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
What you have booted up here is the live-cd - not an installation on hd.
Attempting to change grub's config there is pointless and impossible.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i want to increase system boot time adam_blackice Fedora 4 09-10-2006 05:22 PM
Fresh Install Of Distr From Network - Boot Menu, Need to pull up a menu of OS dist to SupermanInNY Linux - Distributions 0 01-22-2006 12:48 PM
XP/Fedora dual boot timeout alaneh Fedora 2 08-08-2005 10:17 PM
change the timeout on boot billb Linux - General 7 12-25-2004 10:40 PM
Increase boot times: have hotplug run in background? r_jensen11 Slackware 4 09-18-2004 08:33 AM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration