LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2009, 09:36 PM   #1
joseph2020
Member
 
Registered: Mar 2009
Location: USA
Distribution: Ubuntu 12.04
Posts: 235

Rep: Reputation: Disabled
inconsistent dialup issues


I'll try to make this as brief as possible, but want to include all pertinent info. I am trying to use an old external serial 56k motorola modem. I have tried many different (and different version numbers) linuxes and my modem is usually not found.

I use ppp and when using ubuntu 5.1 or Freespire the modem is found and I can dial out normally. Everything else i've tried...fedora, knoppix, suse, ubuntu (later versions), kubuntu, mepis cannot find the modem.

Suse 11 finds the modem, dials and everything seems fine, the modem shows as being online, but I cant go to any websites, keep getting a cant find address error.

...aside from Ubuntu 5.1 I have pretty much stuck with KDE distros as KPPP is easy to set up for dialup modems, and is included with every distro I have seen.

Right now I am using freespire 2 and it works well, but i would rather be using the latest suse or fedora.

I have seen that the modem is seen as /dev/ttyS0 when it is found. The ones that don't work it does not matter what I change the port to. its always modem not found.

as a last resort is there any console commands I can try to install modems? Or to find out if it is seen? Its very confusing why it works on the old ubuntu but not the latest ones. and why it works with Linspire but not other KDE distros.

Any help would be appreciated. Sorry for the extreme length of this message/question.

Thank You
 
Old 03-30-2009, 09:49 PM   #2
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
I hope you got wvdial, not every distro provides this. You can use wvdialconf to first configure and find your modem then edit your /etc/wvdial.conf and later running wvdial. or you can make symlink with your already known serial port.
Code:
ln -s /dev/ttyS0 /dev/modem
then runs KPPP as usual. Don't forget to query modem first.
 
Old 03-30-2009, 10:14 PM   #3
joseph2020
Member
 
Registered: Mar 2009
Location: USA
Distribution: Ubuntu 12.04
Posts: 235

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hurry_hui View Post
I hope you got wvdial, not every distro provides this. You can use wvdialconf to first configure and find your modem then edit your /etc/wvdial.conf and later running wvdial. or you can make symlink with your already known serial port.
Code:
ln -s /dev/ttyS0 /dev/modem
then runs KPPP as usual. Don't forget to query modem first.
I am using freespire right now and the wvdialconf command doesn't work at all:

joe@joehome:~$ wvdialconf
bash: wvdialconf: command not found
joe@joehome:~$

thanks for your help
 
Old 03-31-2009, 12:58 AM   #4
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
You should have root access or sudo to run wvdialconf. You also need to become root to create symlink.
 
Old 04-01-2009, 02:15 AM   #5
joseph2020
Member
 
Registered: Mar 2009
Location: USA
Distribution: Ubuntu 12.04
Posts: 235

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hurry_hui View Post
You should have root access or sudo to run wvdialconf. You also need to become root to create symlink.
Ok...thanks again! tried that, same results.


I am using the root account.

root@joehome:~# wvdialconf
-su: wvdialconf: command not found
root@joehome:~#

thanks again for your help! any help or idea always appreciated.
joe
 
Old 04-01-2009, 05:40 AM   #6
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Just forget wvdial now. Please, run this first as a root by typing at prompt:
Code:
#ln -s /dev/ttyS0 /dev/modem
. then check by running:
Code:
#file /dev/modem
.
 
Old 04-02-2009, 01:59 AM   #7
joseph2020
Member
 
Registered: Mar 2009
Location: USA
Distribution: Ubuntu 12.04
Posts: 235

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hurry_hui View Post
Just forget wvdial now. Please, run this first as a root by typing at prompt:
Code:
#ln -s /dev/ttyS0 /dev/modem
. then check by running:
Code:
#file /dev/modem
.
root@joehome:~# ln -s /dev/ttyS0 /dev/modem
root@joehome:~# file /dev/modem
/dev/modem: symbolic link to `/dev/ttyS0'
root@joehome:~#

what next?

Thanks again for your help.

Last edited by joseph2020; 04-02-2009 at 02:17 AM.
 
Old 04-02-2009, 03:31 AM   #8
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
There is no need to softlink /dev/ttyS0 to /dev/modem, /dev/ttyS0 is an available port in kppp and is also seen by wvdial (which needs to be installed to avoid the "command not found" error).

In kppp, click 'configure', on the 'Accounts' tab click 'new', click 'manual setup', put your ISP's name in the connection name field, then click 'add', put in the ISP's phone number and click 'OK'. Now click on the Modems tab and click 'new', on the 'Device' tab give your modem a name in the Modem name field, hit the drop down menu for Modem device and select /dev/ttyS0, leave the rest on this tab as is. Now hit the Modem tab, then the Modem commands button, you'll notice the 'initialization string 2:' field is empty, kppp does not work without a init2 string, copy and paste this string: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0, this is the string wvdial uses by default. Click 'OK' and then click the 'Query modem' button, it should say "looking for modem, modem found or similar" and a progress bar showing kppp is running tests on the modem.
If it said it found the modem, click OK a few times to bring you back to the connection window where you input login ID and password and hit connect.
 
Old 04-03-2009, 03:04 AM   #9
joseph2020
Member
 
Registered: Mar 2009
Location: USA
Distribution: Ubuntu 12.04
Posts: 235

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Junior Hacker View Post
There is no need to softlink /dev/ttyS0 to /dev/modem, /dev/ttyS0 is an available port in kppp and is also seen by wvdial (which needs to be installed to avoid the "command not found" error).

In kppp, click 'configure', on the 'Accounts' tab click 'new', click 'manual setup', put your ISP's name in the connection name field, then click 'add', put in the ISP's phone number and click 'OK'. Now click on the Modems tab and click 'new', on the 'Device' tab give your modem a name in the Modem name field, hit the drop down menu for Modem device and select /dev/ttyS0, leave the rest on this tab as is. Now hit the Modem tab, then the Modem commands button, you'll notice the 'initialization string 2:' field is empty, kppp does not work without a init2 string, copy and paste this string: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0, this is the string wvdial uses by default. Click 'OK' and then click the 'Query modem' button, it should say "looking for modem, modem found or similar" and a progress bar showing kppp is running tests on the modem.
If it said it found the modem, click OK a few times to bring you back to the connection window where you input login ID and password and hit connect.
Thanks! tried it and modem is now seen, dials out, everything seems fine...modem sounds and lights all good but cannot access internet....browsers dont work.

I tried with Fedora, K/ubuntu, and Mepis...seeing the modem now, thanks to your help...still using freespire which works reliably every time, but wishing for something visually and functionally better.

Thanks again
 
Old 04-04-2009, 12:21 AM   #10
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Well,
Sounds like your modem is ready to go.

Not entirely sure about Fedora, if memory serves me correctly, Mepis is based on Ubuntu. And again, if memory serves me correctly, I could not access internet with Ubuntu until I allowed my user to do so. Ubuntu...I feel is designed for families with exploratory children, as such, the children are not allowed to get in trouble till papa allows it.

You may want to go through System/Administration/Authorizations in Ubuntu to see what a normal user is not allowed to do and make necessary changes if you have administrative rights. Even after going though the authorizations thing I still could not get online, it wasn't till I went to System/Administration/Users and Groups, highlighted my user and click 'Unlock', then click on Properties/User Privileges and put a check in the box next to 'Connect to internet using a modem' and 'Use Modems'. And another thing with Ubuntu and Debian with Gnome, I kept getting an "Offline" error in Firefox when trying to go somewhere, had to go to the File menu and remove the check mark next to 'Work Offline'.

Now...
The damn memory thing...
I remember having to highlight my user in the left window, and clicking 'Add' to have my user name appear in the right window, something to do with exceptions, or allow. Problem is, I have a ton of different operating systems and I keep thinking this was in Ubuntu, but as I write this I'm going through the menus in a Ubuntu virtual machine and can't find anything of the sort, and I've got a virtual Mandriva running also and can't find it there, checked Debian on my laptop, etc. etc. etc.

Sooooo....
I have a feeling, you now just have to go through settings as admin in your distributions before the user(s) can access the internet.
 
Old 04-04-2009, 01:55 AM   #11
joseph2020
Member
 
Registered: Mar 2009
Location: USA
Distribution: Ubuntu 12.04
Posts: 235

Original Poster
Rep: Reputation: Disabled
thanks much for the info Jr.H...but this part I don't understand

Now...
The damn memory thing...
I remember having to highlight my user in the left window, and clicking 'Add' to have my user name appear in the right window, something to do with exceptions, or allow. Problem is, I have a ton of different operating systems and I keep thinking this was in Ubuntu, but as I write this I'm going through the menus in a Ubuntu virtual machine and can't find anything of the sort, and I've got a virtual Mandriva running also and can't find it there, checked Debian on my laptop, etc. etc. etc.
__________

Had a very very bad day today, not in the mood to mess with the modem tonight. I'll experiment some more and post later.

thanks much for your help again
 
Old 04-04-2009, 03:25 AM   #12
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
OK
You forced me to investigate further.
I vaguely remember being well restricted and could not do many things till I added my user to the "Allowed Users" box. Turns out it was parental controls in Mandriva One, so...disregard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpsenSUSE 11.1 ppp dialup issues RivenJ Linux - Newbie 1 02-22-2009 07:52 PM
Pidgin - inconsistent behaviour since last week's msn issues.... mrclisdue Linux - Software 1 01-24-2009 12:50 AM
Dialup connection issues Opt1mus Linux - Newbie 7 10-16-2004 04:04 AM
ICS issues with dialup under Mandrake 10 LynxofCP Linux - Networking 0 05-16-2004 01:14 AM
Mandrake update - annoyinf issues for dialup Asificare Mandriva 3 08-25-2003 03:07 AM


All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration