LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2009, 03:30 AM   #1
08CP022
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Rep: Reputation: 0
IN opensuse 11.1, how to install using yast?


When i try to install something directly from internet, like wyne or anything else, the yast runs and the process continues but then a error comes which says that it cannot access the software manager or software repository and i have no other option left but to quit. how to solve this. Is it related with 'root user'? Because i am the root user and there are some folders which do not open and ask for the root user permissions.
 
Old 03-23-2009, 04:53 AM   #2
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Rep: Reputation: 15
Quote:
Is it related with 'root user'? Because i am the root user and there are some folders which do not open and ask for the root user permissions.
I dont think so. You need root permission to run yast. you said that u are able to run it.

Quote:
error comes which says that it cannot access the software manager or software repository
I get this type of error when there is problem with net connection.Have you properly configured all repositories ? Can you post exactly word-by-word what the error message says ?

try this. open terminal. enter su. then the root password. when the prompt changes something like "root@---#" enter the following command

zypper install wine

and cut and paste the results of the above command with your next post.

Last edited by ps_sabu; 03-23-2009 at 04:59 AM.
 
Old 03-23-2009, 05:21 AM   #3
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
It might be and most probably is that the repos that you're using are currently unavailable.You can try to use different repositories/mirrors.
 
Old 03-25-2009, 06:50 AM   #4
08CP022
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I am able to access YAST when I enter my root password but when the YAST runs itself when i try to install a program using repository, the error comes. It says that the software repositories/software manager is protected with some ........app no. such as 8772 etc. and then I am left with no other option but to quit. Can you give me the exact process to install something like WYNE in my opensuse 11.1?

Thanks!!

Last edited by 08CP022; 03-25-2009 at 07:00 AM.
 
Old 03-26-2009, 04:18 AM   #5
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Why don't you use KSysGuard or top or something and see what's that app/s which are blocking Yast to work properly because I guess that number (8772) is a PID (most likely).
 
Old 03-26-2009, 08:41 AM   #6
08CP022
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
yes that file is PID. but i can't see that app on ksysguard. do you have any other options because it will only be possible when that app stops protecting/blocking yast.
 
Old 03-26-2009, 10:15 AM   #7
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Ok,run;
Code:
ps aux
Post the output.Also,post all PIDs that you see in error message when you run Yast.
Or run;
Code:
ps aux | grep 8772
If you use second command,run it for any other PID that might be blocking Yast,if necessary.
 
Old 03-26-2009, 02:25 PM   #8
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Rep: Reputation: 15
I suggest that you run yast and when the error message comes note down the PID of the process that blocks access to repos.

Then, if for example the above pid is 4456 yourun,

Code:
kill -9 4456
Now the blocking process willbe killed.

Now start yast and I hope everything will go smoothly from here on.

Last edited by ps_sabu; 03-26-2009 at 02:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OPenSUSE Yast repositories? craigevil SUSE / openSUSE 104 12-27-2010 10:08 AM
Cannot Access YAST in openSUSE 11.0 deepgrewal SUSE / openSUSE 9 10-20-2008 02:23 AM
OpenSuse YAST AUGGGGH!! Mufasa Linux - Software 7 08-04-2008 02:54 AM
YaST & openSuse 10.2 sadiqdm SUSE / openSUSE 3 05-20-2008 07:45 AM
How to install a second(third) printer in opensuse 10.0 using yast? csilviu SUSE / openSUSE 2 09-29-2006 12:39 PM


All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration