LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2011, 08:03 PM   #1
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Rep: Reputation: Disabled
imac powerpc g3 screen goes black during boot


Hi folks,

Sorry, I know this is probably covered somewhere in another post, in fact I did find posts about the same problem.
This is my first post, so bear with me.

I just installed debian with the graphical desktop on an imac g3 400 mhz 128MB RAM everything worked great until I rebooted after the install of the graphical desktop, I let it do it's thing and right after screen turns white with black text about yaboot, then a flash of color and poof screen goes dead. I saw a thread about fixing this problem, but I cant seem to get any other prompt than "boot:". How can I make the system boot in base system only upon start up? and from there what should I do? the thread I found was quite old and may be out of date, I'm not sure. I have been an Apple user all my life starting with Apple II Plus to present Mac, so this is really frustrating for a pop down menu junkie!

I remember in the other thread about reconfiguring x-server or something like that, it is obviously not detecting or setting my monitor correctly.

Any help will be greatly appreciated, and THANK YOU in advance!
 
Old 10-11-2011, 10:13 PM   #2
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Here is how you do it when Grub is your boot loader:

At the grub boot menu press the E key. Next select the distro you want to boot and press the E key again. Now select the line with "kernel /boot/vmlinuz" and hit the E key one more time. Now type a space and the number 3 at the end of that line, so for example from:

QUOTE
kernel /boot/vmlinuz-2.6.17 ro root=/dev/hda6
to
QUOTE
kernel /boot/vmlinuz-2.6.17 ro root=/dev/hda6 3


Finally press the B key and your distro will boot in runlevel 3

Assuming you are using Grub.

Then run Xorg -configure

Last edited by AuroraZero; 10-11-2011 at 10:15 PM. Reason: added a debian command
 
1 members found this post helpful.
Old 10-11-2011, 11:56 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Once again, in Debian the runlevels 2-5 are the same and the default runlevel is 2.
Use AuroraZero's advice to boot in runlevel 1, then apply this fix.
 
1 members found this post helpful.
Old 10-12-2011, 12:04 AM   #4
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
Smile

[QUOTE=AuroraZero;4496038]Here is how you do it when Grub is your boot loader:

At the grub boot menu press the E key. Next select the distro you want to boot and press the E key again. Now select the line with "kernel /boot/vmlinuz" and hit the E key one more time. Now type a space and the number 3 at the end of that line, so for example from:

QUOTE
kernel /boot/vmlinuz-2.6.17 ro root=/dev/hda6
to
QUOTE
kernel /boot/vmlinuz-2.6.17 ro root=/dev/hda6 3


Finally press the B key and your distro will boot in runlevel 3

Assuming you are using Grub.

AuroraZero, Thank you so much for your reply and so quickly too, I must be crazy that I left out it seems to say on startup that Grub cannot be used with my machine architecture or something like that, anyway, kernel is debian 2.6.32-5PPC , and it says boot loader is Yaboot v1.1.13.


I am gonna try what you said anyway if I can and see what happens, but if you have other advice on Yaboot and such I am all ears and eyes

THANK YOU SO MUCH!

Last edited by NK9sBoo; 10-12-2011 at 11:25 AM.
 
Old 10-12-2011, 01:14 AM   #5
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Once again, in Debian the runlevels 2-5 are the same and the default runlevel is 2.
Use AuroraZero's advice to boot in runlevel 1, then apply this fix.
OK You guys are awesome, that is exactly what I need, but can you tell me how to set runlevel 1 for Debian using Yaboot v1.3.13? Also, I was able to get a prompt in BusyBox v1.17.1 by booting from the my iso cd and backing out before selecting language and then starting a shell, can get a prompt and it says user = root but when I give command "cd" and enter "/etc" on next prompt line, it says Permission Denied. You seem like you know your stuff so if you wouldn't mind giving me the Yaboot solution I would be forever grateful! And if I can ever do anything for you, just say the word.

THANKS AGAIN!
 
Old 10-12-2011, 01:36 PM   #6
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Type linux -b at the yaboot prompt.
 
1 members found this post helpful.
Old 10-12-2011, 04:09 PM   #7
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
Talking New Problem

Quote:
Originally Posted by AuroraZero View Post
Type linux -b at the yaboot prompt.
New Problem:

That works as you said. Now I have "Give root password for maintenance" and then under that, "(or type Control-D to continue):" then blinking cursor. However my keyboard won't work, so now I am where I want to be, can see what I am doing, but can't do anything about it. LOL!

I see it found my Apple Extended USB Keyboard
Manufacturer: Mitsumi Electric
and chose # 1 of 1 script or, sorry the screen just went black again, but I was where you said I would be, anyway, any ideas about why the keyboard won't work in runlevel 1 or how to fix without being able to enter any typing?

Should I try buying a generic usb keyboard? It is seeing and powering the keyboard and mouse because it says so, and the optical mouse lights up, and I tried with the mouse disconnected just in case but still the same.

THANK YOU SO MUCH AGAIN FOR ALL OF YOUR HELP!
AND THANK YOU IN ADVANCE FOR YOUR FURTHER HELP!

Last edited by NK9sBoo; 10-12-2011 at 04:28 PM.
 
Old 10-12-2011, 04:42 PM   #8
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Try unplugging it and replugging it in after you hit run level 1. I am researching to find more but that is one solution that worked for someone else.
 
Old 10-12-2011, 06:58 PM   #9
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
I'll try that again because......

Quote:
Originally Posted by AuroraZero View Post
Try unplugging it and replugging it in after you hit run level 1. I am researching to find more but that is one solution that worked for someone else.
Hi AuroraZero,

Thank You for that tip, I tried it one time and it re-recognized the keyboard, but still nothing, I will try it a few times in a row now though to see if that does it, because I did notice that sometimes I have to type in Linux -b twice for it to boot the kernel so maybe a little repeating will help.

THANKS AGAIN, You are awesome!

Let me know if you hear of any other fixes for this, I am also constantly searching in google and the forums, but I don't always have much luck, so you are my lifeline right now, but not to worry if we tweak things wrong, this is my learning machine so I can always re-install, but the software that comes to me via internet for additional software after the base system, does use a lot of my Wildblue 30 day rolling FAP limit but if I have to, I can just wait a week or two to re-do. Hopefully it won't come to that, I think my install went ok, but one can never be 100% sure.

THANKS IN ADVANCE FOR YOUR FURTHER HELP!
 
Old 10-12-2011, 07:05 PM   #10
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
What keyboard did you select when you installed? Was it qwerty/mac-usb-us? If not and if you can get it to do it try dpkg-reconfigure console-data and select that keyboard. I am thinking it auto detected the wrong one by default.
 
Old 10-12-2011, 07:35 PM   #11
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AuroraZero View Post
What keyboard did you select when you installed? Was it qwerty/mac-usb-us? If not and if you can get it to do it try dpkg-reconfigure console-data and select that keyboard. I am thinking it auto detected the wrong one by default.
I selected English > U.S. English, debian did the rest automatically,there were no other options except British English and several other languages, it works in all other modes that I have been able to use, but not in runlevel1, however, I should probably mention that this is a keyboard from an iMac G5, but I have had no issues with it up to this point, I did try unplugging and plugging it back in several times and no luck except that it recognizes the new USB device each time as "Apple Extended USB Keyboard" it just won't do anything, funny huh? If you know how I can change that setup without using my keyboard or being able to see what I'm doing,those are my two choices, unless I can do it from the base install iso cd, monitor and keyboard both work at the same time in there. I'll try anything once, or as many times as it takes to get it right.

Thanks Again AuroraZero!

Be looking forward to your next reply!
 
Old 10-12-2011, 07:42 PM   #12
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Can you boot up the cd/dvd get into the console. Then switch to the hard drive and run the reconfigure? I am wondering if that would reconfigure the hard drives console or the discs. The machine is recognizing the keyboard which is a good thing but the console now needs to be configured to use it.

I have found anther way but it is a long process and involves editing the initramfs. Let me know if this does not work and I shall post it for you.

Last edited by AuroraZero; 10-12-2011 at 07:47 PM.
 
1 members found this post helpful.
Old 10-12-2011, 08:23 PM   #13
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
I will try, Do you know how to........

Quote:
Originally Posted by AuroraZero View Post
Can you boot up the cd/dvd get into the console. Then switch to the hard drive and run the reconfigure? I am wondering if that would reconfigure the hard drives console or the discs. The machine is recognizing the keyboard which is a good thing but the console now needs to be configured to use it.

I have found anther way but it is a long process and involves editing the initramfs. Let me know if this does not work and I shall post it for you.
I will try that, I was trying to fix the monitor issue that way before and kept getting "Permission denied" even though it also said "user=root" I imagine you are on the right track about if it might reconfigure the cd rather than the hard drive and that is why it denies permission, because you can't make changes to the cd? Is there a command I should use in the console from the cd to get into the hard drive and make changes? Either way, you have been so helpful, I don't know how I would ever be able to, but if I can ever do anything to help you, you can count on it.

I was also wondering what you think about me trying a "generic" usb keyboard? I can always buy one from Best Buy and take it back if it doesn't work, only drawback to that is, I live in the boonies and closest Best Buy is about 60 miles away, I do get close to there often though since that is also near where I get groceries. Anyway TMI? sorry for rambling on.

Thanks Again And, as always I will look forward to your next reply.

THANK YOU AuroraZero!
NK9sBoo
 
Old 10-12-2011, 08:44 PM   #14
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
You are correct you can not edit the cd's files and that is why the permission denied error shows up. I think what we will have to do is edit the initramfs and make the usb keyboard work from boot time. I don't think it is going to make any difference what keyboard you use. I think the system is recognizing the keyboard as it should it just is not configuring it correctly. So it will still see the keyboard but I am betting it will not set up a new one the right way either.

Let's give this a try and see if it works. Does not look to hard to implement so hopefully it works out for you.

The initramfs-tools must include the usbhid module and its dependencies for USB keyboard support at boot time. Either the configuration file /etc/initramfs-tools/conf.d/driver-policy must include most modules, or they will have to be specified in another file:

Code:
#
# MODULES: [ most | netboot | dep | list ]
#
# most - Add most filesystem and all harddrive drivers.
#
# dep - Try and guess which modules to load.
#
# netboot - Add the base modules, network modules, but skip block devices.
#
# list - Only include modules from the 'additional modules' list
#

MODULES=most
If the configuration above was not set to include most modules then the necessary modules have to be specified in the file /etc/initramfs-tools/modules:
Code:
 # USB keyboard at boot
usbcore
uhci_hcd
ehci_hcd
usbhid
Apply changes.

Code:
# update-initramfs -u
The last part of this is what concerns me. When you run it try switching to the hard drive. eg: cd /mnt/hda (or whatever drive designation the hd is). I am hoping that will update the hd's initramfs instead of trying to update the cd/dvd's.

You are most welcome for the help. As I said before I am not the most knowledgeable in the Debian sector. I run mostly Slackware but I like to learn and this is teaching me things as well as you. So it is a win win for the both of us.
 
Old 10-12-2011, 10:44 PM   #15
NK9sBoo
LQ Newbie
 
Registered: Oct 2011
Location: Big Sur, CA
Distribution: MintPPC 9.3
Posts: 24

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AuroraZero View Post
You are correct you can not edit the cd's files and that is why the permission denied error shows up. I think what we will have to do is edit the initramfs and make the usb keyboard work from boot time. I don't think it is going to make any difference what keyboard you use. I think the system is recognizing the keyboard as it should it just is not configuring it correctly. So it will still see the keyboard but I am betting it will not set up a new one the right way either.

Let's give this a try and see if it works. Does not look to hard to implement so hopefully it works out for you.

The initramfs-tools must include the usbhid module and its dependencies for USB keyboard support at boot time. Either the configuration file /etc/initramfs-tools/conf.d/driver-policy must include most modules, or they will have to be specified in another file:

Code:
#
# MODULES: [ most | netboot | dep | list ]
#
# most - Add most filesystem and all harddrive drivers.
#
# dep - Try and guess which modules to load.
#
# netboot - Add the base modules, network modules, but skip block devices.
#
# list - Only include modules from the 'additional modules' list
#

MODULES=most
If the configuration above was not set to include most modules then the necessary modules have to be specified in the file /etc/initramfs-tools/modules:
Code:
 # USB keyboard at boot
usbcore
uhci_hcd
ehci_hcd
usbhid
Apply changes.

Code:
# update-initramfs -u
The last part of this is what concerns me. When you run it try switching to the hard drive. eg: cd /mnt/hda (or whatever drive designation the hd is). I am hoping that will update the hd's initramfs instead of trying to update the cd/dvd's.

You are most welcome for the help. As I said before I am not the most knowledgeable in the Debian sector. I run mostly Slackware but I like to learn and this is teaching me things as well as you. So it is a win win for the both of us.

Hi Again, ok so I have keyboard working and am logged in as root, This is how: I booted up to Yaboot and then put in CD and then I booted Linux -b. Now I have tried to put in "/etc/X11/xorg.conf" many times and it says: "no such file or directory" also tried "cd" then "/etc" I get "bash:/etc is a directory" I'm thinking maybe the monitor fix for my version might be a little different somehow? But I am not finding much info. I will also let you know if I can boot up and log in as root without the CD even being in the slot, just thought I should clarify I did not boot from CD just had it in the slot while working.


If you have any ideas I will try them.

And once again, THANK YOU AuroraZero!
I'll be looking forward to your next reply
NK9sBoo

Last edited by NK9sBoo; 10-13-2011 at 11:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer A0A 110 has a black screen during boot up along with a black cursor sw3etpinay Linux - Newbie 23 12-29-2010 12:05 PM
Debian Lenny + Nvidia Quadro FX 380 LP -> black screen on iMac 27" siriri Linux - Hardware 1 01-26-2010 07:19 AM
Unsure how to install Linux on PowerPC iMac with broken optical drive hiyaubuntu Linux - Newbie 8 06-04-2009 08:00 PM
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
Ubuntu 6.06 -> Debian Sarge, using debootstrap on PowerPC (iMac G3) RavenOfOdin Debian 5 07-22-2006 06:26 PM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration