LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2009, 07:49 PM   #1
DJYin
LQ Newbie
 
Registered: May 2009
Posts: 3

Rep: Reputation: 0
Im using Slackware Linux and cannot find a monitor resolution calibration function


Hi, I've recently purchased a new monitor for my cpu that runs on Slackware linux. Now, I've hooked everything up fine, the monitor displays everything right, however, I get a very annoying error message that pops up every 40 seconds stating the following:

"Incorrect optimum mode. The optimum resolution of this monitor is as follows....." and yeah. Normally, if I was using Windows, this wouldnt be a problem as I would simple go to control panel > Display > and then adjust accordingly. However, this Slackware linux has no such option to adjust monitor resolution.

Any help or ideas? Keep in mind that I am an ABSOLUTE noob when it comes to Linux. Im not even absolutely sure my linux is called "Slackware," that's just the title when it boots up with all that white writing on the blackscreen.

Thankyou in advance.
 
Old 05-30-2009, 09:16 PM   #2
digerati1338
Member
 
Registered: May 2007
Location: CO
Distribution: Ubuntu
Posts: 152
Blog Entries: 1

Rep: Reputation: 18
Let me start by saying that Slackware is a very good linux distribution, but is notoriously difficult for beginners. Many advanced users like it because of its somewhat old fashioned manual configuration as opposed to the GUIs on distributions like Ubuntu. With that being said, it's up to you if you want to use slackware or switch to a simpler distribution such as Ubuntu, PCLinuxOS, or something similar. You can obtain any of these for free by downloading and burning the CD image.

To change your display configuration in slackware you will need to modify the file /etc/X11/xorg.conf. This is a text configuration file that tells your computer how to use the monitor and keyboard. You can google for xorg.conf and find plenty of tutorials for monitor configuration. It is relatively simple acutally. You just need to change or add to the correct sections with the specs for your monitor. Good luck.
 
Old 05-31-2009, 04:53 AM   #3
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Please let us know which videocard and which monitor you're using.

As suggested, you need to modify the xorg.conf. Important sections are the sections 'Device', 'Monitor' and 'Screen'.
Please post those if you need more assistance.

Assuming that you use the correct video driver (and configuration in the section 'Device'), it might be as easy as modifying the 'Screen' section and adding another mode in the subsection 'Display'

Code:
Modes "1280x960" "1024x768"
This will tell the video driver to use one of those modes (first one has preference)
 
Old 05-31-2009, 12:56 PM   #4
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,614

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
DJYin:

It seems you are using an Acer monitor with an nVidia card. I have had that experience too.

If you don't know how to manually configure the /etc/X11/xorg.conf file to fit your needed resolution you can do it through a GUI.

Slackware 12.2 runs two windowing managers, KDE and Xfce. Under KDE there is no problem, this windowing manager offers a lot of tweaking tools, just click Menu > System > Settings and choose Display, there you are offered with resolution choices.

Under Xfce click Menu > Settings > Display, the same choices are offered.

Or you may post your xorg.conf entries here for everyone to help you how to manually do it.

Finally, if nothing is critical to use Slackware, as advised by digerati1338 above, I would recommend you install an easier distro. You may also try Linux Mint, this is very easy and user friendly, you can download their latest release here http://ftp.heanet.ie/pub/linuxmint.c...-Universal.iso, burn the image and install.

Hope this helps.

Goodluck.
 
Old 05-31-2009, 01:47 PM   #5
AGer
Member
 
Registered: Oct 2007
Distribution: Slackware current
Posts: 136
Blog Entries: 22

Rep: Reputation: 19
Sometimes the problem just goes away if you install a proprietary driver for your card.
 
Old 05-31-2009, 03:17 PM   #6
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
The easiest way is to 'su' into root and run 'xorgsetup' when Xorg is not started (so before running 'startx'). This usually configures it the best. If not, you can try 'xorgconfig'. And if you're running KDE, there's an option within the window manager options.

@ digerati1338
@ malekmustaq

I can't count the number of times a Slackware user posts in the newbie section of LQ and gets told:

"Slackware is hard, install Ubuntu."

Will you stop it please, I'm sick of it. To install another distro is not the easiest solution to this problem, although to you it probably seems to be. Do you see me going around telling Ubuntu users to use Slackware as a solution to all the problems they experience with Ubuntu (which I must say are a lot more, and are more difficult to fix).

Last edited by H_TeXMeX_H; 05-31-2009 at 03:19 PM.
 
Old 06-01-2009, 01:30 AM   #7
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I agree, H_TeXMeX_H. I had similar sentiments but decided not to react. It seems to become a trend nowadays.

And thanks for pointing to 'xorgconfig'; I always forget about it.
 
Old 06-01-2009, 07:35 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Quote:
Originally Posted by malekmustaq View Post
It seems you are using an Acer monitor with an nVidia card. I have had that experience too.
I'm using an Acer monitor, nVidia card, and Slackware. No problems whatsoever getting the optimum resolution. I just ran xorgsetup at runlevel 3.
 
Old 06-01-2009, 08:37 AM   #9
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,614

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
H_TexMeX_H:

Yes xorgsetup is easier, more automated. Sorry I forgot this solution.

Re: your sentiment:

Q--""Slackware is hard, install Ubuntu."
Will you stop it please, I'm sick of it. To install another distro is not the easiest solution to this problem, although to you it probably seems to be. Do you see me going around telling Ubuntu users to use Slackware as a solution to all the problems they experience with Ubuntu (which I must say are a lot more, and are more difficult to fix)."

Comment:

At least as far as I am concerned "there is no malice" to my recommendation. I am compelled to offer it out of authentic motive to "make the newbie's INITIAL EXPERIENCE ON LINUX EASIER and less discouraging. We cannot help, this is the law of nature concerning intelligence and adaptability: in order to learn faster the new comer must begin with such things that he can easily comprehend, control and enjoy doing it. It is not infrequent to find newbie posts exploding out in frustration emoting their language at difficulties handling Linux, to this I have the honest concern to minimize as much as I can help it.

There is no argument needed to show the fact that Slackware is more difficult for newbies than Ubuntu and its flavor Mint. This is a universal knowledge that requires no affidavit to prove its truth. I don't feel any amount of guilt telling this truth to a newbie.

Nothing against Ubuntu. Even until now I maintain a unit running nothing but Ubuntu and Mint. I love Ubuntu and from this distro I learned Linux.

Yes I don't see you going around... and I don't go-around too, (in fact I only serve one Linux forum) telling Ubuntu users to switch Slackware (what for?). This is not my style. I am not that cheap minded for all you know. I am an old man. All that I want is just to HELP others for free because I feel I am indebted to Linux community.

My children are using Ubuntu, Mint, Fedora, Debian, RHL, Solaris. Only one of them followed my suit in Slackware as main stay. I am not a bigot nor an idiot.

I hope you can grant this old man the feeling of vindication or that of exoneration.

Thank you for the moment.
 
Old 06-01-2009, 08:37 AM   #10
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,614

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
doubled sori must be dleted

Last edited by malekmustaq; 06-01-2009 at 08:51 AM.
 
Old 06-01-2009, 04:09 PM   #11
DJYin
LQ Newbie
 
Registered: May 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Wow, incredible, you guys are geniuses! I'm sorry that I was unable to give you guys a clearer description, but even with my vague details, you guys were able to figure out the solution! Thanks so much to those who provided advice. In particular, thanks H TexMex H, I followed your solution of running su and xorgconfig into root, worked perfectly. Thankyou guys again!
 
Old 06-01-2009, 04:15 PM   #12
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Sure thing, you might also want to browse through the slackbook, link in my sig, it has useful info, including the solution I gave.
 
Old 06-01-2009, 05:48 PM   #13
DJYin
LQ Newbie
 
Registered: May 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Curious, Tex, I have another "problem." I've had Slackware for awhile now, and its great and all, but whenever I start it up and first enter the desktop, it makes a very annoying noise, it's that Road Runner "Beep Beep." It's absolutely dreadful and annoying, is there any way to disable this? Thankyou.
 
Old 06-02-2009, 05:07 AM   #14
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Is it playing on the speakers or on the PC piezo buzzer inside the case ? If on the speakers it's probably something within KDE, so look through the settings (I don't use KDE). It may be some type of startup sound.

If it's the buzzer, then edit '/etc/rc.d/rc.modules' using a text editor as root, so 'su' into root then use any text editor, if you're on the console you can just use 'nano /etc/rc.d/rc.modules' and comment out (put # in front of) the pcspkr line, so change:

Code:
# Enable PC speaker support:
/sbin/modprobe pcspkr
to

Code:
# Enable PC speaker support:
#/sbin/modprobe pcspkr
and save 'Ctrl O'. 'Ctrl X' to exit. Next time you boot it will take effect.

Last edited by H_TeXMeX_H; 06-02-2009 at 05:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
? boot ubuntu with (monitor) flatronL1719S off and find resolution correct; /etc/X11/ blesbok Linux - Hardware 7 11-18-2008 04:22 AM
Monitor calibration under Linux merchtemeagle Linux - Hardware 1 05-13-2008 08:56 AM
Monitor calibration (color temperature) seanr Linux - Software 5 02-20-2006 10:00 AM
Ubuntu, monitor color calibration? mipia Linux - Distributions 2 09-01-2005 02:46 PM
monitor calibration rosscopeeko Linux - Software 1 06-02-2004 09:21 AM


All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration