LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2010, 04:22 AM   #1
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Rep: Reputation: 0
Ignoring unknown interface eth0=eth0


I want to edit my hosts file, so I.
sudo gedit /etc/hosts
I saved, and reset the network by
sudo /etc/init.d/networking restart

but got output of:

* Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.

and hosts file doesn't work for me.
What's wrong? How to solve it.

I am using ubuntu 10.10 now.
 
Old 11-05-2010, 05:10 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
The hosts file has nothing to do with your interfaces. Does your network connection work properly?

I don't understand what you mean by
Quote:
and hosts file doesn't work for me.
What exactly are you trying to do?
jdk
 
Old 11-05-2010, 06:54 AM   #3
ddaemonunics
Member
 
Registered: May 2008
Location: Romania
Distribution: Debian
Posts: 242

Rep: Reputation: 41
please post ifconfig -a output
 
Old 11-05-2010, 08:16 AM   #4
Skaperen
Senior Member
 
Registered: May 2009
Location: WV, USA
Distribution: Slackware, Ubuntu, Amazon Linux
Posts: 1,830
Blog Entries: 21

Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by ddaemonunics View Post
please post ifconfig -a output
And the contents of the /etc/network/interfaces file.
 
Old 11-05-2010, 07:50 PM   #5
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
The hosts file has nothing to do with your interfaces. Does your network connection work properly?

I don't understand what you mean by
What exactly are you trying to do?
jdk

I am trying to visit website like www.dropbox.com but it can not be reached directly here.
I need to use dropbox software directly not by proxy.

Hope I make it clear

Last edited by wznjsy; 11-05-2010 at 07:56 PM.
 
Old 11-05-2010, 07:52 PM   #6
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ddaemonunics View Post
please post ifconfig -a output

eth0 Link encap:以太网 硬件地址 00:1e:c9:03:f7:28
inet 地址:166.166.166.52 广播:166.166.166.255 掩码:255.255.255.0
inet6 地址: fe80::21e:c9ff:fe03:f728/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:2557 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:2175 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:2567248 (2.5 MB) 发送字节:348324 (348.3 KB)
中断:17

lo Link encap:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 跃点数:1
接收数据包:540 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:540 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:42040 (42.0 KB) 发送字节:42040 (42.0 KB)

vboxnet0 Link encap:以太网 硬件地址 0a:00:27:00:00:00
BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)

wlan0 Link encap:以太网 硬件地址 00:1f:3c:3b:35:8f
inet6 地址: fe80::21f:3cff:fe3b:358f/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:255946 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:188599 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:226361532 (226.3 MB) 发送字节:21760555 (21.7 MB)

I got this.
 
Old 11-05-2010, 07:54 PM   #7
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Skaperen View Post
And the contents of the /etc/network/interfaces file.
auto lo
iface lo inet loopback
 
Old 11-06-2010, 12:08 AM   #8
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by wznjsy View Post
I am trying to visit website like www.dropbox.com but it can not be reached directly here.
I need to use dropbox software directly not by proxy.

Hope I make it clear
Not really. Why do you want to reedit your hosts file? I don't see any connection between that and anything else you're talking about.

Do you have a working internet connection? Your problem seems to be about just one website and not the entire web. Is this correct?
jdk
 
Old 11-06-2010, 12:55 AM   #9
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
Not really. Why do you want to reedit your hosts file? I don't see any connection between that and anything else you're talking about.

Do you have a working internet connection? Your problem seems to be about just one website and not the entire web. Is this correct?
jdk

Website like dropbox, facebook can not be visited directly. Possible solutions known by users in China, is to to edit hosts file, and most of them has done that.
But it did not work for me right now.
 
Old 11-06-2010, 01:04 AM   #10
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Sorry, I really don't know what you're talking about. What exactly are you supposed to do with your host file and what does that have to do with your interfaces?
jdk
 
Old 11-06-2010, 01:04 AM   #11
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
abc

Last edited by jdkaye; 11-06-2010 at 02:33 AM. Reason: removed duplicate post
 
Old 11-06-2010, 01:21 AM   #12
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
Sorry, I really don't know what you're talking about. What exactly are you supposed to do with your host file and what does that have to do with your interfaces?
jdk
Sorry to trouble you.
What I am try to is to let my dropbox software to be able to visit dropbox website directly by editing my /etc/hosts file.
Because, in China, the great firewall forbids users to visit this website.
 
Old 11-06-2010, 02:35 AM   #13
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Yes, you said that already but I still don't see how editing your hosts file will solve this. Why don't you use an anonymiser website like anonymouse? And what does all this have to do with your interfaces issue? You still are not being clear.
jdk
 
Old 11-06-2010, 03:33 AM   #14
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,576
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Quote:
Originally Posted by wznjsy View Post
Because, in China, the great firewall forbids users to visit this website.
If the firewall works by blocking IP addresses (normal choice) then changing the hosts file will not help.

If the firewall is preventing DNS resolution (strange choice) then changing the hosts file will help.
 
Old 11-06-2010, 03:38 AM   #15
wznjsy
LQ Newbie
 
Registered: Nov 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
Yes, you said that already but I still don't see how editing your hosts file will solve this. Why don't you use an anonymiser website like anonymouse? And what does all this have to do with your interfaces issue? You still are not being clear.
jdk
Thanks for your message.
Edit host file will enable users to visit websites directly, China visitors use this way for a long time.
I am fresh man of linux,especially to ubuntu. When I try to edit hosts file like others, but did not succeed to visit those websites like others.

I konw there is some poxy like anonymouse.org can help to visit, but I just want to visit that website directly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0: Device eth0 has different MAC address than expected,ignoring. lin1010 Linux - Networking 5 11-24-2010 07:30 AM
Eth0 : unknown interface mcpoon Linux - Newbie 1 07-13-2009 04:17 AM
915gavl--eth0: unknown interface: No such device dgermann Linux - Networking 1 06-25-2005 04:05 PM
Bringing up interface eth0 Delaying eth0 initialization. [ FA bansal_ashok Linux - Networking 4 05-27-2005 10:09 AM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 05:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration