LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-02-2013, 10:30 AM   #1
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Rep: Reputation: Disabled
ibus does not work well if i login as user account


In Slackware 14.0, login as root, install ibus, pyxdg, ibus-qt, ibus-table and mm-kb.tgz (keyboard for myanmar/burmese language). input method work fine. everything ok. then create user account and login back as user. ibus run at start up. but ibus preference > input method is empty.
so restart computer, login as root again, ibus works perfect.

the problem is that ibus does not work well if i login as user account.

what is solution? anybody, please...
 
Old 04-04-2013, 07:53 AM   #2
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 185

Rep: Reputation: Disabled
Logging into X as root is bad idea, don't do it.

Quote:
but ibus preference > input method is empty.
So i'm assuming IBus itself starts properly and you have the icon in your systray - in user account.

A: If the 'Input Method' window is blank, it means you haven't configured methods for this particular user.
B: If the 'Select an input method' menu on the top is blank, it means IBus can't see input methods you installed. How did you install the ibus-table? MAKE INSTALL or via src2pkg?


It might be an access rights problem, too.

(Perhaps try to install ibus-anthy slackbuild, relogin (anthy is in the default Slack install, if you don't have it, get it). Can you see japanese input?)
 
Old 04-04-2013, 10:31 AM   #3
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
I installed ibus-anthy slackbuild, i can see japanese input and it work as user login.

You are right, it might be an access rights problem.

I have tested ibus-tables using src2pkg.
Those ibus-tables I installed are
ibus-table-1.3.0 (root-ok) (user-no)
ibus-table-1.3.9 (root-ok) (user-no)
ibus-table-1.4.99 (root-ok) (user-no)
ibus-table-1.5.0 (did not work at all)

Quote:
you haven't configured methods for this particular user.
BTW, do I need configure methods for particular user. I don't know that.
How to do that.
I think, that is solution.
 
Old 04-04-2013, 12:07 PM   #4
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 185

Rep: Reputation: Disabled
Quote:
I installed ibus-anthy slackbuild, i can see japanese input and it work as user login.
So i'm assuming the only problem is getting those burmese tables running under user account.


Quote:
How to do that.
I think, that is solution.
Well, i don't think, honestly. What i meant by that is just 'select your method from the menu and put it in your Input Method window', something you already must have done by trying the other methods. I put it there just for the completionist's sake, to be sure we both talk about the same thing.

Quote:
You are right, it might be an access rights problem.
I played with that right now - those tables don't have to be even readable and my IBus happily uses them.

I have seriously no idea where is the problem..


Could you post the output of "less /var/log/packages/ibus-table*" ?
Which Myanmar tables do you use? Can you give me the DL link?
 
Old 04-04-2013, 09:11 PM   #5
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
output is
Quote:
PACKAGE NAME: ibus-table-1.3.0.20100621-i486-1
COMPRESSED PACKAGE SIZE: 260K
UNCOMPRESSED PACKAGE SIZE: 1.0M
PACKAGE LOCATION: ibus-table-1.3.0.20100621-i486-1.txz
PACKAGE DESCRIPTION:
ibus-table: ibus-table
ibus-table:
ibus-table: No description was given for this package.
ibus-table:
ibus-table:
ibus-table:
ibus-table:
ibus-table:
ibus-table:
ibus-table:
ibus-table: Packaged by src2pkg
FILE LIST:
./
install/
install/doinst.sh
install/slack-desc
usr/
usr/libexec/
/var/log/packages/ibus-table-1.3.0.20100621-i486-1 lines 1-23/103 15%
 
Old 04-04-2013, 09:26 PM   #6
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
I downloaded ibus-myanmar.tar.gz and ibus-table-burmese_0.1_all.deb from

and installed (used src2pkg to install .deb). but both of them don't work.

the one working as root login is mm-kb.tgz. check here
that file is origianally .deb file which is running on my ubuntu with ibus.
i converted it .deb to .tgz using deb2pkg.
 
Old 04-05-2013, 04:10 AM   #7
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 185

Rep: Reputation: Disabled
That output isn't complete.

Your ibus-myanmar.tar.gz is the same as mine.

Forget about any .deb, use scr2pkg to compile source tarballs. Actually i think it might be the source of the problem.

Try to install this one
http://code.google.com/p/ibus/downlo...ar.gz&can=2&q=
src2pkg it and installpkg it.
 
Old 04-05-2013, 05:25 AM   #8
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
Okkkk...
ibus is working perfectly and happily.

i remove mm-kb.tgz and ibus-tables i previously installed.

then, as u said, i installed ibus-table.1.3.9 using src2pkg and installpkg.
and i simply extract ibus-myanmar.tar.gz because i can not compil it by src2pkg.
actually that file contains only 2 .db files and 2 .svg files.
so i copy them to ibus-table's tables and icons directories.

now everything is working on my slackware machine.

ခင္ဗ်ား ကုိ အရမ္း ေက်းဇူးတင္ပါတယ္...
it mean that "thank u so so much"

btw, how did u compile ibus-myanmar.tar.gz by using src2pkg.
 
Old 04-05-2013, 06:19 AM   #9
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 185

Rep: Reputation: Disabled
Glad i could help, now i can go and grab my very first "Problem solved" badge! :^D

Quote:
btw, how did u compile ibus-myanmar.tar.gz by using src2pkg.
It isn't a package, just ordinary tarball. I unpacked it same way as you did.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] SSH - How can I only allow a key pair login for my user account not root account? shanekelly Linux - Security 5 01-25-2013 09:45 AM
How do I check a user account to see when the last login was? jdcsyoung Linux - General 2 02-11-2008 01:26 PM
can't login as user account tchoua Mandriva 23 02-23-2005 02:49 PM
Force user login with different account rte Linux - Newbie 1 04-01-2004 09:09 AM
can't login to regular user account luchobucho Linux - General 2 10-27-2003 05:11 AM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration