LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-13-2003, 03:51 PM   #1
MizuChi
LQ Newbie
 
Registered: Dec 2003
Location: Japan
Distribution: Mepis Linux
Posts: 9

Rep: Reputation: 0
Question i810_audio.. not nvaudio?


i`m just confused, the drivers that nvidia made had a driver called nvaudio.. but when i ran the soundcard detection thing, it says that my soundcard is an i810_audio.. i did a little bit of googling around and found out that it`s the same as AC97 codec and i read somewhere that installing intel`s chipset drivers for i810 will fix problems.. the good news is, i got the volume control online, but the bad news is, it dont seem to work.. no sound..

the question is, how do i get the sound to work? i heard about ALSA and i`ve tried it, and that didnt seem to work.. is there any irq settings or dma and stuff that i need to set before installing the drivers? i have an NF7-S Rev2.0 (nForce2 mobo) with soundstorm.. but with linux, i guess u can rule out the soundstorm thing..

please guide me step by step as i am a real newbie at linux.. i am using redhat 9.0.. still new i guess..

any help is appreciated..
 
Old 12-13-2003, 03:59 PM   #2
goldennuggets
Member
 
Registered: Feb 2003
Location: Ohio, USA
Distribution: Slackware
Posts: 151

Rep: Reputation: 15
nvidia has very good help on getting your sound to work. I currently have an nforce card, with the nvaudio drivers running on slack.
Just goto http://www.nvidia.com/object/linux.html
They'll have what you need there. Basically what your needing to do is insert the nvaudio modules into the system. Then have them inserted at load time. I can't remember the actuall steps at the moment, if you can't get it going, post again and i'll look up the readme file.
 
Old 12-13-2003, 04:51 PM   #3
MizuChi
LQ Newbie
 
Registered: Dec 2003
Location: Japan
Distribution: Mepis Linux
Posts: 9

Original Poster
Rep: Reputation: 0
yes.. i did exactly as was written in the manual.. but still no go.. i just think that it might be some sort of irq or dma problem.. but i`m still a noob.. i dont know much about linux systems..

can you tell me in detail as to what i am to do?

this is what i get if i try to install the module for nvaudio

[root@localhost nvaudio]# insmod nvaudio
Using /lib/modules/2.4.20-8/kernel/drivers/sound/nvaudio.o
/lib/modules/2.4.20-8/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec_R84601c2b
/lib/modules/2.4.20-8/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate_R5307368c
/lib/modules/2.4.20-8/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate_R42924aaa

i renamed the i810_audio module on purpose so that i might be able to subsitute that module with another one.. unfortunately it didnt seem to work..

Last edited by MizuChi; 12-13-2003 at 05:15 PM.
 
Old 12-13-2003, 11:19 PM   #4
MizuChi
LQ Newbie
 
Registered: Dec 2003
Location: Japan
Distribution: Mepis Linux
Posts: 9

Original Poster
Rep: Reputation: 0
*bump*
 
Old 12-16-2003, 10:18 PM   #5
MizuChi
LQ Newbie
 
Registered: Dec 2003
Location: Japan
Distribution: Mepis Linux
Posts: 9

Original Poster
Rep: Reputation: 0
anyone?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvaudio problems in Slack 9.1 FlatZ28 Slackware 5 01-12-2004 06:17 AM
nvaudio modules not installing. hamish Red Hat 2 12-16-2003 10:28 PM
Need help with nvnet nvaudio xiojqwnko Slackware 2 12-08-2003 12:30 PM
can`t load nvaudio module poweroff Linux - General 8 11-18-2003 06:16 PM
nvaudio not working right mindcry Linux - Software 1 09-15-2003 06:07 AM


All times are GMT -5. The time now is 08:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration