LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-17-2006, 03:30 PM   #1
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Rep: Reputation: 0
I updated, now kde won't start


Hi,
I installed some updates and rebooted, and now I am stuck in a command screen. I tried to use startkde and kde and a few other cpmmands, and it just tells me stuff like "xset: unable to open display" "Aborting. $Display is not set" "No Such File or Directory" "Can't contact Kdeinit!" "Can't connect to server" "Running shutdown scripts"

Any idea on what is wrong?

I am using Suse 10.0, the install was downloaded from the novell site and burned on 5 cds.

Thanks for any help
 
Old 01-17-2006, 03:55 PM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 47
What did you update? It sounds like your just booting into runlevel 3 instead of 4 or 5. And some of the error messages sound like you've su'ed to root before trying to start kde. That won't work without some extra parameters.

Try this: As your user, not root and not su'ed, issue the command startx. If that doesn't work use Midnight Commander (type mc on the commandline) and view your /home/<current username>/.xinitrc file. It should have just one line that reads

startkde

Other stuff can be in there but this is the only line required to start a kde session.
 
Old 01-17-2006, 04:40 PM   #3
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
The only part in the xinitrc file that says startkde is "windowmanager=/usr/X11R6/bin/startkde

What do I do now?

Also, I think I saw runlevel 5 before the command said login.

Last edited by Ian18; 01-17-2006 at 04:43 PM.
 
Old 01-17-2006, 05:17 PM   #4
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 47
Hmmm...based on the new information you've given and the previous error messages I have two ideas (unless someone else can offer more):

1. Try creating the $DISPLAY environment variable before starting X

set DISPLAY=0:0

2. It might be an X configuration problem such as an incorrect video driver. Check the graphics device section of /etc/X11R6/Xorg.conf. Yours might be different because of the distro but it should be close.

Last edited by dracolich; 01-17-2006 at 05:19 PM.
 
Old 01-17-2006, 05:49 PM   #5
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Here is exactly what I happens when I type startkde

Ian@linux:/startkde
xset: unable to open display
xset: unable to open display
xsetroot: unable to open display
Startkde: Starting up...
Kdeinit: Aborting. Display is not set
Warning: Connect () Failed: No such file or directory
Ksmserver: Cannot connect to X server
Error: Couldn't attach to DCOP server!
Startkde: Shutting down...
Warning: Connect () Failed: No such file or directory
Error: Can't connect kdeinit!
Unix_connect: Can't connect to server (Linux:/tmp/ksocket-Ian/linux.site-lbcd-43797866)
Startkde: Running shutdown scripts
Startkde: Done

Last edited by Ian18; 01-17-2006 at 05:51 PM.
 
Old 01-17-2006, 06:46 PM   #6
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Can we see any errors from Xorg.0.log? Did you update xorg as well? This looks like xorg rather than kde problem.
 
Old 01-17-2006, 06:56 PM   #7
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
It was some updates from the update watcher.
 
Old 01-19-2006, 02:20 PM   #8
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
I still need some help on this. Has anyone had a similar problem? All I did was install some updates from the update watcher, and now kde won't run.

I appreciate any and all help

Note: I found this, but do you know how to uninstall it?
http://www.linuxquestions.org/questi...d.php?t=128486

Last edited by Ian18; 01-19-2006 at 02:41 PM.
 
Old 01-19-2006, 03:52 PM   #9
dbogdan
Member
 
Registered: Feb 2005
Location: Metro Detroit, US
Distribution: Suse/Slackware/Mepis
Posts: 174

Rep: Reputation: 31
Do you happen to have an NVidia video chipset and official nvidia drivers ?

I've been bit in the past installing kernel updates with the official nvidia driver.... something to do with mis-matched versions.

If this is you're case, try reinstalling the ndivia driver and rerun sax2 per the nvidia install documentation.


heck, even if you don't have the nvidia chipset, try re-running
sax2


cheers.
 
Old 01-19-2006, 04:32 PM   #10
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
How do I run sax2 in the command screen? If not that, then how do I switch that driver back to the previous driver from the command screen?

Thanks for the help so far
 
Old 01-19-2006, 09:50 PM   #11
dbogdan
Member
 
Registered: Feb 2005
Location: Metro Detroit, US
Distribution: Suse/Slackware/Mepis
Posts: 174

Rep: Reputation: 31
You need to run sax2 before Xwindow (Xwindow is the GUI basically) starts, this is simple for you since X is broken and won't start.


As root (using su or sudo) simply type sax2 and hit enter, this will help you reconfigure the X environment.

typing man sax2 and pressing enter will give you a bit more detail...

are you running an nvidia chipset ?
 
Old 01-20-2006, 01:56 PM   #12
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
It wants me to switch to run level 3, how do I do that?
 
Old 01-20-2006, 02:38 PM   #13
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
The Failsafe got me to runlevel 3. I am in Sax2, now what?


Update: I got out of sax2, and tried Startx. It worked!!!

Thank you all for your help

Before I reboot in regularly, do I need to change anything?

Update 2: It locked up (as it sometimes does, for reasons I don't know), but it booted up fine.

Any idea on how to stop it from randomly locking up? Would upgrading to kde 3.5 (from 3.4) or upgrading the kernel from default (2.6.13) to 2.6.15 help?

Last edited by Ian18; 01-20-2006 at 03:23 PM.
 
Old 01-22-2006, 03:25 PM   #14
dbogdan
Member
 
Registered: Feb 2005
Location: Metro Detroit, US
Distribution: Suse/Slackware/Mepis
Posts: 174

Rep: Reputation: 31
Hmm,

You first need to find out why it's locking up.... lockups are -usually- hardware related but not always..

Forgot about needing to be at init3, sorry bout that. For future reference, you can type init3 in the boot options line (after pressing F2 at the initial SuSE boot prompt) to boot into init3, ot you can, as root, type init3 at a shell to get you there if already in X)


Anyway, start looking at your log files... as always, with Linux there's more than one way to accomplish thing... In Yast you can use the system log viewer... launch Yast, choose Miscellanous, then choose View System Log. You can choose the different logs at the top.

Start viewing those to see if there are any glaring problems then post the error message(s) that seem relevent.

Also take a look at you're .xsession-errors file in your home dir... notice the '.' at teh beginning of the file....

Dave.
 
Old 01-22-2006, 10:30 PM   #15
Ian18
LQ Newbie
 
Registered: May 2005
Posts: 14

Original Poster
Rep: Reputation: 0
I am not sure what a problem would look like in the logs. Do you know of a site that has a list of things to look for?

Edit: Here is what I found so far (in the messages section of the system log).

Dec 25 15:49:38 linux kernel: uhci_hcd 0000:00:08.0: host system error, PCI problems?
Dec 25 15:49:38 linux kernel: uhci_hcd 0000:00:08.0: host controller process error, something bad happened!
------------------
Dec 25 15:49:43 linux kernel: powernow: This module only works with AMD K7 CPUs
Dec 25 15:49:43 linux rcpowersaved: CPU frequency scaling is not supported by your processor.
Dec 25 15:49:43 linux rcpowersaved: enter 'CPUFREQD_MODULE=off' in /etc/sysconfig/powersave/cpufreq to avoid this warning.
Dec 25 15:49:43 linux rcpowersaved: Cannot load cpufreq governors - No cpufreq driver available
Dec 25 15:49:43 linux [powersave]: ERROR (CPUFreq_Kernel:21) Can not set ondemand governor, maybe your cpufreq driver is too slow.
Dec 25 15:49:43 linux [powersave]: ERROR (CPUFreq_Kernel:23) Try CPUFREQ_CONTROL=userspace in /etc/sysconfig/powersave/cpufreq.
Dec 25 15:49:43 linux [powersave]: ERROR (PM_Interface:231) Cannot create cpufreq objects
Dec 25 15:49:43 linux SuSEfirewall2: Warning: ip6tables does not support state matching. Extended IPv6 support disabled.
---------------------------
Dec 25 15:49:52 linux modprobe: FATAL: Error inserting sonypi (/lib/modules/2.6.13-15-default/kernel/drivers/char/sonypi.ko): No such device
-------------------------------
Dec 26 00:08:53 linux kernel: ehci_hcd 0000:00:08.2: startup error -19

Last edited by Ian18; 01-22-2006 at 10:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When will knoppix be updated with kde 3.5.0? maximalred Debian 2 12-18-2005 01:16 PM
Updated libpng, now existing GTK prog won't start anymore - Rh9 rylan76 Linux - Software 1 05-12-2005 02:06 PM
updated Kernel via Redhat's up2date; now X won't start Daninchina Linux - Newbie 9 02-01-2005 01:52 AM
Should it be updated. KDE 3.1.4 -> 3.2.2 ? GATTACA Slackware 7 05-20-2004 04:24 PM
updated kde now can't start x h00ligan Linux - Software 6 03-09-2004 09:39 AM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration