LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2007, 04:54 AM   #1
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Rep: Reputation: 21
Exclamation I think I completely broke my system :D


Hello,

The distro is (was ) Debian.

Was just tinkering around with my system, when some package (belocs-locales-data I think it was) was having a cry about dependencies. apt-get said I should try "apt-get -f install" to fix the problem. And so I did. It said something along the lines of "Be careful, don't delete these unless you know what you are doing." Type "Yes, do as I say!" to continue.

And so I did. It removed a bunch of packages, and now my system is competely broken. Nothing works - ls, clear, wget, ssh, nothing.

Trying to install ssh results in this:

Code:
 root@testsrv ~ $ apt-get install ssh
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  belocs-locales-bin: Depends: belocs-locales-data but it is not going to be installed
  coreutils: PreDepends: libselinux1 (>= 1.32) but it is not going to be installed
  debianutils: PreDepends: mktemp but it is not going to be installed
  gcc: Depends: gcc-4.1 (>= 4.1.1-2) but it is not going to be installed
  iptables: Depends: libselinux1 (>= 1.32) but it is not going to be installed
  libdevmapper1.02: Depends: libselinux1 (>= 1.30) but it is not going to be installed
                    Depends: libsepol1 (>= 1.12) but it is not going to be installed
  libpam-modules: Depends: libselinux1 (>= 1.30.28) but it is not going to be installed
  ssh: Depends: openssh-client but it is not going to be installed
       Depends: openssh-server but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Running 'apt-get -f install' puts me here:

Code:
 root@testsrv ~ $ apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  apt aptitude base-passwd bash belocs-locales-bin binutils bsdutils coreutils cpio cpp cpp-4.1 debconf debconf-i18n debian-archive-keyring debianutils
  diff dmidecode dpkg e2fslibs findutils gcc gnupg gpgv grep groff-base hostname info iptables iputils-ping klogd laptop-detect liba52-0.7.4 libacl1
  libapr1 libartsc0 libasound2 libaspell15 libasyncns0 libatk1.0-0 libattr1 libaudiofile0 libblkid1 libbz2-1.0 libc6 libcaca0 libcap1 libcomerr2 libconsole
  libcucul0 libdb4.2 libdb4.3 libdb4.4 libdc1394-13 libdevmapper1.02 libdirectfb-0.9-25 libdrm2 libdv4 libdvdnav4 libedit2 libesd0 libexpat1 libfribidi0
  libgcc1 libgcrypt11 libgdbm3 libglib2.0-0 libgnutls13 libgpg-error0 libgpmg1 libgsm1 libidn11 libjack0.100.0-0 libjasper-1.701-1 libjpeg62 libkrb53
  liblcms1 libldap2 liblircclient0 liblocale-gettext-perl libltdl3 liblzo1 liblzo2-2 libmad0 libmpcdec3 libncurses5 libncursesw5 libnewt0.52 libogg0
  libopencdk8 libpam-modules libpam0g libpcre3 libpopt0 libraw1394-8 libreadline5 libsasl2-2 libsdl1.2debian-alsa libselinux1 libsepol1 libsigc++-2.0-0c2a
  libslang2 libspeex1 libsqlite3-0 libss2 libssp0 libstdc++6 libsvga1 libsysfs2 libt1-5 libtasn1-3 libtext-charwidth-perl libtext-iconv-perl
  libtext-wrapi18n-perl libtheora0 libtwolame0 libungif4g libusb-0.1-4 libuuid1 libvolume-id0 libvorbis0a libvorbisenc2 libwrap0 locales m4 makedev mawk
  perl perl-base perl-modules sysklogd tasksel tasksel-data zlib1g
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt libc6 (due to apt) libgcc1 (due to apt) libstdc++6 (due to apt) debian-archive-keyring (due to apt) base-passwd bash debianutils (due to bash)
  libncurses5 (due to bash) bsdutils coreutils libacl1 (due to coreutils) libselinux1 (due to coreutils) diff dpkg findutils grep hostname perl-base
0 upgraded, 0 newly installed, 133 to remove and 0 not upgraded.
52 not fully installed or removed.
Need to get 0B of archives.
After unpacking 143MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] Yes, do as I say!
E: Sub-process /usr/sbin/dpkg-preconfigure --apt || true returned an error code (100)
E: Failure running script /usr/sbin/dpkg-preconfigure --apt || true
And throws me back to prompt.

Have I totally killed my system? Any way to recover from this? Or do I just cut my losses and format?
 
Old 09-19-2007, 06:03 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
There may be a way to at least limit the damage. Can you post your /etc/apt/sources.list? This kind of problem usually occurs when you run a mixed repository and then upgrade packages. So if you were using stable (Etch), you might survive the damage by upgrading to testing (Lenny) and just running Lenny until it becomes stable in a year or so.

I don't think there's a graceful way to downgrade that works 100% of the time, but you could try pinning back to stable and then dist-upgrading and hoping it does the trick...

http://xpt.sourceforge.net/techdocs/...s/ar01s08.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Completely modular system Pelican Linux - General 2 07-01-2005 06:54 PM
system freezes completely c-- Ubuntu 2 03-29-2005 05:23 PM
Broke my system... Gillibiabtiag Linux - Newbie 4 09-23-2004 11:37 PM
Upgrade to Mandrake 9.2 completely broke video The MCP Mandriva 0 11-26-2003 08:09 PM
CUPS (Completely Unforgiving Printing System) help. SIR_Taco Linux - General 0 02-17-2003 11:30 PM


All times are GMT -5. The time now is 08:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration