LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-21-2009, 06:14 PM   #1
NU2GEN2
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Rep: Reputation: 0
I need to enable USE=X to emerge fluxbox


This is the error i am getting

*To build fluxbox with imlib in USE, you need an X enabled
*media-libs/imlib2 Either recompile imlib2 with the X
*USE flag turned on or disable the imlib USE flag for fluxbox

*ERROR: x11-wm/fluxbox-1.0.0-r2 failed
*Call stack

ebuild.sh, line 49: Called pkg_setup
* fluxbox -1.0.0-r2.ebuild, line 46: Called die


* The specific snippet of code:
die "USE=imlib requires imlib2 with USE=X"
*The die message:
* USE=imlib requires imlib2 with USE=X
 
Old 01-21-2009, 07:39 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,443

Rep: Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066
So what's your question ?.
If you don't know what USE flags are for in gentoo, you haven't read the handbook.
 
Old 01-23-2009, 05:36 PM   #3
NU2GEN2
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Original Poster
Rep: Reputation: 0
I read the handbook

I read everything even found some things on the net using the --pretend key to find out what USE flags i need. did all that and it still says the same thing.
Here is my USE config

USE="X x11-wm/fluxbox-1.0.0-r2 vim-syntax slim toolbar fluxbox-syntax nls qt3 -gnome -kde dvd alsa cdr"

Can someone help me install fluxbox?
 
  


Reply

Tags
fluxbox, gentoo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
python: can't open file 'emerge\bin\emerge.py' Virtuality Programming 5 01-30-2008 02:23 PM
Fluxbox emerge fails..need some help GUIPenguin Linux - General 1 02-14-2006 09:31 AM
Fluxbox error /usr/share/fluxbox/nls/en_GB/fluxbox.cat humbletech99 Debian 2 12-29-2005 11:16 AM
How to enable antialias support in Fluxbox 0.1.14 davidas Linux - Software 13 04-09-2004 08:58 PM
emerge errors during emerge -u world busbarn Linux - Distributions 6 04-23-2003 10:37 AM


All times are GMT -5. The time now is 06:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration