LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-23-2014, 08:44 PM   #1
lordbobo
LQ Newbie
 
Registered: May 2014
Posts: 2

Rep: Reputation: Disabled
Exclamation I need of Arch help!!! No terminal....


I have been "playing around" with Linux for a few years now and I am starting to get love with it. Today I finally got Arch installed on my laptop and then I installed GDM. Now GDM auto runs from boot. The problem is that I forgot to install the extras and I no longer have any kind of terminal and as far as I can tell I have no way to install anything without reformatting. Is there a way to log out log GDM so I can install the extras?
 
Old 05-23-2014, 09:10 PM   #2
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 15 , ChromeOS
Posts: 4,926
Blog Entries: 19

Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
For my cli boot I use init 3

https://wiki.archlinux.org/index.php...ipts/runlevels

You can use runlevel 1 or 3 for a terminal session.

I am not sure if Cntrl+Alt+t will drop you out of GDM and into terminal mode because I do not use GDM.
 
Old 05-23-2014, 09:21 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,061

Rep: Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916
Arch now runs systemd - perhaps this might be a better reference in this case.

Arch is a learning experience - the doco is excellent, so use it.
 
Old 05-24-2014, 08:43 AM   #4
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,367

Rep: Reputation: 233Reputation: 233Reputation: 233
Quote:
Originally Posted by syg00 View Post
Arch now runs systemd - perhaps this might be a better reference in this case.

Arch is a learning experience - the doco is excellent, so use it.
perhaps he's just looking for a way to log in?

*In GDM press Ctrl+Alt+F1
*log in as root (or use sudo)
*disable GDM (will take down X as well):
Code:
systemctl disable gdm.service
*fix whatever you need to fix

*enable GDM again (if that's what you wish):
Code:
systemctl enable gdm.service

*post back if any of the above steps don't work

Last edited by jens; 05-24-2014 at 08:56 AM.
 
Old 05-24-2014, 09:04 AM   #5
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,367

Rep: Reputation: 233Reputation: 233Reputation: 233
Quote:
Originally Posted by rokytnji View Post
For my cli boot I use init 3
Using the init command (not sysv specific) should work as well (though not recommended with any init-system).
 
Old 05-24-2014, 10:38 AM   #6
sansprecept
LQ Newbie
 
Registered: Nov 2013
Location: Houston, Tx
Distribution: Arch, Slackware
Posts: 11

Rep: Reputation: 1
I did that once. Went all the way through the install and boot went straight to GMD but I could not log into gui as root. I booted back to the install disk and chrooted to fix it. Haven;t forgotten to add a user since^o^
 
Old 05-24-2014, 11:07 AM   #7
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,367

Rep: Reputation: 233Reputation: 233Reputation: 233
Quote:
Originally Posted by sansprecept View Post
I did that once. Went all the way through the install and boot went straight to GMD but I could not log into gui as root. I booted back to the install disk and chrooted to fix it. Haven;t forgotten to add a user since^o^
It's as easy as typing adduser
Ps: the root part is an X thingy can be undone (though not recommended for obvious reasons).

Last edited by jens; 05-24-2014 at 11:09 AM.
 
Old 05-24-2014, 11:11 AM   #8
sansprecept
LQ Newbie
 
Registered: Nov 2013
Location: Houston, Tx
Distribution: Arch, Slackware
Posts: 11

Rep: Reputation: 1
Yep, but at the time I liked to make everything more difficult
 
Old 06-01-2014, 12:12 PM   #9
lordbobo
LQ Newbie
 
Registered: May 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
Solved

I was able to install the extras by placing the install disk in and rebooting. From there I just remounted the new OS and could install the extras
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Arch Linux Terminal Quirk aka: No Text or Cursor p5ych00n5 Linux - Software 1 05-25-2014 01:41 PM
LXer: Arch BSD: Arch Linux Atop The FreeBSD Kernel LXer Syndicated Linux News 0 01-24-2013 04:20 PM
Need instuctions for reseting display and xorg settings in Arch terminal. diigra Linux - Desktop 5 07-11-2012 03:26 PM
Arch Linux: In KDE, the default directory is Documents *When I open Terminal* theif519 Linux - Newbie 4 06-08-2011 05:26 AM
[SOLVED] Terminal doesn't launch (Arch + Xfce) laisa Linux - Software 2 04-22-2011 08:33 AM


All times are GMT -5. The time now is 04:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration