LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2004, 08:29 AM   #1
Punkie
LQ Newbie
 
Registered: Apr 2003
Location: Montreal, Canada
Distribution: CLFS 1.0.0
Posts: 24

Rep: Reputation: 15
Angry I need my mail! (desperate call for help with sendmail)


Hello everyone,

Well, as you can see, I have a problem with my sendmail. I have installed it and am able to send mail, but there's one catch to it: my e-mail address figures as "user@host.domain.com" instead of "user@domain.com". This prevents me from sending e-mail, as most of the servers check to see whether the "host.domain.com" is a valid domain - which is not. However, if they checked for "domain.com", that is a valid domain and well recognized.

I am trying to configure my sendmail to leave out the "host" part when constructing my e-mail address, so that it looks as "user@domain.com". Unfortunately I seem to be looking in all the wrong places, even though I have tried reading most FAQs related to sendmail - I still have no answer to my question.

At the moment, I am using "nail" for sending/reading e-mails which allows me to specify a "from" address, but I'd like to make this configuration in sendmail and mail client independent.

I am using a Linux From Scratch "distribution", I know where my files are, I know that I should change something in /etc/mail/sendmail.mc, but what is the option?

Thanks in advance, hope to get this working soon.
 
Old 01-29-2004, 09:08 AM   #2
Punkie
LQ Newbie
 
Registered: Apr 2003
Location: Montreal, Canada
Distribution: CLFS 1.0.0
Posts: 24

Original Poster
Rep: Reputation: 15
Just wanted to also mention that I do intend to read up on all the options of sendmail, but at the moment I have other priorities... The only thing I hope to fix is this problem, the rest I will probably be able to figure out by myself.
 
Old 01-29-2004, 10:46 AM   #3
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
Try adding this to your sendmail.mc and then recreate your .cf file.:

define(`confDOMAIN_NAME', `domain.com')dnl
 
Old 01-29-2004, 11:18 AM   #4
GraemeK
Member
 
Registered: Aug 2003
Location: Essex, UK
Distribution: Windoze 2000, Fedora Core 3
Posts: 325

Rep: Reputation: 30
werid! i never had that problem! let us know how you get on!

G
 
Old 01-29-2004, 11:23 AM   #5
Punkie
LQ Newbie
 
Registered: Apr 2003
Location: Montreal, Canada
Distribution: CLFS 1.0.0
Posts: 24

Original Poster
Rep: Reputation: 15
Afraid that didn't work out... Sendmail manages to get the domain name from the system, that's not the problem, the problem is it reports my e-mails coming from user@hostname.domainname instead of what I want (user@domainname). That option just "forces" the domain name to "domain.com".
 
Old 01-29-2004, 12:03 PM   #6
GraemeK
Member
 
Registered: Aug 2003
Location: Essex, UK
Distribution: Windoze 2000, Fedora Core 3
Posts: 325

Rep: Reputation: 30
what does your local-host-names file and hosts files look like?

G
 
Old 01-29-2004, 12:19 PM   #7
Punkie
LQ Newbie
 
Registered: Apr 2003
Location: Montreal, Canada
Distribution: CLFS 1.0.0
Posts: 24

Original Poster
Rep: Reputation: 15
local-host-names: Kamona
(the same as my hostname)
hosts (i'm assuming we're talking about /etc/hosts) has:
127.0.0.1 localhost.localdomain localhost
192.168.0.3 Kamona.CyberPunksNation.org Kamona
81.57.99.95 Kamona.CyberPunksNation.org Kamona


Probably should have mentioned this as well, I've installed sendmail following these instructions: http://linuxfromscratch.mirror.ac.uk.../sendmail.html
 
Old 01-29-2004, 03:45 PM   #8
Punkie
LQ Newbie
 
Registered: Apr 2003
Location: Montreal, Canada
Distribution: CLFS 1.0.0
Posts: 24

Original Poster
Rep: Reputation: 15
Ok... after countless hours of reading and trying and... I found it.

I had to add these two lines to my sendmail.mc (do this after copying the general-linux.mc):

MASQUERADE_AS(`domain.com')dnl
FEATURE(masquerade_envelope)dnl

And... it worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail error Fetching mail could not lock /var/spool/mail/username sukhdev50 Linux - Networking 0 05-04-2005 04:41 AM
Call to undefined function mail() The_Lance SUSE / openSUSE 1 04-12-2005 09:55 AM
Desperate to get ANY mail server up on RH9 (Shrike) Hendon Linux - Networking 9 12-27-2004 05:11 AM
Desperate help sendmail xedios Linux - Software 1 10-28-2004 06:45 PM
Display problem -- desperate call samartha1983 Linux - Hardware 4 02-14-2004 12:57 PM


All times are GMT -5. The time now is 03:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration