LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-25-2014, 05:23 PM   #1
blockie
LQ Newbie
 
Registered: Apr 2014
Location: Fresno, CA
Distribution: ubuntu
Posts: 12

Rep: Reputation: Disabled
I need help using the commands to change etc\default\grub


I make the changes to subect and try to save, only to be told I don;t have permission. Apparently the file belongs to "root". How do I become"root" or change the ownership to me? I don't even know what user I am. How do I find that Out?
 
Old 04-25-2014, 06:30 PM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Hi,
Quote:
Originally Posted by blockie View Post
I make the changes to subect and try to save, only to be told I don;t have permission. Apparently the file belongs to "root". How do I become"root"
Use the command
Code:
su -l
If that doesn't work, post back here with the exact error message and the output of
Code:
lsb_release --all
Quote:
or change the ownership to me?
You don't want to do that.
Quote:
I don't even know what user I am. How do I find that Out?
This will tell you:
Code:
whoami
HTH,

Evo2.
 
Old 04-25-2014, 07:19 PM   #3
blockie
LQ Newbie
 
Registered: Apr 2014
Location: Fresno, CA
Distribution: ubuntu
Posts: 12

Original Poster
Rep: Reputation: Disabled
su -l returned PW I entered the password that I generally use and gor authenication failure

On the next code I got a description of Ubuntu
No LSB modules found
ID: Ubuntu
Desc: Ubuntu 12.04.4 LTS
Rel: 12.04
Code name: Precise

The whoami returned william@William-PC:~$
Did this again about 3 hours later and whoami returnes willam Not William.Must Have done it when I installed Ubuntu

Last edited by blockie; 04-25-2014 at 08:54 PM. Reason: Add more info
 
Old 04-25-2014, 11:14 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Since you are using Ubuntu you can access the file with the command: sudo gedit /etc/default/grub
Using 'sudo' will prompt for your primary user password which you enter. gedit is the text editor to open the file. The primary user would be the one you created during installation and should have root privileges when you prefix a command with sudo and enter the password. If you have multiple users, you will need to know which one this is. You can give other users root privileges but it certainly isn't necessary on a standard home computer.

What are you wanting to edit in the file?
 
Old 04-26-2014, 12:58 AM   #5
blockie
LQ Newbie
 
Registered: Apr 2014
Location: Fresno, CA
Distribution: ubuntu
Posts: 12

Original Poster
Rep: Reputation: Disabled
Thanx, Yancey.
What I trying to do for now is make the "grub2" skip displaying a menu or anything else.
You see, I have installed Ubuntu alongside my normal W7. I am using "EasyBCD" for the dual-boot of W7 and Ubuntu. However I get another menu saying essetially that what I already had a menu for. This menu is redundant when I select Ubuntu on the first (EasyBCD) menu. I must select Ubuntu again. so wish to make the grub2 menu invisable.

Later, I will install Zorin, along with Ubuntu and W7. Then I will have three choises. Then I will probably remove the "EasyBCD" and pretty up the grub2 menu page.

Bill
 
Old 04-26-2014, 10:30 AM   #6
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
If you are using EasyBCD then the next menu you see is the Ubuntu Grub menu. I don't think EasyBCD boots a Linux system, it basically chainoads or points to the IPL on its partition and the Grub bootloader takes over. I'm not really that familiar with EasyBCD so that may not be right. I've read a number of posts where people using EasyBCD were unable to boot multiple Linux systems. Never tried it myself so I can't verify it but I would not be surprised if it happens.

Grub in the mbr chainloads windows also so it would be similar.
 
Old 04-26-2014, 05:00 PM   #7
blockie
LQ Newbie
 
Registered: Apr 2014
Location: Fresno, CA
Distribution: ubuntu
Posts: 12

Original Poster
Rep: Reputation: Disabled
OK, I have deleted the results of EasyBCD.I now boot into Wndows 7 after the bios. No menu used.
I cannot get into Ubuntu though. I would like the grub2 menu to popup after the bios so I could have a true dual boot sytem. As soon as the Linex/Zorin disk arrives I will install it. Then I will have three OS,s on my hard drive. I'm going to want a menu system with three options on it. With you all,s help I Will then pretty up the menu so that an attractive menu will be displayed.
In the meantime I'd like to have a dual boot menu system so I can use Ubuntu.

Bill
 
Old 04-26-2014, 09:52 PM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
From another terminal you can:

$ ls -l /boot/grub/grub.cfg
$ sudo chown user:user /boot/grub/grub.cfg

(save the changes you made)

$ sudo chown root:root /boot/grub/grub.cfg

To gain the permissions needed to save the changes you've already made. Where user:user is the user who made the changes and wants to save them. And of course restore them afterwards.

If the system supports booting from USB, you can use a usb device with grub on it to handle the dual boot options. Which you could setup on another machine. Lots of ways to get there in linux.
 
Old 04-26-2014, 11:40 PM   #9
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Quote:
OK, I have deleted the results of EasyBCD.I now boot into Wndows 7 after the bios. No menu used.
I cannot get into Ubuntu though.
Right. That would be expected behavior according to what you posted earlier. You previously stated that you used EasyBCD to boot windows and chainload to Ubuntu. Since you removed the EasyBCD, there is no entry for pointing to Grub and therefore no Ubuntu boot. If I'm understanding your post, you will need to either reinstall or reconfigure EasyBCD or install the Ubuntu Grub to the mbr and then run sudo update-grub from Ubuntu.

My experience with EasyBCD is that it will chainoad Linux. Grub chainloads windows and doesn't boot any windows version directly. In either case you will have two menus.
 
Old 04-26-2014, 11:47 PM   #10
blockie
LQ Newbie
 
Registered: Apr 2014
Location: Fresno, CA
Distribution: ubuntu
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
From another terminal you can:

$ ls -l /boot/grub/grub.cfg
$ sudo chown user:user /boot/grub/grub.cfg

(save the changes you made)

$ sudo chown root:root /boot/grub/grub.cfg

To gain the permissions needed to save the changes you've already made. Where user:user is the user who made the changes and wants to save them. And of course restore them afterwards.

If the system supports booting from USB, you can use a usb device with grub on it to handle the dual boot options. Which you could setup on another machine. Lots of ways to get there in linux.
I'm not sure I understand everything in your post. First I only have access to one machine and it cannot boot from USB.

The first time you use "user:user" it would translate to "user:Willam". Thats my user name. Am I right?

Bill
 
Old 04-27-2014, 01:49 AM   #11
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
It would be William:William in that case. Using chown in that syntax changes the owner and the group of the file in a single command. You could use chown and chgrp with just the user instead of user:user. You could also chmod the write permissions on the file, but a little more involved to undo.
 
Old 04-27-2014, 02:12 AM   #12
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,827

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
Why do people insist on putting "easyBCD" into the mix ?????
Grub 2 boots win7 JUST FINE and with NO outside help

let Win7 have the MBR on the first drive where win7 is installed
install Grub to the FIRST linux partition( or drive if using 2 disks)
the Operating system installer will AUTO !!!! add an entry for win7
( with no outside help needed )
the ubuntu installer will AUTO do it

then set the partition ( or disk) that grub is on as the one to boot from in the bios of the computer


all one has to do is NOT replace MS's bootloader
( windows HATES that and will likely try to " fix" a working grub install and REINSTALL windows bootloader )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Change default GRUB americast Linux - Newbie 12 11-04-2012 03:38 AM
change grub boot order, all instructions say change default, but I don't see default mhg Linux - Newbie 5 11-09-2008 11:01 AM
grub not seeing grub-set-default change bic Linux - Software 4 02-15-2008 02:44 PM
How do you change the default Boot-up OS in Grub? buckwheat12 Fedora 3 05-08-2004 04:24 PM
how to change default os in Grub eye Linux - Software 3 05-16-2003 09:10 AM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration