LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-12-2005, 10:48 PM   #1
xri
Member
 
Registered: Aug 2002
Distribution: Slackware 14.2, Archlinux
Posts: 283
Blog Entries: 11

Rep: Reputation: 41
I Messed Up My File Associations In Konqueror


I tried to prevent Konqueror to open an embedded audio stream, so I went to file associations and for mp3 I replaced Netscape plug-in with KHTML.

Right after that, I cannot browse the Internet with Konqueror, because it only shows the html source.


How can I get Konqueror to behave like a web browser, instead of just showing the html code when going to one my bookmarks.


I tried reinstalling Konqueror (on the hope that it would reset the file associations to default values) but no joy.

I went to Control Center and went through all the file types and clicked Default, but nothing changed.

My guess is that if I delete the configuration file regarding these file associations and then reinstall Konqueror, maybe it will come with default settings (just an idea).

How can I take Konqueror to its default file associations?
 
Old 04-12-2005, 10:52 PM   #2
shengchieh
Member
 
Registered: Jul 2004
Location: Palo Alto, CA
Distribution: #! Korora
Posts: 472

Rep: Reputation: 30
To change file assoc., go to

start (Xandros Launch)
-> control center
-> file manger
-> file association

It's bound to different for your distribution. Nevertheless
you need to wiggle around and find the "file association"
in the "control center". And then, do your changes.

Sheng-Chieh
 
Old 04-13-2005, 12:19 PM   #3
xri
Member
 
Registered: Aug 2002
Distribution: Slackware 14.2, Archlinux
Posts: 283
Blog Entries: 11

Original Poster
Rep: Reputation: 41
Thanks, but I tried that already. I went to the Control Center and tried to restore all the file associations to prior values.

However, I can't find a reason for Konqueror to show only the HTML source code instead of the web pages, just after I changed an association in ONE OF THE AUDIO FILE TYPES (mp3). Even though I deleted that change, Konqueror keeps not showing the web pages.

I will try deleting the file associations configuration file, and then reinstalling Konqueror. I'll let you know tonight.

If you think it's a bad plan, please let me know, and thanks again.
 
Old 04-13-2005, 02:37 PM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Have you checked under View -> View Mode that it's set on KHTML
 
Old 04-15-2005, 12:39 AM   #5
xri
Member
 
Registered: Aug 2002
Distribution: Slackware 14.2, Archlinux
Posts: 283
Blog Entries: 11

Original Poster
Rep: Reputation: 41
Yes, I checked under View, but this time it does not show options, as it used before.

I've tried deleting this file:
$HOME/.kde/share/config/profilerc
and then copying a default one from another user, and changed the owner and group and permissions, but it did not solve the problem.

I used the solution from this posting:

http://www.linuxquestions.org/questions/showthread.php?s=&threadid=194887&highlight=konqueror+file+associations+configuration

but it did not add khtml to the list of available services for embedded html


I understand that, if khtml was available among the choices for embedded html files (from the 'text' group), probably Konqueror would start working again.

But this choice is not available any more!!

How can I make it available?

Please help!!
 
Old 04-15-2005, 01:55 AM   #6
xri
Member
 
Registered: Aug 2002
Distribution: Slackware 14.2, Archlinux
Posts: 283
Blog Entries: 11

Original Poster
Rep: Reputation: 41
I tried the same sequence as another regular user:

I went to Control Center->File Associations->Audio->mp3->Embedded
I chose to Add KHTML
Then I closed Control Center

Then again, on Konqueror, it started to show only the html source, not the Web pages as such.

Then I went back to Control Center, and I found:

1. Under Audio->mp3->Embedded, the KHTML I had added is not there any more (it did not stick)
2. Under Text->html, there is only Advanced text editor, and NOT KHTML any more (which was the default)
3. Whichever file type I choose, when the Embedded type is active, KHTML is not an option any more. It just vanished from the "Add" list.

I feel stuck here. There must be a way to make KHTML available so in the Add list (Control Center->File Associations->(whichever type)->Embedded).

Please help me out, oh wise ones. There has to be a way to restore Konqueror's defaults!
 
Old 04-23-2005, 07:38 PM   #7
xri
Member
 
Registered: Aug 2002
Distribution: Slackware 14.2, Archlinux
Posts: 283
Blog Entries: 11

Original Poster
Rep: Reputation: 41
After the sequence described on my prior posting, the MIME options and the Add options for Embedded files should not get messed up like that; that should not happen. Maybe on a newer version of KDE (mine is 3.1) there is not this problem any more.
I tried all the recipes from similar postings (not that there are that many anyway), except for deleting all the files under .KDE/
I've been hesitant to do it because I would probably loose my configurations and other data.
Maybe if I delete share/mimelnk and then reinstall KDE I'll get the default MIME settings. I'll try that and post. If there is any better idea, please post it (thanks).

Maybe I should just reinstall the whole thing...
 
Old 04-23-2005, 07:53 PM   #8
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Just logout and back in as another user. Then su to your regular home directory and rename .kde to something like .kde.backup. Then logout and login as regular user. You will have lost all your kde settings but if you need any data it will still be in your .ked.backup directory for you to cut and paste back.

Brian1
Google the Linux way at ' http://www.google.com/linux '
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
konqueror fonts messed up mi6alec Mandriva 2 03-06-2004 09:05 AM
Dam! I messed up my program associations. lectraplayer Linux - Newbie 3 02-04-2004 10:41 PM
File Associations gag Linux - Newbie 6 10-15-2003 05:34 PM
Sorting files in Konqueror/File associations/sound in KDE Kelvie Linux - Newbie 9 07-19-2003 02:56 AM
konqueror is all messed up wr3ck3d Linux - General 2 12-14-2002 05:38 PM


All times are GMT -5. The time now is 04:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration