LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I have Ubuntu 10.9(?) and after an update yesterday, I now have no sound whatsoever. (http://www.linuxquestions.org/questions/linux-newbie-8/i-have-ubuntu-10-9-and-after-an-update-yesterday-i-now-have-no-sound-whatsoever-917965/)

idiotsquad 12-09-2011 04:43 PM

I have Ubuntu 10.9(?) and after an update yesterday, I now have no sound whatsoever.
 
I have Ubuntu 10.9(?) and after an update yesterday, I now have no sound whatsoever. Why is this? I have tried to fiddle with the sound controls and whatever I think might be linked to me having sound and nothing happens. I am a complete idiot when it comes to computers and my sound was working fine until this update. Am I doing something wrong, or did I update something that screwed it all up?

Doc CPU 12-10-2011 10:30 AM

Hi there,

Quote:

Originally Posted by idiotsquad (Post 4546223)
I have Ubuntu 10.9(?) and after an update yesterday, I now have no sound whatsoever. Why is this? I have tried to fiddle with the sound controls and whatever I think might be linked to me having sound and nothing happens. I am a complete idiot when it comes to computers and my sound was working fine until this update. Am I doing something wrong, or did I update something that screwed it all up?

without knowing exactly what you did, particularly what packages you updated, it's hard to tell what really happened - other than: "That's not the way it should be."

The first thing that I'm stopping short at is the version number you mention - there has never been an Ubuntu 10.9, as Ubuntu has a very logical versioning: There were, for example, Ubuntu 7.04, 7.10, 8.04, 8.10, 9.04, 9.10, 10.04, 10.10 ... Do you see the regularity? The major version number is always the year of issue, and there are usually two releases each year, one in April, and one in October.
When you say 10.9 - could it be you actually mean 9.10, also called "Karmic Koala"? If so, that's now two years old, support has been suspended, and I'd recommend you to change to a more recent release. If you don't like Ubuntu 11.x (which uses the Unity desktop and apparently has a lot of problems), you should update to at least 10.04, which is an LTS (long term support), meaning that it will be supported over 3 years, instead of the usual 18 months of the intermediary releases.

[X] Doc CPU

mbvpixies78 12-12-2011 05:28 AM

Ubuntu versions aside...
 
You might do a little research on your particular version of Ubuntu's sound system. I don't use Ubuntu, but I know, for example, that ALSA is used in other distros. My point is that if you find out what you are using, then you can reinstall the package and this will most likely fix your problem. You would do something like this at the command prompt (it's best to leave the GUI and run this at run_level 3 (GUI is run-level 5):

#sudo apt-get remove <sound_package_name>
#sudo apt-get install <sound_package_name>
#sudo apt-get update

Be aware that packages come in different versions and sometimes certain versions of Ubuntu will work better with certain versions of sound packages.

If any of this is over your head in terms of understanding, just ask. We all start somewhere and you really need to get your hands dirty to make Linux work for you, particularly getting comfortable with the command prompt.

Brains 12-12-2011 12:46 PM

Check mixer settings, Ubuntu uses alsa, from a command propmt enter command: alsamixer. A mixer should appear, make sure master(s) and pcm are up around seventy five percent or so, below each line is a box with the letter 'm', with the cursor under the master or pcm line, toggle the m key to fiddle with mute as they may just be muted. Play with these while music is playing or something that puts out sound. Sometimes channels that are not muted need to be muted, this was a problem I had with one of the features of my sound blaster Audigy card (digital output or something) in Mandriva in the past.

If you get it fixed through alsamixer, quit it and run command: sudo alsactl store to save the changes.


All times are GMT -5. The time now is 06:08 AM.