LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2008, 04:15 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
I have no name!@


I dont know what happened to my fedora machine.Whenever I am trying to login it says:

Code:
login as: saturn
saturn@10.14.242.168's password:
Last login: Thu Aug 28 13:03:39 2008 from 10.14.2.254
id: cannot find name for user ID 501
id: cannot find name for user ID 501
[I have no name!@atix ~]$

Whenever I try doing this:
Code:
[I have no name!@atix opt]$ sudo rm -fr fedora-ds/
Mail submission program must have RunAsUser set to non root user
saturn is not in the sudoers file.  This incident will be reported.
Any idea?

Last edited by your_shadow03; 08-28-2008 at 04:17 AM.
 
Old 08-28-2008, 04:18 AM   #2
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 485
Blog Entries: 159

Rep: Reputation: 74
grep <user_name> /etc/passwd

Sounds like /etc/passwd got modified. I did the same on a FreeBSD machine one time and it asked me "who are you?", which made me feel a bit weird. heh.

Let me know if the command above gives you "sane" output.
 
Old 08-28-2008, 04:20 AM   #3
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
I remember I had installed fedora DS on the same machine long back .is this Becoz of that?
if yes,then how can i delete that LDAP setup.
I notice that it has been installed on /opt directory.

What Should i do to remove LDAP/Fedora DS and bring it to point to Local System?

As for now, I cant do anything as it reports the error.

Pls help
 
Old 08-28-2008, 06:38 AM   #4
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
I can see that /etc/shadow file doesnt exist.How can i bring it back?
Also I logged intom runlevel 1 and issue passwd command
it says:
Code:
passwd(pam_unix)[2053]:user "root" doesnt have modifiable password
Pls help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration