LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2013, 06:26 PM   #1
cowboy5709
LQ Newbie
 
Registered: Oct 2013
Posts: 5

Rep: Reputation: Disabled
Unhappy I have Linux Mint 14.1 Nadia x64 and Windows 7 Ult---How do I Change Boot order?


How do I Change Boot order? I want to boot Win7 first because my wife wants to be happy!!!

My Knowledge of Linux is very basic


Thank You

Last edited by cowboy5709; 10-12-2013 at 06:28 PM. Reason: more info
 
Old 10-12-2013, 06:43 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Code:
gksu gedit /etc/default/grub &

Code:
GRUB_DEFAULT=saved The information in this section applies to GRUB 1.98 and later. The "saved" entry enables the "grub-reboot" and "grub-set-default" commands to set the default OS for future boots.

The default OS for future boots will not be set merely by selecting an OS when booting.

grub-set-default Sets the default boot entry until changed.

The format is sudo grub-set-default X, with X being the menu entry position (starting with 0 as the first entry) or the exact menu string.

Example: sudo grub-set-default 3

Example: sudo grub-set-default "Ubuntu, Linux 2.6.32-15-generic"

To obtain the existing menu entry choice number (starting from 0) or the menu entry "string", run:
grep menuentry /boot/grub/grub.cfg

grub-reboot This command sets the default boot entry for the next boot only. The format of the command is the same as for grub-set-default (see above).
set the default to the number that windows is in the list

https://help.ubuntu.com/community/Gr...iguring_GRUB_2

Last edited by andrewthomas; 10-12-2013 at 06:45 PM. Reason: added link
 
Old 10-15-2013, 08:34 PM   #3
cowboy5709
LQ Newbie
 
Registered: Oct 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
I tried your suggestions and never could get to work. I took LinuxMint off and added PCLinuxOS kde 10-13 which allowed me to install kGrubEditor which I have used in the past.This allowed me to Boot Win7 as first option, Then PCLinuxOS AS 2nd Boot option.

Thank you for your help

Problem Solved, Thank You

Last edited by cowboy5709; 10-15-2013 at 08:35 PM.
 
Old 10-15-2013, 11:59 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
You could have accomplished what you wanted with any system using Grub2 by opening a text editor and typing:

sudo gedit /etc/default/grub

That would have opened the grub file in a text editor and you would have seen at the top of the file this line:

Quote:
GRUB_DEFAULT=0
You would change the 0 to whatever number the entry for windows was, if it was third you would put a 2, fourth a 3 as Grub counts from zero. Save the change and run sudo update-grub and you're done.

As a PCLinux user myself for years, good choice.
 
Old 10-16-2013, 07:51 AM   #5
cowboy5709
LQ Newbie
 
Registered: Oct 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Smile Thank You for your reply. I will check out what you requested I do.

Quote:
Originally Posted by yancek View Post
You could have accomplished what you wanted with any system using Grub2 by opening a text editor and typing:

sudo gedit /etc/default/grub

That would have opened the grub file in a text editor and you would have seen at the top of the file this line:



You would change the 0 to whatever number the entry for windows was, if it was third you would put a 2, fourth a 3 as Grub counts from zero. Save the change and run sudo update-grub and you're done.

As a PCLinux user myself for years, good choice.
Actually, everything wasn't as easy as I said. I had Linux Mint 14.1 Nadia installed when I wanted to change Boot Order. I decided to install Linux Mint 15 KDE instead. It installed all the way to the end, almost to the point of rebooting and then screen froze and wouldn't do anything (not even reboot). I shut computer off,restarted with No grub menu to boot to. Used "Boot Repair" disk and restarted and told it to repair Boot. It Did, and this allowed me to get back into Windows. I went to Distrowatch in windows and downloaded the newest Ubuntu and PCLinuxOS. Installed Ubuntu first (went well) but I did not like as well as Linux Mint 14.1. Went back to windows and used "MiniTool Partition Wizard Home Edition" to remove all of Ubuntu. Then I installed PCLinuxOS 10-13 and I am very happy with my choice.
I think most made a serious mistake by not offering "KGrubEditor" in the popular Distro's anymore. Those kinds of programs help users such as myself get acclimated to Linux. When you take away those tools, you are making it harder for the "Average person" to stay with Linux long enough to learn it and like it. You Drive many back to Windows. Give us those tools,then the Terminal interaction will come later.

Been back and forth to windows and Linux so many times I can't count. It makes many scared of Linux such as my wife. Linux should not be Scary, it should be FUN!!!!!!!

My Opinion
 
Old 10-16-2013, 08:13 AM   #6
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US, Earth, end border$! ◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest, has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,101
Blog Entries: 2

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
trick your mind to thinking it's fun, make a game out of it and try more, one of my favorite things looking back was all the distros I tried to find my likes
 
Old 10-16-2013, 08:43 AM   #7
cowboy5709
LQ Newbie
 
Registered: Oct 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
sudo gedit /etc/default/grub

This is what I got after typing in terminal what you said:

sudo gedit /etc/default/grub

** (gedit:8418): WARNING **: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

** (gedit:8418): WARNING **: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

** (gedit:8418): WARNING **: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

(gedit:8418): Gtk-WARNING **: Theme parsing error: <data>:5:10: Not using units is deprecated. Assuming 'px'.

(gedit:8418): Gtk-WARNING **: Theme parsing error: <data>:7:20: Not using units is deprecated. Assuming 'px'.

(gedit:8418): Gtk-WARNING **: Theme parsing error: <data>:7:22: Not using units is deprecated. Assuming 'px'.

(gedit:8418): Gtk-WARNING **: Theme parsing error: <data>:8:15: Not using units is deprecated. Assuming 'px'.

** (gedit:8418): WARNING **: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

** (gedit:8418): WARNING **: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

** (gedit:8418): WARNING **: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
 
Old 10-16-2013, 08:50 AM   #8
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US, Earth, end border$! ◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest, has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,101
Blog Entries: 2

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
You can use the code tags button[#] when posting \ no smileys and we'll know whats what e.g:
Code:
;)
Try:
Code:
cat /etc/default/grub
to see if it is there and read it then it's just a mater of editing it as root

Last edited by jamison20000e; 10-16-2013 at 08:54 AM.
 
Old 10-16-2013, 09:28 AM   #9
cowboy5709
LQ Newbie
 
Registered: Oct 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
tried it

cat: /etc/default/grub: No such file or directory
 
Old 10-16-2013, 09:48 AM   #10
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
What I said was the command would work with Mint. Since you indicated you have installed PCLinuxOS over Mint, there is no Grub2 nor is there and /etc/default/grub file. If you boot a Mint CD, you would see it there. You could not edit it on a CD as it is a read-only system. My earlier post was for informational purposes, what you could have done when Mint was installed.
 
Old 10-16-2013, 09:48 AM   #11
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US, Earth, end border$! ◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest, has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,101
Blog Entries: 2

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
Grub has changed since I used to tweaked it a lot, use your file browser and look at /boot/grub/grub.cfg or 'cat /boot/grub/grub.cfg' this is probably where you need that edit (as root) then run:
Code:
su or sudo
update-grub

Last edited by jamison20000e; 10-16-2013 at 10:00 AM.
 
Old 10-16-2013, 09:53 AM   #12
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US, Earth, end border$! ◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest, has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,101
Blog Entries: 2

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
Edited the above
 
Old 10-16-2013, 10:19 AM   #13
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,902

Rep: Reputation: 261Reputation: 261Reputation: 261
After editing /etc/default/grub need to run sudo update-grub, for changes to take place. It isn't recommended to edit /boot/grub/grub.cfg, any changes to it will change back the next time update-grub is ran either by updates or manually.
 
Old 10-16-2013, 10:22 AM   #14
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US, Earth, end border$! ◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest, has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,101
Blog Entries: 2

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
Quote:
Originally Posted by cowboy5709 View Post
cat: /etc/default/grub: No such file or directory
hope 5709 did not keep : when running take a look in /etc/grub.d/ the README will open when clicked but right click and say open with text editor for the other files ? just for informative purposes

Last edited by jamison20000e; 10-16-2013 at 10:26 AM.
 
Old 10-16-2013, 11:46 AM   #15
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 15 , Slackel 14.1, ChromeOS
Posts: 4,701
Blog Entries: 19

Rep: Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952
Quote:
Theme parsing error:
change the theme and then

Code:
sudo gedit /etc/default/grub
is what I would do when faced with this error.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Mint Mate 14 Nadia Staritza Linux Mint 12 07-22-2013 10:22 AM
Boot issues with Linux Mint 14 Nadia xfce on solo instal . M2V mobo, 3Gb ram. filmtechie Linux - Newbie 18 12-22-2012 03:31 PM
[SOLVED] Xfce edition for Linux Mint Nadia? crosstalk Linux Mint 6 12-02-2012 11:53 PM
LXer: Linux Mint 14 Will Be Named Nadia LXer Syndicated Linux News 0 08-24-2012 11:30 PM
Need to change DEBIAN 5.0 & WINDOWS 2k/xp boot order on GRUB PC caf Debian 2 04-14-2009 01:27 PM


All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration