LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-29-2012, 11:11 PM   #1
edison_0927
LQ Newbie
 
Registered: Feb 2012
Posts: 13

Rep: Reputation: Disabled
i have a new problem with ns2


i got the error below when i using the ns2 to scenario my protocol


Starting program: /usr/local/bin/ns sim.tcl
num_nodes is set 25
INITIALIZE THE LIST xListHead
Loading scenario file...

Program received signal SIGSEGV, Segmentation fault.
0x0829c00b in MobileNode::update_position() ()



who can help to fix it ,thank you !!!!!!!
 
Old 05-30-2012, 01:56 AM   #2
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Rep: Reputation: 210Reputation: 210Reputation: 210
Looks like the NS guys f*d up; segfaults aren't supposed to happen in good releases. You should report it as a bug.

But, to answer your question, try one of these:

Code:
strace /usr/local/bin/ns sim.tcl
Code:
gdb --args /usr/local/bin/ns sim.tcl
# type run, then bt
Code:
valgrind /usr/local/bin/ns sim.tcl
Then use your Googling skills to figure out what's wrong, based on the information those things return.

Also, double check your input file. You might be passing a bad value to update_position().
 
Old 05-30-2012, 08:07 AM   #3
edison_0927
LQ Newbie
 
Registered: Feb 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
i have fixed the problem already ..
thank you very much
 
Old 06-01-2012, 12:14 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,353
Blog Entries: 55

Rep: Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541
Quote:
Originally Posted by edison_0927 View Post
i have fixed the problem already ..
Then list your fix for others please.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
want to install ns2.29.3 along with mannasim patch for ns2.29 jeevanpinto Linux - Software 4 10-02-2013 12:09 AM
Differences between LEACH results on ns2.1b5 and ns2.35 deepa_2111 Linux - Software 15 05-16-2013 05:53 PM
ns2 :the problem of have 8.5.10, need exactly 8.4? dyhdragonone Linux - Newbie 1 12-30-2011 01:36 PM
i am using ubuntu as os. for NS2 to implement a routing protocol in ns2. sujovasu Programming 1 07-27-2010 01:44 AM
any one help me with this problem on ns2 narayanasai Linux - Networking 2 10-05-2009 03:11 PM


All times are GMT -5. The time now is 12:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration