LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I get a message "Authentication Failed during during boot . I cannot boot my system (http://www.linuxquestions.org/questions/linux-newbie-8/i-get-a-message-authentication-failed-during-during-boot-i-cannot-boot-my-system-782725/)

hirschi 3 score 1 01-17-2010 02:08 AM

I get a message "Authentication Failed during during boot . I cannot boot my system
 
My Redhat 5.3 desktop running on an AMD 64 system was not receiving the updates from rhn until a few days ago when it started checking in and downloading updates. The updates crashed generating bug reports. I tried running yum-complete-transaction command, it aborted also. I found a knowledge base article with instructions on how to rebuild the rpm database which I followed. After completing the procedure I tried to reboot. The system gets to the logon screen and then I get the message Authentication Failed and the system locks up. The commands I ran are:
rm /var/lib/rpm/__db*
rpm -rebuilddb
yum clean all

I am also seeing a message during boot up that the module libxml2 is missing and when I try to download the package from rhn yum cannot find the server.

Simon Bridge 01-17-2010 09:48 AM

Have you told RHN about this - did you send them the bug reports?

Quote:

The system gets to the logon screen and then I get the message Authentication Failed
Boot to single user mode, and attempt to log in without the gui.

It sounds like something is trying to authenticate you without you typing anything. Like this guy.
"in the login splash screen, I get the "Authentication failed" message window. The box where I'm supposed to enter my user name is faded and contains three dots. I can't enter anything."

Solved by reinstalling the pam packages.

Quote:

I am also seeing a message during boot up that the module libxml2 is missing and when I try to download the package from rhn yum cannot find the server.
If you cannot boot, how can you use yum?

chrism01 01-17-2010 05:18 PM

Just to check, you do know that

rpm --initdb
rpm --rebuilddb

take 2 dashes '--', not one?

hirschi 3 score 1 01-18-2010 10:11 AM

Thank you All,

I think I have two problems

I do have a subscription to rhn, and I have submitted a ticket about my machine not checking in but they haven't updated my request for over a week. When they do reply they replay as if I really know something. You folks so far do a better job of talking on my level (sublevel).

1. I am getting the same message and symptoms as "this guy." I found a workaround the lockup by hitting "escape" and then quickly clicking on the restart option on the gui before the nest message locks me out. I can boot the machine using the using the emergency command from grub. So if I could find the name of my cdrom or my usb memory stick I could download the libxml2 package then I might be able to boot to the gui again. Any suggestions?

2. I cannot access the internet when I run yum install package the message indicates it cannot find the website and I get the message that the libxml2 module is missing. How do I guide yum to the correct website?

And yes I did learn that I need the double - for the rmp rebuilddb command, along with a few other things I did want to learn.

hirschi 3 score 1 01-19-2010 10:40 PM

I found out from redhat that I should not use yum-complete-transaction. (Now they tell me) I appears that some files have been deleted. I don't know how to communicate with rhn from the command line. So, I cannot run the tests they ask me to run and transmit the data to the support people. I can't seem to mount a usb flash drive. It is getting apparent that I will have to reload the system again. I just got my virtual xp up to speed. I don't want to start over. This is the second time rhel 5.3 has crashed. Anybody have any ideas?

GrapefruiTgirl 01-19-2010 10:42 PM

How exactly to you mean "communicate with rhn from the command line"? You need to use a browser, for example?

Have you got Links or Lynx installed? Two decent command line browsers.

If this isn't the issue, please provide a bit more detail about what exactly you need from the command line.

Sasha

chrism01 01-20-2010 12:37 AM

I'm not entirely clear what the exact problem is, but it sounds like your having issue connecting to rhn, possibly caused by your repo (repository) lists/files being corrupt.
Here is a useful set of yum cmds: http://kbase.redhat.com/faq/docs/DOC-2531
You should find the repos defined in the dir /etc/yum.repos.d.
You should also have a /etc/yum.conf like this http://www.redhat.com/docs/en-US/Red...m-yumconf.html.

You might want to post the main conf and the repo files.

Simon Bridge 01-21-2010 11:08 PM

Quote:

Originally Posted by hirschi 3 score 1 (Post 3832981)
I found out from redhat that I should not use yum-complete-transaction. (Now they tell me) I appears that some files have been deleted. I don't know how to communicate with rhn from the command line. So, I cannot run the tests they ask me to run and transmit the data to the support people. I can't seem to mount a usb flash drive. It is getting apparent that I will have to reload the system again. I just got my virtual xp up to speed. I don't want to start over. This is the second time rhel 5.3 has crashed. Anybody have any ideas?

As the others have pointed out, this is too ambiguous: you need to be specific.

Which files seem to be deleted and what is it that makes you suspect this?
How are you trying to communicate with RHN? How have you been doing this until now and what has changed? What are the tests RHN want you to run? How do they expect you to communicate the results to them?

How are you trying to mount a usb flash drive and why?

Reinstalling is likely to be counter productive now you have engaged RHN support. Since this is not the first time you have experienced this, your test and reports will be useful for them to prevent this sort of thing happening in the future.


All times are GMT -5. The time now is 09:18 AM.