LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-24-2004, 12:05 PM   #1
xephyr
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Rep: Reputation: 0
Question I edited my fstab for ntfs, I can open the drive, but no files


I added the following line

ntfs rw,auto,user,umask=222 00
into my fstab
Now I can open the drive as a normal user, but guess what? I see no files or contens or folders or what so ever there!
HELP!!!!!!
 
Old 10-24-2004, 12:12 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
It the line you posted here is exactly as you entered it it fstab, it won't work. Look at the syntax used in your current fstab, and correct the entry. It need to name the device where ntfs is located, the name of the mount point, the filesystem type, and the rest of the parameters. Be advised that mounting it rw may cause problems if you try to write to it. Search these board for discussions on that issue.
 
Old 10-24-2004, 12:34 PM   #3
xephyr
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Original Poster
Rep: Reputation: 0
here is exavtly what is in my fstab

/dev/hda8 /mnt/hda/8 ntfs rw.auto,user, umask=200 0 0

I can open the dir, but there is no file
tell me what is the syntex error up there
 
Old 10-24-2004, 12:52 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You are seeing an empty directory because the file system isn't mounted.
Code:
Your second message has:
/dev/hda8 /mnt/hda/8 ntfs rw.auto,user, umask=200 0 0
You have a period after the rw option, a space before umask.

This may work better:
/dev/hda8 /mnt/hda/8 ntfs ro,default,umask=200 1 0
The first 0 at the end of the fstab entry says whether the drive should be mounted when the computer is booted. I would suggest reading the man mount page. Since the ntfs filesystem is currently read only, using the options dmask and fmask may make more sense. The umask is the file creation mask. The fmask is a file mask, dmask is directory mask. Also consider using using uid=xephyr assuming that is the name of your user account.
 
Old 10-24-2004, 05:23 PM   #5
xephyr
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Original Poster
Rep: Reputation: 0
.........
Maybe I didn't make myself clear enought......

I can access the drive, and by that I mean I can click it and open it
but there is nothing inside, it's empty, blank, with no icons or whatsoever
 
Old 10-24-2004, 05:36 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,152

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
What do you mean by access the drive or open the drive as a normal user?

Just because you can browse to the /mnt/hda8 directory does not mean the partition is actually mounted. The mount command without options will display all mounted filesystems as will as the df command.

With the umask=222 option you do not need the rw option.
 
Old 10-24-2004, 07:40 PM   #7
WhiteChedda
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Mandrake 9.1 for now
Posts: 205

Rep: Reputation: 30
Quote:
Originally posted by xephyr
.........
Maybe I didn't make myself clear enought......

I can access the drive, and by that I mean I can click it and open it
but there is nothing inside, it's empty, blank, with no icons or whatsoever
Sounds like you are just accessing the mounting point created for it, but it isn't mounted, so.
From a console type mount, and see if it is actually mounted.

Also NTFS write = no can do in linux right now.
I suggest you turn that off before you blow something up.

If you just want to read the NTFS parition as a user I suggest trying in fstab

/dev/hda8 /mnt/ntfs ntfs users,gid=100,umask=002,ro,noexec,nosuid

This should work fine for just reading the partition.

If you want limited user reading of it, create a new group, add the memebers you want to be able to read it and replace the gid=100 part with the id from that group instead of 100.
 
Old 10-26-2004, 07:06 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You can see if a partition is mounted by entering the command 'mount'.

You can also read the /etc/mtab file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving files from NTFS drive to a EXT3 drive?? webshark Slackware 10 05-28-2006 04:02 PM
just edited fstab and quick question cjae Linux - Newbie 1 08-12-2005 02:24 PM
Open vi at top of file rather than last edited line... davee Linux - General 2 04-22-2005 07:34 AM
I need 'su' access in OpenOffice to open NTFS files penguin_powered Linux - Newbie 1 10-31-2004 04:54 PM
Cannot Copy Files From Network FAT32/NTFS Drive to My Local Linux Drive michaelh Linux - Networking 3 10-29-2002 11:27 AM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration