LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I edited my fstab for ntfs, I can open the drive, but no files (http://www.linuxquestions.org/questions/linux-newbie-8/i-edited-my-fstab-for-ntfs-i-can-open-the-drive-but-no-files-246725/)

xephyr 10-24-2004 12:05 PM

I edited my fstab for ntfs, I can open the drive, but no files
 
I added the following line

ntfs rw,auto,user,umask=222 00
into my fstab
Now I can open the drive as a normal user, but guess what? I see no files or contens or folders or what so ever there!
HELP!!!!!!

bigrigdriver 10-24-2004 12:12 PM

It the line you posted here is exactly as you entered it it fstab, it won't work. Look at the syntax used in your current fstab, and correct the entry. It need to name the device where ntfs is located, the name of the mount point, the filesystem type, and the rest of the parameters. Be advised that mounting it rw may cause problems if you try to write to it. Search these board for discussions on that issue.

xephyr 10-24-2004 12:34 PM

here is exavtly what is in my fstab
 
/dev/hda8 /mnt/hda/8 ntfs rw.auto,user, umask=200 0 0

I can open the dir, but there is no file
tell me what is the syntex error up there

jschiwal 10-24-2004 12:52 PM

You are seeing an empty directory because the file system isn't mounted.
Code:

Your second message has:
/dev/hda8 /mnt/hda/8 ntfs rw.auto,user, umask=200 0 0
You have a period after the rw option, a space before umask.

This may work better:
/dev/hda8 /mnt/hda/8 ntfs ro,default,umask=200 1 0

The first 0 at the end of the fstab entry says whether the drive should be mounted when the computer is booted. I would suggest reading the man mount page. Since the ntfs filesystem is currently read only, using the options dmask and fmask may make more sense. The umask is the file creation mask. The fmask is a file mask, dmask is directory mask. Also consider using using uid=xephyr assuming that is the name of your user account.

xephyr 10-24-2004 05:23 PM

.........
Maybe I didn't make myself clear enought......

I can access the drive, and by that I mean I can click it and open it
but there is nothing inside, it's empty, blank, with no icons or whatsoever

michaelk 10-24-2004 05:36 PM

What do you mean by access the drive or open the drive as a normal user?

Just because you can browse to the /mnt/hda8 directory does not mean the partition is actually mounted. The mount command without options will display all mounted filesystems as will as the df command.

With the umask=222 option you do not need the rw option.

WhiteChedda 10-24-2004 07:40 PM

Quote:

Originally posted by xephyr
.........
Maybe I didn't make myself clear enought......

I can access the drive, and by that I mean I can click it and open it
but there is nothing inside, it's empty, blank, with no icons or whatsoever

Sounds like you are just accessing the mounting point created for it, but it isn't mounted, so.
From a console type mount, and see if it is actually mounted.

Also NTFS write = no can do in linux right now.
I suggest you turn that off before you blow something up.

If you just want to read the NTFS parition as a user I suggest trying in fstab

/dev/hda8 /mnt/ntfs ntfs users,gid=100,umask=002,ro,noexec,nosuid

This should work fine for just reading the partition.

If you want limited user reading of it, create a new group, add the memebers you want to be able to read it and replace the gid=100 part with the id from that group instead of 100.

jschiwal 10-26-2004 07:06 PM

You can see if a partition is mounted by entering the command 'mount'.

You can also read the /etc/mtab file.


All times are GMT -5. The time now is 09:22 AM.