LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-07-2015, 11:28 AM   #1
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Rep: Reputation: 0
I don't think Crossfire is working


Ok, so I finally seem to have gotten my graphics drivers installed and running correctly, but now I'm facing an issue with getting Crossfire enabled.
My laptop has 2x 5870 graphics cards in it and I'm trying to enable both for Crossfire, but I don't believe anything I'm trying is working. The in-game performance I'm getting seems to indicate that crossfire definitely isn't working, along with checking some of the settings that I know of/can find.

If I open the AMD Catalyst Control Center GUI, Crossfire shows as disabled. If I enable it I get told to reboot in order for the settings to take effect. When I do reboot and go back into AMD Catalyst Control Center, it's still disabled.

If I run,
Code:
aticonfig --lsch
Then I get the following output,
Code:
Multiple GPU chain for adapter 0, status: Crossfire is enabled
  0. 02:00.0 AMD Mobility Radeon HD 5800 Series
  1. 03:00.0 AMD Mobility Radeon HD 5800 Series
This was from following a tutorial I found about setting up a GPU chain. Whilst that seems to say that Crossfire is enabled (Though I think that might just mean the chain is capable of Crossfire rather than Crossfire itself being enabled), if I run
Code:
aticonfig --lscs
Then I get,
Code:
    Candidate Combination: 
    Master: 2:0:0 
    Slave: 3:0:0 
    CrossFire is disabled on current device
    CrossFire Diagnostics:
    CrossFire can work with P2P mapping through GART
    Dongle Capabilities: support PASSTHROUGH |INTERLINK_SW_AFR | INTERLINK_AUTO_AFR | INTERLINK_BLACKING | INTERLINK_SUPERAA
Which says that Crossfire is disabled.

It should be doable I believe, as listing my candidates shows,
Code:
Master adapter:  0. 02:00.0 AMD Mobility Radeon HD 5800 Series
    Candidates:  1. 03:00.0 AMD Mobility Radeon HD 5800 Series
I don't have any secondary displays connected to the laptop, just the built-in display.

From looking at the aticonfig help, I think I need to do something involving the following commands,
Code:
aticonfig --mgpu-sls={on|off}
aticonfig --crossfire={on|off}
But I don't quite know what parameters I should be using with them.

Incase it's needed, I'm running the latest version of Debian.

Last edited by Lagamorph; 06-07-2015 at 11:30 AM.
 
Old 06-10-2015, 10:08 AM   #2
/dev/random
Member
 
Registered: Aug 2012
Location: Ontario, Canada
Distribution: Slackware 14.1, LFS-current, NetBSD 6.1.3
Posts: 262

Rep: Reputation: 101Reputation: 101
Try this

Code:
aticonfig --adapter=0,1 --cfa
aticonfig --adapter=0,1 --crossfire=on
 
Old 06-10-2015, 07:25 PM   #3
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, running the first command I get this output,
Code:
Multiple GPU chain added
Warning: X needs to be restarted before MGPU changes take effect.
I'm guessing that's normal for the command.


For the second command though I get this,
Code:
Warning: No MGPU chain defined for master adapter 1
Crossfire chain(s) enabled
Warning: X needs to be restarted before CrossFire changes take effect.
The "No MGPU chain defained for master adapter 1" part slightly concerns me though. Is that normal? Is it just saying that there's no chain after adapter 1 since I only have adapters 0 and 1?
 
Old 06-10-2015, 08:31 PM   #4
/dev/random
Member
 
Registered: Aug 2012
Location: Ontario, Canada
Distribution: Slackware 14.1, LFS-current, NetBSD 6.1.3
Posts: 262

Rep: Reputation: 101Reputation: 101
I think that is correct, what happens when you restart X and run the second command? (not the whole machine)
 
Old 06-11-2015, 03:52 AM   #5
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
I've been rebooting the machine. How do I restart just X? I've tried googling how to do it but I can't seem to find how to do it on KDE.

EDIT - Ok, figured it out,
Code:
sudo service kdm restart
I've run the first command, then restarted X, then run the second command, then restarted X, but I can't see any difference. Both the --lscs and --lsch commands return exactly the same results as above.

Last edited by Lagamorph; 06-11-2015 at 04:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is crossfire and SLI so destructive and worthless? Holering Linux - Hardware 3 02-26-2015 06:02 PM
information of Crossfire and how to use Crossfire zeeshanayub Linux - Newbie 1 03-15-2014 06:35 AM
Opteron 1207 and Crossfire? Vegetarian Smoker General 0 04-23-2007 10:45 PM
X crash using ATI driver 8.28.8 on CrossFire system LAj Linux - Hardware 7 11-14-2006 04:44 PM
Problems running game Crossfire gusjones Ubuntu 2 06-17-2005 06:59 AM


All times are GMT -5. The time now is 06:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration