LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 04-30-2015, 11:02 AM   #1
b4str1
LQ Newbie
 
Registered: Apr 2015
Posts: 11

Rep: Reputation: Disabled
Question I don't have sound in Slackware 14.1 64bits


Hi, I am new in Slackware. I installed it with KDE.
When I am starting the system this appears:
http://oi60.tinypic.com/20f7qkl.jpg

But there is a good new. When I run "aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav" (A command that I found surfing in Internet) The pc give me sound.


In no other way I have sound. What can I do? Thanks a lot

Sorry for my basic english
 
Old 04-30-2015, 11:01 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,342
Blog Entries: 12

Rep: Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730
What is your sound card? Running the command lspci in a terminal should report that information.

I've gotten those same KDE messages. I always ignore them and make them go away. I do not think, though I may be wrong, that they have any bearing on the larger issue.

Last edited by frankbell; 04-30-2015 at 11:03 PM.
 
Old 05-01-2015, 12:15 AM   #3
b4str1
LQ Newbie
 
Registered: Apr 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
What is your sound card? Running the command lspci in a terminal should report that information.

I've gotten those same KDE messages. I always ignore them and make them go away. I do not think, though I may be wrong, that they have any bearing on the larger issue.
Thanks. I solved it changing in /etc/inittab
From:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
To:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

I wonder why this change solved the problem xD
 
Old 05-01-2015, 12:23 AM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by b4str1 View Post
Thanks. I solved it changing in /etc/inittab
From:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
To:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

I wonder why this change solved the problem xD
Changing the runlevel from 3 to 4 should of given you a GUI.
If changing the runlevel fixed the sound I'd like to know how?

-:-That's perplexing.-:-
 
Old 05-01-2015, 12:58 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,430

Rep: Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349
This thread is a duplicated in the the Slackware forum. http://www.linuxquestions.org/questi...ts-4175541255/

The explanation for the effect by changing run levels when a user has not been explicitly made a member of the audio group when the adduser command was used is here. http://www.linuxquestions.org/questi...ml#post5355701
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Blaster Audigy Fx on Slack 14.1 (64bits) Alekzar Slackware 17 03-06-2015 10:25 AM
Skype and Slackware 13.1 64bits qlands Slackware 5 02-17-2011 08:19 AM
[SOLVED] Firefox 3.6.12 for Slackware 13.1 64bits qlands Slackware 5 01-26-2011 04:42 AM
Slackware 13 64bits. glore2002 Slackware 9 08-28-2009 02:38 PM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration