LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2014, 12:36 AM   #1
godwin.a
LQ Newbie
 
Registered: Feb 2014
Posts: 1

Rep: Reputation: Disabled
I deleted the Eth0 configuration information from vim ifcfg eth0. How to retrieve it?


I deleted the Eth0 configuration information from vim ifcfg eth0. How to retrieve it?
 
Old 02-08-2014, 03:58 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
If you've closed the vim session, its basically gone.
You could have a look for a hidden file ending in '.swp' which is a backup vim uses whilst its running.
Which distro are you running?
Some distros may re-create a basic version upon reboot, based on /etc/udev/rules.d/70-persistent-net.rules or similar.

Ultimately you could try a tool like photorec or testdisk, but its hard work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Network eth0 activated upon boot in ifcfg-eth0; but no network connection after login TomRaaijmakers Linux - Networking 1 06-17-2010 09:29 AM
fedora/redhat: ifcfg-eth0 and ifcfg-eth1 Shaun2222 Linux - Networking 9 01-23-2008 04:25 PM
eth0 not coming up at bootup even when configured in ifcfg-eth0 djcham Linux - Networking 1 12-04-2006 09:09 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 06:33 PM
ifcfg-eth0 configuration problem shyam Linux - Networking 2 08-06-2003 07:25 AM


All times are GMT -5. The time now is 10:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration