LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2003, 09:44 AM   #1
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Rep: Reputation: 15
I cant get the OS boot menu


i have just installed Linux mandrake 9.1alongside Win XP, when i boot up i get the Linux boot menu OK but i dont get an option for Windows XP

what have i done, have i broke it already ?.

i can can still boot into windows ok but it is a long winded process

tim
 
Old 09-20-2003, 09:53 AM   #2
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
boot into linux and edit your /boot/grub/grub.conf or /etc/lilo.conf-depending on you are using grub or lilo.
in your grub.conf,

#
# Sample boot menu configuration file
#

# Boot automatically after a minute.
timeout 60 << here you time setting

# By default, boot the second entry.
default 1 << here you choose which OS run 1st

# Fallback to the first entry.
fallback 0

title Windows XP
rootnoverify (hd0,0)
chainloader +1
makeactive

# For booting Linux
title Linux
root (hd0,7)
kernel /boot/vmlinuz-2.2.17 root=/dev/hda8
#end
-----------------
dont forget to replace hd0 with the one corresponding to your windows boot device drive.
if using lilo,
add the following to /etc/lilo.conf
#begin
other=/dev/hda2
label=w2k
#end
{you can see all your partitions and corresponding device drives using 'fdisk -l'
 
Old 09-20-2003, 09:55 AM   #3
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
also
in grub,
hda is hd0
hda1 is (hd0,0)
hdb is hd1
hdb3 is (hd1,2)
 
Old 09-20-2003, 09:59 AM   #4
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
thanks lads, i'll give that a go, fingers crossed.

tim
 
Old 09-20-2003, 11:12 AM   #5
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
ok friend, i have found this file below in the etc/lilo.conf, what do i do to it, it only really needs two entries Linux and Win XP

my windows partition is hda, i see that is in the first line of the file ?, i'm confused.

i know that when this file is loaded on boot up it loads linux by default, i dont know what the others do, how can i edit it to have a choice of linux or windows.

at the moment the only way i have a choice is to use the CD1 and type F1, rescue and select either reinstall linux boot loader OR restore windows boot loader. any more help would be very much appreciated. tim


boot=/dev/hda
map=/boot/map
default="linux"
keytable=/boot/uk.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda3
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi acpi=off quiet"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda3
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi acpi=off"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda3
initrd=/boot/initrd.img
append="devfs=nomount hdc=ide-scsi acpi=off failsafe"
read-only
other=/dev/fd0
label="floppy"
unsafe
 
Old 09-20-2003, 11:20 AM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
You havent got an entry for Windows at the moment.........if it is /dev/hda1 then

Put this in at the bottom

other = /dev/hda1
table = /dev/hda
label = "Windows"

then save the file

then type

/sbin/lilo

you can always change the default line later to Windows if you want but for now just try the above.

(boot=/dev/hda - this just tells you were LILO is installed to - in your case its the MBR)



Last edited by Skyline; 09-20-2003 at 11:25 AM.
 
Old 09-20-2003, 11:40 AM   #7
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
o my god

i dont believe it, i have edited the file as you suggested kind sir, but i cant save it, i havent got permission !!!!!!!!!!!!!

tim
 
Old 09-20-2003, 11:42 AM   #8
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
You need to be root user to edit lilo.conf succesfully

su
root password

kedit /etc/lilo.conf
 
Old 09-20-2003, 11:53 AM   #9
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
sorry to bea bother mate, but where do i type that please

i thought i was the root user, the only user

tim
 
Old 09-20-2003, 11:56 AM   #10
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Open a Console - type it there
 
Old 09-20-2003, 12:24 PM   #11
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
how and where do i do that please mate.

i am only beginner, so be gentle with me LOL, tim
 
Old 09-20-2003, 12:34 PM   #12
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
K
Terminals
Console (Terminal Program)

su
root password

kedit /etc/lilo.conf

Put this in at the bottom

other = /dev/hda1
table = /dev/hda
label = "Windows"

then save the file

close it

then as root user again

/sbin/lilo

to make the changes take effect
 
Old 09-20-2003, 12:43 PM   #13
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
ok i found something called KONSOLE
i type SU ok
but when i type root password

and root + my actual password

it says command not found



tim
 
Old 09-20-2003, 12:46 PM   #14
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
its

su

not

SU

also when people say to type your root password they mean type your actuall root password - not the words "root password"

Last edited by Skyline; 09-20-2003 at 12:47 PM.
 
Old 09-20-2003, 01:15 PM   #15
timmy toad
Member
 
Registered: Sep 2003
Location: Flitwick, BEDS, UK
Distribution: mandrake 9.1
Posts: 45

Original Poster
Rep: Reputation: 15
Thanks a lot mate i have succesfully done it and i am rather pleased with myself, i've been trying to get that sorted out all day !!!! LOL

perhaps i should start another post, but can i ask what the other items in the menu do, because i only need Linux and Windows XP ???

BTW i found out that spaces arent allowed in the Label



thanks again for your perciverance with me

tim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot SUSE/XP But SUSE wont let me boot or see boot menu Hairulfr SUSE / openSUSE 9 08-17-2005 01:57 PM
Dual Boot : Making Windows First Option in boot menu Maxwell Rain Linux - Software 3 11-27-2004 04:00 PM
About boot menu on a dual boot sys Gethyn Linux - Newbie 4 10-15-2004 12:30 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-13-2004 12:40 AM
cd locked out on floppy boot! Help boot menu rooman Linux - General 5 08-07-2002 03:56 PM


All times are GMT -5. The time now is 06:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration