LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2010, 10:02 PM   #1
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Rep: Reputation: 0
i cant get any music player program to work correctly. ubuntu 10.10


hi im using ubuntu 10.10 on a dell e1505 laptop with a x1400 graphics card. 2.5 gb ram and a core 2 duo 1.83. i also dual boot vista for lightroom only.

my huge problem is that every music player i try doesnt work correctly in some way. ive tried amarok, banshee, rhythmbox, songbird (wine), exail, one with a name that started with a "g" and was long and strange. i forget the name now. i think i tried a few others too. i also have about 40k songs but ive only loaded my entire library into rhythmbox. the others i just tried with one cd.

my problem is that they either crash right away, things dont work such as the eq, or they freeze the entire pc. rhythmbox is the best i can do and it freezes my entire pc after about an hour of use...sometimes quicker.

something that could possibly be of importance...i could not get 10.04 to work with my external monitor on this pc. it made the entire screen very wiggly looking. 10.10 solved that. though it does flicker every once in awhile.

please tell me there is some way i can fix this...i really dont want to go back to vista.

im very new to linux so if you need to see some kind of log or report...please tell me how. thanks.
 
Old 10-17-2010, 10:31 PM   #2
longbow0
LQ Newbie
 
Registered: Jul 2005
Distribution: Debian
Posts: 20

Rep: Reputation: 2
you could try wine+foobar2000, it has a better organization of musics.
 
Old 10-17-2010, 10:36 PM   #3
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by longbow0 View Post
you could try wine+foobar2000, it has a better organization of musics.
i forgot all about foobar. i will give it a try. i would rather fix this problem if i can though.
 
Old 10-18-2010, 04:34 PM   #4
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
bump
 
Old 10-18-2010, 07:31 PM   #5
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
well it looks like gmusic browser works good. i would still like to fix this problem though so i can use any player i like.
 
Old 10-18-2010, 09:59 PM   #6
mericet
Member
 
Registered: Jul 2009
Posts: 50

Rep: Reputation: 8
Just a thought - I wonder if your sound card is functioning properly?
See if there is a proprietary driver available for your sound card :
System > Administration > Hardware Drivers
 
Old 10-18-2010, 10:06 PM   #7
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,352
Blog Entries: 12

Rep: Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731
Try starting a problem music player from the command line and noting any error messages, especially if it crashes.

If it locks your system, you may want to have a digital camera to take a picture of the display, rather than trying to write them down in real time.
 
Old 10-19-2010, 07:00 AM   #8
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
You can try:
Linux Mint Forums • View topic - Fix for exaile, pitivi and listen
Quote:
Remove the package "python-gi" it fixes them all, I did it and got exaile 3.2 working. This fixes the problem with it crashing when you try to play a song. The problem with the exaile 2.14 in the default repo not starting is another problem
 
Old 10-19-2010, 03:27 PM   #9
thandermax
Member
 
Registered: Jun 2005
Distribution: OpenSUSE 10.3 , 11.2 , Solaris 10, Ubuntu 9.10
Posts: 84

Rep: Reputation: 16
Red face install Xine or VLC

Quote:
Originally Posted by longbow0 View Post
you could try wine+foobar2000, it has a better organization of musics.
Try installing Xine first (Xine download link) , it is used by many player as backend for decoding MP3/FLAC/MP4/RM etc...


Otherwise you can try VLC player also (all of the plugins are inbuilt/included in same package)
 
Old 10-19-2010, 03:46 PM   #10
beetleman64
LQ Newbie
 
Registered: Dec 2009
Location: Glasgow, Scotland
Distribution: Ubuntu 11.04
Posts: 25
Blog Entries: 11

Rep: Reputation: 0
What format are your songs in? If they're MP3s then you'll need to install the decoder from the software centre. Alternatively, you could install the Ubuntu Restricted Extras package which plays a wider range of formats (although patents are an issue if you're in the US or Japan).
 
Old 10-19-2010, 05:51 PM   #11
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
thanks for all the suggestions. im going to try them out now.

on thing that might be of importance is that when i try to update in the update manager i get this error "W:Failed to fetch http://ppa.launchpad.net/webupd8team...rce/Sources.gz 404 Not Found
, E:Some index files failed to download, they have been ignored, or old ones used instead." i did manage to get all the updates by installing a few at a time instead of all at once. though if i click on "check" that error still pops up.
 
Old 10-19-2010, 06:02 PM   #12
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by beetleman64 View Post
What format are your songs in? If they're MP3s then you'll need to install the decoder from the software centre. Alternatively, you could install the Ubuntu Restricted Extras package which plays a wider range of formats (although patents are an issue if you're in the US or Japan).
they are all mp3's. i had all the gstreamer codec packs installed except for the pack for aac, xvid, mpeg2, fadd. i dont have any of those music files but im installing it anyways.
when i go to install the extras it says i need to remove ffmpeg codec library and ffmpeg utlity library. it also gives me an option to install anyways. i dont have any music that ive bought online. i assume thats what those codecs are for. so im not sure if i even need them.

also all my music is on an external hard drive, in case that matters.
 
Old 10-19-2010, 06:13 PM   #13
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mericet View Post
Just a thought - I wonder if your sound card is functioning properly?
See if there is a proprietary driver available for your sound card :
System > Administration > Hardware Drivers
i dont see the option "hardware drivers" all i see is "additional drivers" it scans and only gives options for my wireless card.
 
Old 10-19-2010, 06:41 PM   #14
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by craigevil View Post
how do i remove "python-gi"?

edit to add...i just did a search in synaptic package manager and i didnt see "python-gi" not sure if thats where i should be looking or not.

Last edited by chinolofus; 10-19-2010 at 06:58 PM.
 
Old 10-19-2010, 06:47 PM   #15
chinolofus
LQ Newbie
 
Registered: Oct 2010
Distribution: ubuntu 10.10
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by frankbell View Post
Try starting a problem music player from the command line and noting any error messages, especially if it crashes.

If it locks your system, you may want to have a digital camera to take a picture of the display, rather than trying to write them down in real time.
this is what i got when i opened rhythmbox

(rhythmbox:2418): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
** Message: pygobject_register_sinkfunc is deprecated (GstObject)

(rhythmbox:2418): Gtk-WARNING **: /build/buildd/gtk+2.0-2.22.0/gtk/gtkliststore.c:329: Invalid type void

Traceback (most recent call last):
File "/home/ryan/.gnome2/rhythmbox/plugins/rbeq/__init__.py", line 40, in activate
shell.props.shell_player.play()
glib.GError: Current playing source is NULL
** (rhythmbox:2418): DEBUG: Syncdaemon not running, waiting for it to start in NameOwnerChanged
** (rhythmbox:2418): DEBUG: Loading the real store page

** (rhythmbox:2418): WARNING **: Got less number of items in credentials hash table than expected!
** (rhythmbox:2418): DEBUG: navigation requested to https://one.ubuntu.com/music/store-no-token

(rhythmbox:2418): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:2418): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:2418): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:2418): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:2418): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:2418): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed
** (rhythmbox:2418): DEBUG: navigation requested to http://stores.7digital.com/default.a...80&partner=983


im letting the music play nonstop now so when it freezes i will post the error message.

Last edited by chinolofus; 10-19-2010 at 06:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does this simple Java program work correctly under Windows but not Fedora 10? arashi256 Linux - Newbie 7 09-05-2014 09:22 PM
LXer: Minitunes (A.k.a. 'Just Another Music Player, Only Better') 0.1 Released! [Ubuntu PPA] LXer Syndicated Linux News 0 07-05-2010 03:20 PM
LXer: Exaile Music Player - Music Player for GTK+ in openSUSE LXer Syndicated Linux News 0 08-31-2008 01:50 AM
LXer: Audacious - Lightweight Music Player for Ubuntu LXer Syndicated Linux News 0 01-28-2008 09:00 PM
LXer: Install Songbird Music Player in Ubuntu LXer Syndicated Linux News 0 02-22-2007 03:16 PM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration