LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-27-2002, 06:34 PM   #1
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Rep: Reputation: 15
I can't get SWAT to work!


I can't seem to get SWAT to work. Everytime I try to connect through my browser using http://localhost:901 it gives me a message stating "a connection with the server cannot be established" SWAT is listed as port 901 in /etc/services and Samba is working just fine (can get to it from my windoze box) but SWAT won't come up. Pls help. Thanks!
 
Old 11-27-2002, 07:17 PM   #2
c0c0deuz
Member
 
Registered: Aug 2001
Location: Qc, Canada
Distribution: RedHat, Mandrake, FreeEOS
Posts: 336

Rep: Reputation: 30
It is possible that your firewall rules block swats port to connect. Go in gnome extra system tools lockkit and completely disable the firewall for a try. If it works than you'll have to soften the rules a bite...
 
Old 11-27-2002, 08:13 PM   #3
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Original Poster
Rep: Reputation: 15
thanks c0c0deuz, but no luck. I actually have all firewalling turned off completely.
 
Old 11-27-2002, 09:19 PM   #4
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Have you made the appropriate changes to either inetd.conf or xinetd.conf?
 
Old 11-27-2002, 11:06 PM   #5
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Original Poster
Rep: Reputation: 15
no inetd.conf seeing as how I am running RH 7.3 but here is the weird part, I have a little tutorial on SWAT telling me to put a line similiar to the following in xinetd.cof

swat stream tcp nowait.400 root /usr/sbin/swat swat

I am assuming that this is a line like what I should have in my actual xinetd.conf file. I figured the /usr/sbin/swat would be the directory where swat actually resides, correct? The weird part is I can't find swat anywhere??!?! Any clues?
 
Old 11-28-2002, 04:21 AM   #6
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
Starting RHL 7.x, you can enable swat using this command:

/sbin/chkconfig swat on

This was discussed about 2 or there days ago (and also a long time ago ) so you might want to search for it for more details.

And don't forget the firewall suggestion above
 
Old 12-02-2002, 09:44 PM   #7
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Original Poster
Rep: Reputation: 15
damn, i thought that was going to work. I think my whole problem is that I cannot find swat anywhere on my system? It's weird. I ran the "/sbin/chkconfig swat on" command like recommended from above, but got an error msg stating "error reading information on service swat: no such file or directory" Anymore suggestions? Thanks again guys!
 
Old 12-02-2002, 10:41 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,965

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Are you sure swat is installed?
 
Old 12-03-2002, 12:36 AM   #9
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Original Poster
Rep: Reputation: 15
i installed all packages upon original installation. I assumed swat would be included. Is it not? Anyways, I downloaded and installed it from an RPM package. I actually just formatted my RH box and am reinstalling, hoping to get it to work. Thanks for all of your guys' help. Really appreciate it.
 
Old 12-11-2002, 09:52 AM   #10
PeterC1
LQ Newbie
 
Registered: Sep 2001
Location: Louisville Kentucky
Distribution: Now use RH 7.3 and RH 8.0
Posts: 16

Rep: Reputation: 0
Granny - had the same problem. You need to edit /etc/xinetd.d/swat to allow you to connect to SWAT. Change the default line disable=yes to disable=no then you must restart xinetd from the terminal with the line /etc/init.d/xinetd restart <enter> you will then be able to start SWART which uses a browser window. This will put you into the GUI for configuring SAMBA. Under RH 8.0 you will find SWAT "hidden" in EXTRAS - Server Setttings where the only folder is SAMBA configuration (Swat) then when you open that it will take you directly to your browser and Swat. Then the fun begins --
Hope this helps

Last edited by PeterC1; 12-11-2002 at 09:56 AM.
 
Old 12-11-2002, 01:28 PM   #11
granny
Member
 
Registered: Nov 2002
Distribution: RH
Posts: 141

Original Poster
Rep: Reputation: 15
Thanks for responded pete, I actually just wiped my box and reinstalled RH 8.0, SWAT is working fine now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How does /sbin/chkconfig swat on work ? ramki Linux - Networking 12 12-26-2002 12:56 PM
Swat jwithers1 Linux - Networking 2 09-26-2002 02:48 PM
SWAT does not work when calling localhost:901 themorph Linux - Networking 2 03-07-2002 12:04 AM
Swat cliffyman Linux - Networking 4 12-20-2001 02:42 AM
getting swat / samba to work with RH7.1 workstation install cliffyman Linux - Newbie 3 11-13-2001 12:25 PM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration