LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2008, 06:53 AM   #1
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Rep: Reputation: 15
I can't find my codec folder


Hi, i was told that my codec folder is at /usr/lib/win32/ but i cannot find it. How?
 
Old 01-03-2008, 06:56 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
What exactly are you trying to do? If you're trying to install MPlayer codecs, then you may need to create the directory if it doesn't exist, or maybe the codecs are already in /usr/lib/codecs. Please give us more info on what you're trying to accomplish.
 
Old 01-03-2008, 07:01 AM   #3
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Original Poster
Rep: Reputation: 15
I want to install win32 codec that can play rmvb format. I cannot play rmvb format on mplayer.
 
Old 01-03-2008, 07:15 AM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209
On which distro are you trying to do it?

On my Debian and F8 all the codecs are in /usr/lib/codecs/

Just unpack the codecs that you downloaded and copy (as root) them to /usr/lib/codecs/
If you don't have the directory 'codecs' - create it as root: mkdir /usr/lib/codecs
 
Old 01-03-2008, 07:20 AM   #5
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Original Poster
Rep: Reputation: 15
I am using Ubuntu 7.10, i didnt have /usr/lib/codecs/ or /usr/lib/win32. where can i install my codecs?
 
Old 01-03-2008, 07:22 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Create the directory. It doesn't matter which one you use to be honest, you just need to tell MPlayer and whatever software where to find the codecs.
 
Old 01-03-2008, 07:25 AM   #7
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209
In case of Ubuntu, unless you changed it, you can't log in as root, you'll probably need to use 'sudo'

eg. sudo mkdir /usr/lib/codecs
type your password
 
Old 01-03-2008, 07:28 AM   #8
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Original Poster
Rep: Reputation: 15
How can i set mplayer to locate my codecs folder?
 
Old 01-03-2008, 07:29 AM   #9
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978
You can go to the Mplayer download page, download the binary package (see section "Binary Codec Packages") that matches your system and unpack them under /usr/lib/win32, e.g. if you have downloaded the package called essential_20071007.tar.bz2
Code:
sudo mkdir /usr/lib/win32
sudo tar -C /usr/lib/win32 -jxvf essential_20071007.tar.bz2
directory /usr/lib/win32 is that used by default in Ubuntu.
 
Old 01-03-2008, 07:30 AM   #10
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209
don't worry about it, if you copy the codecs to the above mentioned location, mplayer will find it.

Once you've done it, try to play some rmvb or mov file, and you'll check if mplayer has found the codecs
 
Old 01-03-2008, 07:32 AM   #11
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Original Poster
Rep: Reputation: 15
i already to do, but i still cannot open rmvb format video.
 
Old 01-03-2008, 07:37 AM   #12
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209
try 3 locations for codecs, one of them must work on Ubuntu. According to mplayer's documentation the default location is /usr/local/lib/codecs/ for mplayer built from the source. If you use a prebuild package, it should be /usr/lib/codecs.
In the past /usr/local/lib/win32 or /usr/lib/win32 was the default directory,
 
Old 01-03-2008, 07:55 AM   #13
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Original Poster
Rep: Reputation: 15
i tried all already. but still cannot. error occur when i open rmvb format. the error is Error Opening/initializing the selected video_out(-vo) device.
 
Old 01-03-2008, 08:00 AM   #14
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209
go to the mplayer preferences, go to the video tab and change the device to xv (i believe that's the one you need)
 
Old 01-03-2008, 08:02 AM   #15
tahrenyie85
Member
 
Registered: Aug 2007
Location: Malaysia
Distribution: FC, Ubuntu
Posts: 50

Original Poster
Rep: Reputation: 15
Thx, i can play rmvb format now after i tried on other mplayer. Last time i used mplayer movie player, now i use gnome mplayer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can not find codec for audio format 0x56444152 tiwarylokesh Linux - Newbie 3 12-20-2007 05:27 AM
Error in MPlayer with video out. Can't find codec-dir. Tillus Linux - Software 2 08-29-2007 10:55 AM
Cannot find codec for audio format 0x56444152 allelopath Linux - Software 1 05-26-2005 02:35 PM
MPlayer cannot find audio codec seagreen Linux - Software 3 02-21-2005 04:09 AM
Can't find codec for audio format 0xA higunj1 Linux - General 6 03-22-2004 02:58 PM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration