LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2006, 10:18 PM   #1
nghoanganh
LQ Newbie
 
Registered: Mar 2006
Posts: 4

Rep: Reputation: 0
I can't compile HelixPlayer's source.


I download HelixPlayer's source from this address:
//download.fedora.redhat.com/pub/fedora/linux/core/4/SRPMS/HelixPlayer-1.0.4-4.src.rpm
This package includes five files:
- hxplay-1.0.4.tar.bz2
- hxplay-1.0.4-nptl.patch
- HelixPlayer-1.0.beta20040615-cvs-no-update.patch
- HelixPlayer-1.0.3-disable-asm.patch
- HelixPlayer-1.0.3-use-compat.patch
I run two commands:
# tar jxpf hxplay-1.0.4.tar.bz2
# patch -p0 <hxplay-1.0.4-nptl.patch
After that :
# cd hxplay-1.0.4; make
Then the result is:
Build complete, 11 of 112 modules failed.
And I try:
# make clean; make
And there is error:
../../audio/fixptutil/pub/math64.h: In function 'MulShift31':
../../audio/fixptutil/pub/math64.h:163: error: inconsistent operand constraints in an 'asm'

I am just a newbie so I don't know how to repair.
Can anyone help me? Thank you very much!
 
Old 04-04-2006, 02:30 AM   #2
nghoanganh
LQ Newbie
 
Registered: Mar 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Is it true when I post this topic here?.
If there is something wrong where can I find the answer for my problem?
Thank you very much!
 
Old 04-04-2006, 10:58 AM   #3
lurker79
Member
 
Registered: Jan 2005
Location: UK
Posts: 55

Rep: Reputation: 16
source rpms you usually rebuild with rpmbuild
when installing this src rpm on the system it will place files under /usr/src/redhat
to rebuild a binary rpm package run
rpmbuild -bb /usr/src/redhat/SPECS/<name of spec file>
this will then place a new binary rpm under /usr/src/redhat/RPMS
If this build fails it should give you more clues as to what is missing on your system, also it will be using a script under /var/tmp which may also help in troubleshooting.
 
Old 04-04-2006, 11:49 PM   #4
nghoanganh
LQ Newbie
 
Registered: Mar 2006
Posts: 4

Original Poster
Rep: Reputation: 0
I run the command :
# rpmbuild -bb HelixPlayer.spec like you showed me!
And the result is:
error: Failed build dependencies:
libtheora-devel >= 1.0alpha3-3 is needed by HelixPlayer-1.0.4-4.i386
Bad luck I can't find any scrip on /var/tmp and I also don't understand this problem.
In the content of HelixPlayer.spec I see:

Requires: libbluecurve.so%{libdepssuffix} %{_libdir}/mozilla/plugins
BuildRequires: libtheora-devel >= 1.0alpha3-3
BuildRequires: libvorbis-devel
BuildRequires: gtk2-devel
BuildRequires: python
BuildRequires: prelink
BuildRequires: libogg-devel

What can I do?
ps: Thanks lurker79 a lot
 
Old 04-05-2006, 05:59 AM   #5
lurker79
Member
 
Registered: Jan 2005
Location: UK
Posts: 55

Rep: Reputation: 16
you need to install the libtheora-devel rpm (with a version number greater or equal to 1.0alpha3-3).
Also worth checking that you have all the other packages mentioned in the BuildRequires lines in the spec file.
Any more problems while building the new rpm, post the errors here.
 
Old 04-06-2006, 02:39 AM   #6
nghoanganh
LQ Newbie
 
Registered: Mar 2006
Posts: 4

Original Poster
Rep: Reputation: 0
After download and install libtheora-devel-1.0alpha4-2.i386.rpm
Every thing now is okay. You are so kind, thanks a lot lurker79.
Best wish for you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't compile from source.... garyozzy Ubuntu 7 11-30-2005 05:00 PM
Compile source on other pc ??? sys7em Linux - General 1 11-01-2004 10:53 AM
Compile from source meodihia Debian 5 09-11-2004 01:29 PM
How to compile source??? Aranilion Programming 12 08-25-2004 01:44 PM
Still can't compile from source Nappa Slackware 1 12-27-2003 05:12 AM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration