LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2006, 01:31 PM   #1
ZoMBiE_KiLLeR
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Rep: Reputation: 15
Unhappy I broke my video driver (ATI)...


Hey everyone, to make a long story short I switched to (RedHat) Fedora Core 5 -DVD iso-. I tried to update my video card (ATI X800XL) diver (kmod-fglrx) stanton-finley.net/fedora_core_5_installation_notes.html#nVidia with yum but I did something wrong.


Now I get errors like (/usr/lib/ati-fglrx/libGL.so.1: cannot restore segment prot after reloc: Permission denied) When I go to the ScreenSaver settings in KDE. I chmod 777 all those files but that did not work.


I found some info on the topic here redhat.com/archives/fedora-test-list/2006-February/msg01565.html but I still do not know how to fix it.


All I need is to restore the video divers from the FC5 DVD so everything will be back to normal. Is there a way of doing this without re-installing the OS? Also does anyone know the command to enter the disply setup, Not the KDE one. Its like sax2 but for FC5?



p.s.
I messed everything up so now I get this erorr when trying to run Quake3:
Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: /usr/local/games/quake3/libGL.so.1: cannot open shared object file: No such file or directory
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem



Same file from the other erorr(libGL.so).
 
Old 04-26-2006, 01:45 PM   #2
fraz
Member
 
Registered: Nov 2004
Location: Edinburgh, Scotland
Distribution: Ubuntu
Posts: 148

Rep: Reputation: 15
The driver in use is found in the xorg.conf file in /etc/X11/
Go to the videocard section and look for the line with driver "fglrx"
or whatever it is and change it to driver "ati"
I think that will use the ati driver included with the distro, and you should be back to where you started. You might want to wait for confirmation from someone else first I don't have an ati myself
 
Old 04-26-2006, 02:47 PM   #3
ZoMBiE_KiLLeR
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
---------------------Here is an ls of the X11 DIR-------------------------------

total 116
drwxr-xr-x 3 root root 4096 Apr 25 12:06 applnk
drwxr-xr-x 2 root root 4096 Apr 21 09:44 fs
-rwxr-xr-x 1 root root 1426 Mar 14 18:16 prefdm
drwxr-xr-x 2 root root 4096 Feb 11 12:16 serverconfig
drwxr-xr-x 2 root root 4096 Feb 11 12:16 starthere
drwxr-xr-x 2 root root 4096 Feb 11 12:16 sysconfig
drwxr-xr-x 2 root root 4096 Apr 21 09:36 twm
lrwxrwxrwx 1 root root 18 Apr 25 13:46 X -> ../../usr/bin/Xorg
drwxr-xr-x 2 root root 4096 Apr 21 09:40 xdm
drwxr-xr-x 4 root root 4096 Apr 21 09:35 xinit
-rw-r--r-- 1 root root 547 Feb 16 09:50 Xmodmap
-rw-r--r-- 1 root root 2729 Apr 26 01:26 xorg.conf
-rw-r--r-- 1 root root 2837 Apr 25 13:41 xorg.conf.backup
-rw-r--r-- 1 root root 2747 Apr 25 13:38 xorg.conf.backup-ati-fglrx
-rw-r--r-- 1 root root 492 Feb 16 09:50 Xresources




--------------and heres whats inside the xorg.conf file-------------------------

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.

FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Samsung Samtron 75(M)E (Plus)"
DisplaySize 320 240
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Technologies Inc R430 [Radeon X800 XL] (PCIe)"
EndSection
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
---------------------------------------------------------------------------------



Says "radeon" but i dont see "fglrx". Should I change it?
 
Old 04-26-2006, 05:02 PM   #4
fraz
Member
 
Registered: Nov 2004
Location: Edinburgh, Scotland
Distribution: Ubuntu
Posts: 148

Rep: Reputation: 15
ok radeon is also one of the ati drivers you will have installed with the ati package.
to get things working (with the old driver) back up the xorg.conf file and change radeon for ati.
if things go pear shaped you won't be able to boot into X so be aware you may need to enter run level 3 and switch back to the xorg.conf file before editing or replace ati with radeon.
 
Old 04-26-2006, 06:54 PM   #5
ZoMBiE_KiLLeR
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Putting ati did not work but I still messed around with it untill I (kind of) fixed it...

(in root) I typed "yum remove kmod-fglrx" then I restarted. That uninstalled the driver.

And now I do not get erorrs. YAY!

Howvever, now I have a small problem. For some reason my desktop display settings do not say the same after restart.

Where in the xorg.conf file is the default settings.
 
Old 04-28-2006, 09:05 AM   #6
fraz
Member
 
Registered: Nov 2004
Location: Edinburgh, Scotland
Distribution: Ubuntu
Posts: 148

Rep: Reputation: 15
do you mean the settings for resolution? they are in the screen section under displaymodes which you don't seem to have.
e.g.
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1024x768"
        EndSubSection
EndSection
Just out of interest, are you giving up on the ati driver? I thought you were going to retry after getting back to preinstall. It looked like there was a missing dependancy from your previous output.
Anyway now you are rid of the previous driver install, here is what I was waiting to suggest:
Setup the livna repo if you haven't already, then use
Code:
yum install kernel-module-fglrx-$(uname -r)
 
Old 04-30-2006, 04:09 PM   #7
ZoMBiE_KiLLeR
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
The driver is working but now I have a new problem.
http://www.linuxquestions.org/questi...d.php?t=440063
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 7000 video driver Progmaker Linux - Hardware 3 02-04-2006 06:06 PM
ATI video driver on SUSE 10.0? danovich SUSE / openSUSE 1 10-08-2005 06:10 AM
ATI driver was installed - No Video rjbippes Linux - Software 4 12-21-2004 04:36 AM
ATI Video Card Driver Issue vegetacron Linux - Hardware 1 10-15-2004 10:28 PM
can't find ATI video card driver pobfosheezy Linux - Laptop and Netbook 1 09-22-2003 08:36 PM


All times are GMT -5. The time now is 10:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration