LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2010, 01:28 PM   #1
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
I broke apt-get again


Do you know what apt-get is really missing...An ignore button.
The title says it all:
Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run apt-get -f install to correct these:
the following packages have unmet dependencies:
libudev0: Depends: udev (= 151-3) but 0.125-7+lenny3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
E: apt-get failed
 
Old 03-30-2010, 01:31 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 164Reputation: 164
Are you using ubuntu or debian? What command did you run that is returning this? Try:

Code:
apt-get update
apt-get upgrade
What is the output? Have you tried what apt-get suggests? (-f install)?
 
Old 03-30-2010, 01:45 PM   #3
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
This happened when i tried to install compiz.
Quote:
Originally Posted by rweaver View Post
Are you using ubuntu or debian?
Debian
Quote:
What command did you run that is returning this? Try:

Code:
apt-get update
apt-get upgrade
Prints the same thing.
Quote:

What is the output? Have you tried what apt-get suggests? (-f install)?
Code:
apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer requred:
xserver-xorg-video-ati
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
udev
1 upgraded, 0 newly installed, 0 to remove and 90 not upgraded.
13 not fully installed.
Need to get 0B/429KB of  archives.
After this operation, 586 kb of additional disk space will be used.
Do you want to continue [Y/n]?y
Preconfiguring packages...
(Reading database ... 116947 files and directories cirrently installed.)
Prepaaring to replace udev 0.125-7+lenny3 (using .../archives/udev_151-3_i386.deb) ...
Since release 150, udev requres that support for CONFIG_FS_DEPRECATED feature is disabled in the running kernel.

Please upgrade your kernel before or while upgrading ude.
AT YOUR OWN RISK, you can force the installation of this version of uudev WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND PROBABLY WILL BREAK YOUR SYSTEM AT THE NEXT REBOOT by creating the /etc/udev/kernel-update file.
there is a safer way to update, do not try this unless you understand what you are doing

dpkg: error processsing /var/cache/apt/archives/udev_151=3+i386 (--unpack):
subprocess new pre-installation script error exit status
Errors were encountered while processing:
/var/cache/apt/archives/udev_151-3_i386.dev
E: Sub-processes /usr/bin/dpkg returned an error code (1)
E: apt-get failed.
That was hard to type out!
 
Old 03-30-2010, 01:55 PM   #4
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Smeeze,

What version of Debian are you running?,are you trying to upgrade from Lenny to Squeeze by any chance?.
 
Old 03-30-2010, 01:58 PM   #5
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Originally Posted by the trooper View Post
Smeeze,

What version of Debian are you running?
I dont know, it was the download on the debian page
Quote:
,are you trying to upgrade from Lenny to Squeeze by any chance?.
No. Just trying to install compiz window manager because of all the effects i hear about.

Last edited by smeezekitty; 03-30-2010 at 01:59 PM.
 
Old 03-30-2010, 02:03 PM   #6
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Ok,check what Debian version you are using with:

cat /etc/debian_version
 
Old 03-30-2010, 02:12 PM   #7
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
5.0.4
 
Old 03-30-2010, 02:22 PM   #8
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Ok,that's Lenny/Stable.

Quote:
Prepaaring to replace udev 0.125-7+lenny3 (using .../archives/udev_151-3_i386.deb)
This is what i don't understand,apt is looking to replace Lenny's udev with one from Testing/Sid.
This version udev(151-3) will not work the default 2.6.26 kernel in Lenny.
What does cat /etc/apt/sources.list give you?
 
Old 03-30-2010, 02:35 PM   #9
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Code:
deb cdrom:[Debian GNU/Linux 5.04 _Lenny_ - Official i386 CD Binary-1]
deb cdrom:[Debian GNU/Linux 5.04 _Lenny_ - Official i386 CD Binary-2]
deb ftp://sunsite.cnlab-switch.ch/mirror/debian/ unstable main contrib non-free
deb-src ftp://sunsite.cnlab-switch.ch/mirror/debian unstable main contrib non
deb-src http://volatile.debian.org/debian-volatile lenny main
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
deb ftp://ftp.uni-kl.de/debian-multimedia testing main
deb ftp://fpt.uni-kl.de/debian-multimedia unstable main
 
Old 03-30-2010, 02:48 PM   #10
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Well there's your problem your sources.list is a mess,big time!.
You have listings for Lenny,Testing and best of all Unstable.

Let's try to get you a better sources.list.
Make yours like this,assuming you are in the U.S:

Code:
#deb cdrom:[Debian GNU/Linux 5.04 _Lenny_ - Official i386 CD Binary-1]
#deb cdrom:[Debian GNU/Linux 5.04 _Lenny_ - Official i386 CD Binary-2]

deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.us.debian.org/debian/ lenny main contrib non-free

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free
Once you have done this,do an aptitude update && aptitude keep-all.
I would suggest using aptitude from this point forward.
Once you get this far and have no errors from aptitude,post back and i'll show you how to add the multimedia repository if you need it.
 
1 members found this post helpful.
Old 03-30-2010, 02:55 PM   #11
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Fixed!
 
Old 03-30-2010, 02:56 PM   #12
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Cool.
Post back if you have anymore problems with Debian.
 
Old 03-30-2010, 03:48 PM   #13
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 164Reputation: 164
*deleted dupe post*

Last edited by rweaver; 03-30-2010 at 03:50 PM.
 
Old 03-30-2010, 03:49 PM   #14
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 164Reputation: 164
Code:
# Main Debian Mirror
deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.us.debian.org/debian/ lenny main contrib non-free

# Security Updates Mirror
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

# Volatile Updates Mirror (SPAM/AV/Faster than Security Related Typically)
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

# Backports from testing/unstable for lenny.
deb http://www.backports.org/debian lenny-backports main contrib non-free
deb-src http://www.backports.org/debian lenny-backports main contrib non-free
To have access to even a broader range of things you can enable back ports and volatile (I highly recommend volatile, back ports is iffy, but you generally won't install anything from it automatically if you make a preferences file like the following...)

Code:
Package: *
Pin: release a=lenny-backports
Pin-Priority: 200
 
Old 03-30-2010, 04:33 PM   #15
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Originally Posted by the trooper View Post
Cool.
Post back if you have anymore problems with Debian.
I happen to have another problem now that you ask.
X is broken
It draws the gnome login screen slowly and once the screen is fully drawn, the screen goes black and it starts drawing it again.
It also looks like its 640x480.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broke my Apt-get ecturkum Linux - Newbie 8 02-28-2007 07:08 AM
HELP! I broke APT cerealdaemon Ubuntu 4 04-29-2006 11:03 PM
I broke apt, sort of coldsalmon Debian 4 06-08-2005 05:47 AM
apt-get broke! jon_k Linux - Software 1 11-07-2004 03:14 PM
Broke apt .5.20 Modify Linux - General 0 01-13-2004 01:37 AM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration