LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-01-2012, 05:36 AM   #1
ashwindgadhave@gmail.com
LQ Newbie
 
Registered: Feb 2012
Posts: 11

Rep: Reputation: Disabled
I am unable to find eht0 while execute ifconfig commang


Hello,

I have installed CentOs6 server in my virtual machine.
Whenver I fire ifconfig command I get below output on my screen

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 b) TX bytes:480 (480.0 b)

But I am not getting ethernet setting in that.
Because of it I am unable to install any package from any mirror.
Please let me know if u have any solution.
 
Old 05-01-2012, 06:09 AM   #2
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
By default ifconfig will only show interfaces that are up.
Code:
ifconfig -a
Will show all interfaces. You can bring the interface up using
Code:
ifconfig ethX up
Other than that you should look at whether the device is detected or not using lspci, lsmod etc, you may need drivers..
 
1 members found this post helpful.
Old 05-01-2012, 06:13 AM   #3
ashwindgadhave@gmail.com
LQ Newbie
 
Registered: Feb 2012
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hello

Thank you for your reply.

Can you please tell me how can I install drivers and what are they? because I am unable to connect to any mirror. Please guide me
 
Old 05-01-2012, 06:17 AM   #4
ashwindgadhave@gmail.com
LQ Newbie
 
Registered: Feb 2012
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hello,

Thank you fukawi1,

Now I am able to see eth0. But one problem is still exist.
I am not able to ping any website or able to download any package from mirror.
 
Old 05-01-2012, 06:26 AM   #5
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Well Occam's Razor suggests
Code:
# ifconfig eth0 up
# dhclient eth0
Is probably worth a shot. But other than that it really could be anything.
Is the host working? other guests? The VM may not be configured correctly.
You need to know how the VM network is configured on the host.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to locate eth0 with ifconfig in Fedora 12 toothpick Linux - Networking 3 04-28-2010 03:21 AM
failed to execute command : ifconfig <interface> create summersgone Linux - Networking 6 05-12-2009 11:04 AM
Unable to ifconfig in Fedora Core 3???? ajeetraina Linux - Newbie 2 12-07-2007 02:42 AM
Inquiries about eht0 and eht0:1 thok Linux - Newbie 2 11-29-2007 05:12 AM
Can't execute ifconfig at command line jhsuan Linux - Newbie 3 08-30-2002 08:57 PM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration