LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2015, 07:13 PM   #1
james frankham
LQ Newbie
 
Registered: Nov 2012
Posts: 29

Rep: Reputation: Disabled
I am trying to use the terminal in Fedora but it won't accept my password.


I have only just installed Fedora and am trying to get updates via

sudo yum update

and it won't accept my administrator password that I created on installing fedora.

Sorry, try again.
[sudo] password for tbird:
sudo: 3 incorrect password attempts.

Is my sudo password my administrator password or the password I use to log in. None of them work.
 
Old 06-15-2015, 07:26 PM   #2
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_10{.0|.1|.2}
Posts: 4,009
Blog Entries: 1

Rep: Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110Reputation: 2110
Sudo would expect your normal user's password, and that user must be enabled in the /etc/sudoers config file.

I am not sure how Fedora assigns sudoers by default, different distros do it differently.
 
1 members found this post helpful.
Old 06-15-2015, 07:48 PM   #3
Keith Hedger
Senior Member
 
Registered: Jun 2010
Location: Wiltshire, UK
Distribution: Linux From Scratch, Slackware64, Partedmagic
Posts: 2,307

Rep: Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566Reputation: 566
If the user is not in the sudoers file the error sudo outputs is to say so and zay that it will be reported not say that the password is incorrect, this may be bad syntax in the sudoers file, it's quite picky about syntax, can you post the sudoers file? after removing any sensitive bits.
 
1 members found this post helpful.
Old 06-15-2015, 07:56 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,658

Rep: Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257
"Is my sudo password my administrator password or the password I use to log in"

User's password. But you could have tried that.
 
1 members found this post helpful.
Old 06-15-2015, 08:40 PM   #5
james frankham
LQ Newbie
 
Registered: Nov 2012
Posts: 29

Original Poster
Rep: Reputation: Disabled
It's not the users password
 
1 members found this post helpful.
Old 06-15-2015, 08:43 PM   #6
james frankham
LQ Newbie
 
Registered: Nov 2012
Posts: 29

Original Poster
Rep: Reputation: Disabled
/etc/sudoers config file.

does anybody know where I find this sudoers file.
 
1 members found this post helpful.
Old 06-16-2015, 01:47 AM   #7
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,037

Rep: Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912Reputation: 1912
On F22 (which you should have installed if a recent install), you should get nag screens for using yum instead of dnf.
So I'll presume you're pre-F22.

I don't use sudo normally, but (in F22) it all looks like the above if you use the wrong user password.
The default sudoers file only has the wheel group (other than root) as authorised to all commands. If you didn't tick the box to be an admin, you probably aren't in the wheel group - "groups" will tell you.
As for sudoers, start with the manpage. As usual.
 
1 members found this post helpful.
Old 06-16-2015, 02:55 AM   #8
james frankham
LQ Newbie
 
Registered: Nov 2012
Posts: 29

Original Poster
Rep: Reputation: Disabled
Infact it is F22.

[bigbird@localhost ~]$ [bigbird@localhost ~]$ sudo yum update
[sudo] password for bigbird:
bigbird is not in the sudoers file. This incident will be reported.
[sudo] password for bigbird:


That is the output when I enter my log in password so it seems I'm not in the sudoers file.
I am very new to F22
 
1 members found this post helpful.
Old 06-16-2015, 03:32 AM   #9
timl
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Fedora,CentOS
Posts: 599

Rep: Reputation: 127Reputation: 127
Hi, you need to obtain superuser privileges with "su" - this does ask for your root password:

Quote:
[tim@lizard ~]$ su
Password:
[root@lizard tim]# visudo
visudo: /etc/sudoers.tmp unchanged
[root@lizard tim]# exit
[tim@lizard ~]$
Once you have the # prompt visudo takes you to the sudoers file wherever it lives. I usually search for "root" until I hit this line:

Quote:
root ALL=(ALL) ALL
I then duplicate that line and, in the duplicated line, replace root with your username.

after saving this file you have sudo privileges. Exit superuser and return to your normal login

HTH
 
1 members found this post helpful.
Old 06-16-2015, 08:16 AM   #10
Nightspirit322
LQ Newbie
 
Registered: Jun 2015
Location: Tampa
Distribution: Fedora/Ubuntu
Posts: 15

Rep: Reputation: Disabled
As said previously, Fedora doesn't have sudo configured by default. You can run the commands by using

su -c 'yum update'
 
Old 06-16-2015, 12:38 PM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,981

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
james frankham
you might want to do some research and READING on the operating system that you installed

Fedora DOSE NOT!!!! use " sudo" by default !!
-- and NEVER WILL !!!!


if you want to use sudo, YOU have to set it up

fedora like RHEL use "su " and " su -"
and that uses the ROOT password
 
Old 06-16-2015, 12:58 PM   #12
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,353

Rep: Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989Reputation: 1989
Quote:
Originally Posted by John VV View Post
fedora like RHEL use "su " and " su -"
and that uses the ROOT password
And every other Linux distribution under the sun, except Ubuntu and its derivatives.
 
Old 06-16-2015, 05:02 PM   #13
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,658

Rep: Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257Reputation: 2257
You can add yourself to sudoer's as noted by a gui.

You can switch user to any user with privileges with su command. su alone is default to root. If you switch user then you'll have to supply the password for the user you selected.

I generally never run as su except in times when you have to fix a goofy distro to accept sudo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iwconfig won't accept my network password newbiesforever Linux - General 7 05-26-2012 11:48 PM
gpodder won't download podcast with username and password on Fedora 12 Brian_Hayward Linux - Software 1 05-04-2010 11:15 PM
terminal will not accept anything brookshire Linux - Newbie 9 06-26-2009 06:12 AM
Text mode won't accept root password PorPorMe Linux - Newbie 2 02-07-2008 05:39 PM
Evolution woes: won't accept password and gives a bunch of errors MamaWombat Linux - Software 0 08-15-2007 10:30 PM


All times are GMT -5. The time now is 08:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration