LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-06-2004, 06:13 PM   #1
Gormless
Member
 
Registered: Oct 2004
Distribution: Fedora Core 2, Knoppix
Posts: 105

Rep: Reputation: 15
Unhappy Problem setting up Xorg-X11 on Gentoo Linux - Need Help!


I'm having difficulty configuring xorg-x11 for my system. This is what I initially did to set up xorg:

# emerge xorg-x11

Download and installation went fine, no problems I could detect whatsoever. Then I ran the following set of commands:

# env-update
# source /etc/profile

# Xorg -configure

At the end of this, it told me it had written /root/xorg.conf.new
So, I proceeded to test.

# X -config /root/xorg.conf.new

Now here is where all the problems turned up. Apart from the system information that was displayed, these are the errors that the test reported:


Parse error on line 49 of section Monitor in file /root/xorg.conf.new
The HorizSync keyword must be followed by a list of numbers or ranges.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found


I am really quite at a lost at how I can go about fixing whatever the problem is. Any help or advice would be greatly appreciated. Thanks for your time.

Last edited by Gormless; 10-06-2004 at 06:16 PM.
 
Old 10-06-2004, 06:29 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Well ... what does line 49 (and its neoughbours) look like?


Cheers,
Tink
 
Old 10-06-2004, 06:33 PM   #3
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Do you have another version of Linux installed that works? If so, reboot into that and mount the gentoo partition somewhere then edit the xorg.conf file. Looks like you need to change something on line 49. Try the values that work on your host system, or just copy the whole file across.
 
Old 10-06-2004, 06:54 PM   #4
Gormless
Member
 
Registered: Oct 2004
Distribution: Fedora Core 2, Knoppix
Posts: 105

Original Poster
Rep: Reputation: 15
Oops, forgot to mention what line 49 said. Sorry about that Tinks.

Line 49 under Monitor says:

HorizSync 1364735232.0 - 0.0

I don't understand what it means or how to "fix" it. Am I providing enough info?
 
Old 10-06-2004, 07:46 PM   #5
Gormless
Member
 
Registered: Oct 2004
Distribution: Fedora Core 2, Knoppix
Posts: 105

Original Poster
Rep: Reputation: 15
Question Xorg-X11 on Gentoo Linux -help!

I dont know what/how to fix the error in the /root/xorg.conf.new
This is what the section looks like containing the error:

Section "Monitor"
#DisplaySize 310 230 #mm
Identifier "Monitor"
Vendorname "DEL"
Modelname "DELL E771a"
HorizSync 1364735232.0 - 0.0
HorizSync 30.0 - 70.0
VertRefresh 892881472.0 - 0.0
Option "DPMS"
EndSection


Running the test # X -config /root/xorg.conf.new tells me that there is a parse error concerning:

HorizSync 1364735232.0 - 0.0

Any idea on what I should change/how I can fix this? I am really new to linux, so plz forgive my ignorance if this is something easy/ stupid. Don't know if this might help, but here is a link containing the specifications for my monitor:

http://support.dell.com/support/edoc...k/en/specs.htm
 
Old 10-06-2004, 08:04 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
The first value looks a bit weird, the 0.0 as the second value
is odd, too ... the syntax as such is ok. Can you give the whole
monitor section?


Cheers,
Tink
 
Old 10-06-2004, 08:04 PM   #7
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
I would set them to Horizontal scan range 31 kHz to 70 kHz (automatic)
Vertical scan range 50 Hz to 160 Hz (automatic) so it would be ection "Monitor"
#DisplaySize 310 230 #mm
Identifier "Monitor"
Vendorname "DEL"
Modelname "DELL E771a"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection
here is mine

Section "Monitor"
Identifier "EV730"
HorizSync 30-69
VertRefresh 50-120
Option "DPMS"
EndSection
 
Old 10-06-2004, 08:42 PM   #8
Gormless
Member
 
Registered: Oct 2004
Distribution: Fedora Core 2, Knoppix
Posts: 105

Original Poster
Rep: Reputation: 15
Thanks for the changes, they fix the error I was originally getting.

However, the test now displays the following:

(EE) R128(0) No DFP detected
Could not init font path element /usr/share/fonts/CID/, removing from list!

Stuck again....


Last edited by Gormless; 10-06-2004 at 08:51 PM.
 
Old 10-06-2004, 09:09 PM   #9
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Thats nothing to worry about,you can delete that line if you want to.Did you try startx?
 
Old 10-07-2004, 05:25 PM   #10
Gormless
Member
 
Registered: Oct 2004
Distribution: Fedora Core 2, Knoppix
Posts: 105

Original Poster
Rep: Reputation: 15
Question I am having trouble getting Xorg-X11 to work...

I am a new linux user running on the gentoo linux distro. After downloading and installing xorg via the "emerge xorg-x11" command and configuring it, I am stuck at getting it to run. This is what happens when I try to copy over the xorg.conf.new to /etc/X11/xorg.conf:

# cp /root/xorg.conf.new /etc/x11/xorg.conf.new
cp: cannot creat regular file '/etc/x11/xorg.conf' : No such file or directory

Am I supposed to create a directory first or something? I am just following a HOWTO manual on installing Xorg, and it doesnt list a step like that. Here is the link to the manual I am currently consulting for the installation and setup:

http://www.gentoo.org/doc/en/xorg-config.xml


Just for the heck of it, I tried running startx and apart from system information and some other info, here are the errors that turned up:

(EE) Unable to locate/open config file

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices


Also, when I run X -config /root/xorg.conf.new , I get one error telling me this:

(EE) R128(0): No DFP detected

I dont know what DFP is or if it important or not. Do I need to fix something in the config file? If so, what should iI fix?

If someone could provide some detailed steps on how to go about installing and setting up Xorg-X11 from where I currently am, that would be fantastic. If I'm not providing enough information, don't hesitate to ask for exactly what you need. Thanks alot of your time.

Last edited by Gormless; 10-07-2004 at 05:32 PM.
 
Old 10-07-2004, 05:34 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php


I have merged your three threads ... next time I'll close them
 
Old 10-07-2004, 05:46 PM   #12
Gormless
Member
 
Registered: Oct 2004
Distribution: Fedora Core 2, Knoppix
Posts: 105

Original Poster
Rep: Reputation: 15
Sorry Tinkster, I'll remember that nextime.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg-x11 6.8.2 problems... Regulus Linux - Software 4 09-18-2005 10:14 AM
xorg-x11-devel for Mandrake 10.1 Malibyte Mandriva 3 03-20-2005 03:31 AM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM
xorg-X11-6.8.1-1 + Mesa-6.1-1 estatik Mandriva 3 10-08-2004 01:51 AM
updating to X11 (Xorg) alexrait1 Slackware 10 06-07-2004 11:29 AM


All times are GMT -5. The time now is 09:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration