LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-29-2003, 01:39 PM   #1
rocketgo
Member
 
Registered: Oct 2003
Posts: 37

Rep: Reputation: 15
https


how do i get https to work?
 
Old 12-29-2003, 01:47 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
What version of apache? You have to have mod_ssl compiled to get https working.

You could try to search mod_ssl on the apache.org site, they have quite a lot of information regarding it, etc. Maybe that will get you started.
 
Old 12-29-2003, 01:47 PM   #3
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
what's wrong with it?
 
Old 12-29-2003, 01:50 PM   #4
rocketgo
Member
 
Registered: Oct 2003
Posts: 37

Original Poster
Rep: Reputation: 15
i am runing yellow dog linux with apache 2.0 i have looked at apache.org but it did not help me
 
Old 12-29-2003, 02:10 PM   #5
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by rocketgo
i am runing yellow dog linux with apache 2.0 i have looked at apache.org but it did not help me
Well, do you even have mod_ssl installed? Did you install apache yourself or is it the version that came with Yellow Dog? That's why its best to ask more specific questions instead of vague type questions, were not here to really rewrite howto's you know..

Where did you look on their site, I always find it very helpful with great information.
 
Old 12-29-2003, 02:12 PM   #6
duerra
Member
 
Registered: Oct 2003
Location: Where No One's Been... Spiral Out!
Distribution: FreeBSD
Posts: 201

Rep: Reputation: 30
Well, I don't know if you have MOD_SSL installed, but once you do, make sure that your httpd.conf is set to listen in on the SSL port (443)

#Where your LoadModule parts are in your conf
<IfDefine SSL>
LoadModule ssl_module modules/mod_ssl.so
</IfDefine>

#Include SSL Config
<IfModule mod_ssl.c>
Include conf/ssl.conf
</IfModule>

See here for a sample ssl.conf and a good description:
http://www.ccl.net/cca/software/UNIX...ssl.conf.shtml

Last edited by duerra; 12-29-2003 at 02:16 PM.
 
Old 12-29-2003, 02:30 PM   #7
rocketgo
Member
 
Registered: Oct 2003
Posts: 37

Original Poster
Rep: Reputation: 15
i thought apache 2.0 allready has mod_ssl installed
 
Old 12-29-2003, 03:19 PM   #8
duerra
Member
 
Registered: Oct 2003
Location: Where No One's Been... Spiral Out!
Distribution: FreeBSD
Posts: 201

Rep: Reputation: 30
It has to be compiled to be SSL-aware, which most are (for Linux), but even that does not mean that SSL is configured for your server (which it likely isn't).
 
Old 12-29-2003, 03:55 PM   #9
rocketgo
Member
 
Registered: Oct 2003
Posts: 37

Original Poster
Rep: Reputation: 15
what would be the best way to configure it?
 
Old 12-29-2003, 08:25 PM   #10
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: CentOS 5.5, Ubuntu 10.04, Linux Mint 11 gnome 64 bit
Posts: 336

Rep: Reputation: 36
Open your configuration file httpd.conf and search for:
# To use server-parsed HTML files
#
#AddType text/html .shtml
#AddHandler server-parsed .shtml

Remove the # before the AddType and commands. The AddType command instructs the server to return text or HTML for the content type whenever it serves a file with the extension .shtml. The AddHandler command instructs Apache to pass the contents of the file to mod_include. From there, it is up to mod_include to handle the response correctly.

Next, add the following directive either in your httpd.conf file, or in a .htaccess file:

Options +Includes

You will probably need to apply the Options to the specific directory where you want SSI enabled in order to assure that it gets evaluated last.

<Directory "/your/path to/htdocs">
Options Indexes +Includes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

This line tells Apache to execute server-side includes in the httpd directory. In order for these changes to take effect, you must restart the server.

su root
/usr/local/apache/bin/apachectl stop
/usr/local/apache/bin/apachectl start
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
https:// wwnexc Linux - Software 3 11-05-2005 11:57 PM
https Ammad Linux - Networking 3 04-20-2005 04:22 AM
https? rocketgo Linux - General 1 11-12-2003 08:22 PM
https spank Linux - Newbie 3 10-25-2003 02:08 PM
https Greg21 Slackware 2 06-20-2003 10:12 PM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration