LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2005, 12:35 PM   #1
pollo
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Rep: Reputation: 0
httpd -v shows nothing


I have installed Fedora Core 3 from box.
I have httpd running -- it shows the index.html with browser.

When I try to give commands:
# httpd -V
# httpd -v
# httpd -h

or any available parameters, HTTPD prints nothing to screen.
What I'm doing wrong?

# rpm -qa | grep httpd
system-config-httpd-1.3.1-1
httpd-manual-2.0.52-3.1
httpd-suexec-2.0.52-3.1
httpd-devel-2.0.52-3.1
httpd-2.0.52-3.1
 
Old 04-06-2005, 01:02 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
You will probably find that if you do 'which httpd', you won't get anything in return, either. That's because httpd in not in your path.
Do 'locate httpd | less', and scroll through the output. You will probably find the httpd executable in /usr/sbin.
Now, re-issue the command with full path to httpd, like so:
/usr/sbin/httpd -v, and you will get the output you seek.
 
Old 04-06-2005, 01:46 PM   #3
pollo
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
thanks for you reply.
I have httpd in my path:

[root@35 ~]# which httpd
/usr/sbin/httpd
[root@35 ~]# /usr/sbin/httpd -v
[root@35 ~]#

still nothing...
 
Old 04-06-2005, 03:35 PM   #4
pollo
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
well. I found out that when I turn selinux off http -v shows the info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
httpd default page shows code tommytomato Linux - General 3 03-09-2005 09:16 PM
service httpd status, results in httpd dead but subsys locked squadja Red Hat 2 09-11-2004 11:31 PM
snmp staus shows it running but on trying MRTG, it shows public@ipaddr not giving res swati220781 Linux - Networking 3 07-08-2004 06:32 PM
desktop shows on TV but movie shows black screen litrelord Mandriva 6 07-05-2004 06:10 AM
httpd chokes on ScriptAlias line in Apache httpd.conf lhoff Linux - Software 1 07-14-2003 11:32 PM


All times are GMT -5. The time now is 08:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration