LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2009, 02:54 AM   #1
jenniekingsland
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Rep: Reputation: 0
httpd daemon failing to start


Hi,

I am new to this so any help will be greatly appreciated.

I have searched Google but cannot find the answer to my problem.

I need to get arcserve running on a linux server using the web interface.

It works on one server you just enter the ip followed by the port number into the address bar and then it loads arcserve up.

I need this to to do the same for another server at a different site but it won't work.

I found some instructions that I need to get httpd daemon running but it won't

I did the following

stopgui
[root@snenmgmt ~]# startgui
ERROR: There was an error starting the httpd daemon.
Please examine the error messages and check the
/opt/CA/BrightStorARCserve/httpd/ directory.

I cant find anything in this directory so how do i get this to run?

I also did a cstatus which returned the below

[root@snenmgmt BrightStorARCserve]# cstatus
caservd 6887
cadiscovd 6898 6890
cauthd 6988
caloggerd 6989
cadbd 6990
camediad 7097 7096 6991
caqd 6992
staging 7108
cprocess

cacommd
httpd

dbclean
MergeCat

Many thanks
 
Old 01-27-2009, 04:10 AM   #2
jenniekingsland
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
when i try to access the web interface it looks like this

Index of /
Name Last modified Size Description-------------------------------------------------------------------------------- jennie.html 06-Aug-2008 14:48 6
--------------------------------------------------------------------------------
Apache/2.0.52 (Red Hat) Server at 172.17.10.194 Port 6060

it should load brightstore CA arcserver but it doesn't

I did a cstatus of the server that is running arcserve on the web interface fine and it looks like this[root@snenmgmt ~]# cstatus
caservd 4099
cadiscovd 4102 4101
cauthd 4203
caloggerd 4204
cadbd 4206
camediad 4302 4301 4207
caqd 4208
staging 4315
cprocess

cacommd 4200
httpd 4190 32419 27509

dbclean
MergeCat
 
Old 01-27-2009, 07:00 AM   #3
jenniekingsland
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Hi i managed to get the http daemon running but now i cannot start apache.

When i ran startgui at first i got this error
[root@snenmgmt ~]# startgui
ERROR: There was an error starting the httpd daemon.
Please examine the error messages and check the
/opt/CA/BrightStorARCserve/httpd/ directory

So i then typed this in
# /usr/sbin/httpd -f $BAB_HOME/httpd/conf/httpd.conf

Which returned
[Tue Jan 27 11:41:32 2009] [warn] PassEnv variable SHLIB_PATH was undefined
[Tue Jan 27 11:41:32 2009] [warn] PassEnv variable LIBPATH was undefined
(98)Address already in use: make_sock: could not bind to address [::]:6060
no listening sockets available, shutting down
Unable to open logs

So i then did this
netstat -tulpn| grep :6060
tcp 0 0 :::6060 :::* LISTEN 11451/httpd

and ran [root@snenmgmt ~]# killall -9 httpd

I then did a startgui which returned
BrightStor ARCserve Backup GUI daemons started
[root@snenmgmt ~]# cstatus
caservd 31061
cadiscovd 31072 31064
cauthd 31163
caloggerd 31164
cadbd 31165
camediad 31260 31259 31166
caqd 31167
staging 31271
cprocess

cacommd 11511
httpd 11501 11512

dbclean
MergeCat

the web interface now loads

i then need to start apache so i enter
apachectl start

which returns
(98)Address already in use: make_sock: could not bind to address [::]:6060
no listening sockets available, shutting down
Unable to open logs
[root@snenmgmt ~]# netstat -tulpn| grep :6060
tcp 0 0 :::6060 :::* LISTEN 11501/httpd



if i run killall -9 httpd
then running the command 'apachectl start' it will start

but then if i enter cstatus it returns[root@snenmgmt ~]# cstatus
caservd 31061
cadiscovd 31072 31064
cauthd 31163
caloggerd 31164
cadbd 31165
camediad 31260 31259 31166
caqd 31167
staging 31271
cprocess

cacommd 11511
httpd

and now there is no number next to httpd and the web interface won't work.

how do i get both httpd to work and apachectl to start

to now get the web interface to load i have to kill the process again using killall -9 httpd and then run the
/usr/sbin/httpd -f $BAB_HOME/httpd/conf/httpd.conf other command to start httpd and then web interface loads but apache needs to be running
 
Old 01-27-2009, 07:07 AM   #4
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,230

Rep: Reputation: 137Reputation: 137
Erm, I am fairly sure httpd is apache2... so your trying to run two instances of the same application both of which want full deligation control over the ports that they are assigned to listen to...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable daemon to run with service daemon start,etc baddah Programming 6 12-02-2007 05:51 PM
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 07:24 AM
httpd server behind router failing to respond to requests daiyu Linux - Networking 9 06-11-2006 08:51 AM
httpd failing deWin Linux - Networking 3 12-25-2004 03:02 PM
httpd daemon cannot be initialized gogo Linux - Networking 0 10-02-2001 04:12 AM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration