LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2011, 01:33 AM   #1
brownie_cookie
Member
 
Registered: Mar 2011
Location: Belgium
Distribution: CentOS release 5.5 (Final), Red Hat Enterprise Linux ES release 4 (Nahant Update 8)
Posts: 416
Blog Entries: 2

Rep: Reputation: 12
Hp-ux b.11.11 u


Hi all

Me again , i'm working on a HP-UX B.11.11 U and I'm stuck.....
I'm following this guide link to guide.
I'm on page 6. I did everything, i've downloaded and unzipped everything.
When I go to the folder ~/downloads and try the
Code:
./configure
command, it does what it's need to do, but THEN
the command
Code:
 make all
fails...
it says:
Code:
[host:/some/folder/downloads/nrpe-2.12]make all
Make: Don't know how to make all.  Stop.
what does that mean?

This is what contains the folder NRPE-2.12
Code:
[host:/some/folder/downloads/nrpe-2.12]ll
total 1008
-rw-r--r--   1 host       user           9205 Mar 10  2008 Changelog
-rw-r--r--   1 host       user            441 Nov 23  2007 LEGAL
-rwxr-xr-x   1 host       user           1753 Mar 14  2007 Makefile.in
-rw-r--r--   1 host       user           7056 Mar 14  2007 README
-rw-r--r--   1 host       user           1172 Mar 14  2003 README.SSL
-rw-r--r--   1 host       user           2723 Mar  9  2007 SECURITY
-rw-r--r--   1 host       user          43882 Jan 20  2006 config.guess
-rw-r--r--   1 host       user          57063 Apr  6 08:15 config.log
-rw-r--r--   1 host       user          32304 Jan 20  2006 config.sub
-rwxr-xr-x   1 host       user         223871 Mar 10  2008 configure
-rw-r--r--   1 host       user          11906 Mar 10  2008 configure.in
drwxr-xr-x   2 host       user             96 Apr  5 16:01 contrib
drwxr-xr-x   2 host       user             96 Apr  5 16:01 docs
drwxr-xr-x   2 host       user           8192 Apr  5 16:01 include
-rw-r--r--   1 host       user           1012 Mar  6  2004 init-script.debian.in
-rw-r--r--   1 host       user           1171 Jan  8  2003 init-script.in
-rw-r--r--   1 host       user           2192 Feb  3  2006 init-script.suse.in
-rw-r--r--   1 host       user           5585 Jun 23  2001 install-sh
-rw-r--r--   1 host       user           4891 Mar 10  2008 nrpe.spec
drwxr-xr-x   2 host       user             96 Apr  5 16:01 sample-config
drwxr-xr-x   2 host       user           8192 Apr  5 16:01 src
-rw-r--r--   1 host       user           1046 Nov 23  2007 subst.in
-rw-r--r--   1 host       user           2143 Mar 10  2008 update-version
can someone help pls

Last edited by brownie_cookie; 04-06-2011 at 01:34 AM.
 
Old 04-06-2011, 01:43 AM   #2
decodedthought
Member
 
Registered: Oct 2007
Location: California,USA
Distribution: Archlinux
Posts: 206

Rep: Reputation: 21
was the ./configure procedure sucessful ? or did it show any error at the end?
 
Old 04-06-2011, 01:52 AM   #3
brownie_cookie
Member
 
Registered: Mar 2011
Location: Belgium
Distribution: CentOS release 5.5 (Final), Red Hat Enterprise Linux ES release 4 (Nahant Update 8)
Posts: 416
Blog Entries: 2

Original Poster
Rep: Reputation: 12
indeed, the configure didn't do his full run
he exited because i don't have openssl installed, so i'm trying to do this now
 
Old 04-06-2011, 02:26 AM   #4
brownie_cookie
Member
 
Registered: Mar 2011
Location: Belgium
Distribution: CentOS release 5.5 (Final), Red Hat Enterprise Linux ES release 4 (Nahant Update 8)
Posts: 416
Blog Entries: 2

Original Poster
Rep: Reputation: 12
problem ...

when i try to install openSSL i get this error:
Code:
[host:/some/folder/downloads/openssl-1.0.0c]./config
Operating system: 9000/800-hp-hpux1x
Can't locate strict.pm in @INC (@INC contains: /opt/perl5/lib/5.00502/PA-RISC1.1 /opt/perl5/lib/5.00502 /opt/perl5/lib/site_perl/5.005/PA-RISC1.1 /opt/perl5/lib/site_perl/5.005 .) at ./Configure line 9.
BEGIN failed--compilation aborted at ./Configure line 9.
Can't locate strict.pm in @INC (@INC contains: /opt/perl5/lib/5.00502/PA-RISC1.1 /opt/perl5/lib/5.00502 /opt/perl5/lib/site_perl/5.005/PA-RISC1.1 /opt/perl5/lib/site_perl/5.005 .) at ./Configure line 9.
BEGIN failed--compilation aborted at ./Configure line 9.
This system (hpux-parisc2-gcc) is not supported. See file INSTALL for details.
the last line says my system is not supporting this, does anyone know which one i do support????
 
Old 04-06-2011, 07:54 AM   #5
decodedthought
Member
 
Registered: Oct 2007
Location: California,USA
Distribution: Archlinux
Posts: 206

Rep: Reputation: 21
see if this helps:
http://granito.org.uk/objphp/users/r...risc32hpux.txt
 
Old 04-06-2011, 08:29 AM   #6
brownie_cookie
Member
 
Registered: Mar 2011
Location: Belgium
Distribution: CentOS release 5.5 (Final), Red Hat Enterprise Linux ES release 4 (Nahant Update 8)
Posts: 416
Blog Entries: 2

Original Poster
Rep: Reputation: 12
when i've got some time i'll see what it does and i'll post my outcome

but thx !!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 07:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration