LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2011, 04:42 AM   #1
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Rep: Reputation: 31
HP Printer doesn't work on Suse 9.0


Hi!

I have the printer HPLaserjet1006 running on Suse9.0. I have installed foo2zjs. The printer is enabled and when I try to print something, the document is added in the queue and everything seems normal except that nothing is being printed, no matter how long I wait.
Since I don't have any error message anywhere, I don't know what to do. The printer works fine under XP on the same computer.
Any suggestion?

Thanks in advance.
 
Old 08-18-2011, 06:59 AM   #2
gary185
Member
 
Registered: Jul 2011
Posts: 113

Rep: Reputation: Disabled
first check the cups web interface to see what it says about if the printer instarted or stopped


printing in linux is always a bit of a struggle to setup
that printer requires some firmware yes ?
I think the firmware needs to be sent tio the printer everytime it's started
http://foo2zjs.rkkda.com/INSTALL
this is covered by the
make install-hotplug
step
exactly what steps did you take to get it set up to this point ?
did you do the step after make
./getweb P1006
then make install
then make install-hotplug
you have foomatic installed yes?

what do you get when you type
usb_printerid /dev/usb/lp0
you should see something in there like FWVER= (firmwareversion)


do you get anything in /var/log/messages when you plug and unplug the printer ?


you might have a bad udev rule getting in the way
 
Old 08-18-2011, 07:11 AM   #3
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
Try this, it is the latest driver package from hp

driver
 
Old 08-18-2011, 07:59 AM   #4
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by Larry Webb View Post
Try this, it is the latest driver package from hp

driver
Thanks for the advice. I've looked on the website but they only offer something for Suse 11 and I use Suse9. I'll still give it a try.
 
Old 08-18-2011, 08:07 AM   #5
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by gary185 View Post
first check the cups web interface to see what it says about if the printer instarted or stopped


printing in linux is always a bit of a struggle to setup
that printer requires some firmware yes ?
I think the firmware needs to be sent tio the printer everytime it's started
http://foo2zjs.rkkda.com/INSTALL
this is covered by the
make install-hotplug
step
exactly what steps did you take to get it set up to this point ?
did you do the step after make
./getweb P1006
then make install
then make install-hotplug
you have foomatic installed yes?

what do you get when you type
usb_printerid /dev/usb/lp0
you should see something in there like FWVER= (firmwareversion)


do you get anything in /var/log/messages when you plug and unplug the printer ?


you might have a bad udev rule getting in the way
Thanks for all the suggestions.

I did make all the "make install" stuffs. The printer is actually being detected but I dont't get any Firmware-info:
Code:
 usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:ACL;CLS:PRINTER;DES:HP LaserJet P1006;
Looking in the logs as you told me gave me a bit of an answer though:
Code:
Aug 18 14:40:45 linux kernel: usb.c: USB device 3 (vend/prod 0x3f0/0x3e17) is not claimed by any active driver.
Aug 18 14:40:49 linux kernel: usb.c: registered new driver usblp
Aug 18 14:40:49 linux kernel: printer.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3E17
Aug 18 14:40:49 linux kernel: printer.c: v0.11: USB Printer Device Class driver
Aug 18 14:40:49 linux insmod: Using /lib/modules/2.4.21-297-athlon/kernel/drivers/usb/printer.o
Aug 18 14:40:49 linux insmod: Symbol version prefix ''
/etc/hotplug/usb/hpljP1006: foo2zjs: Missing HP LaserJet P1006 firmware file /usr/share/foo2xqx/firmware/sihpP1006.dl
/etc/hotplug/usb/hpljP1006: foo2zjs: ...read foo2zjs installation instructions and run ./getweb P1006
/etc/hotplug/usb/hpljP1006: foo2zjs: Missing HP LaserJet P1006 firmware file /usr/share/foo2xqx/firmware/sihpP1006.dl
/etc/hotplug/usb/hpljP1006: foo2zjs: ...read foo2zjs installation instructions and run ./getweb P1006
So i don't know why the file sihpP1006.dl is missing since I did all the foo2zjs installation and I don't know how to provide it. I'll research on the web but I'm thankful for any advice.
 
Old 08-18-2011, 08:22 AM   #6
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
ok. It seemed that I had forgotten to do
Code:
./getweb P1006
.
I did so but I now get a new kind of error messages:
Code:
Aug 18 15:12:43 linux kernel: hub.c: new USB device 00:02.2-2, assigned address 7
Aug 18 15:12:43 linux kernel: printer.c: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3E17
/etc/hotplug/usb/hpljP1006: foo2zjs: loading HP LaserJet P1006 firmware /usr/share/foo2xqx/firmware/sihpP1006.dl to /dev/usb/lp0 ...
Aug 18 15:12:47 linux kernel: usb_control/bulk_msg: timeout
Aug 18 15:12:47 linux kernel: usbdevfs: USBDEVFS_CONTROL failed dev 7 rqt 128 rq 6 len 18 ret -110
Aug 18 15:12:47 linux kernel: usb_control/bulk_msg: timeout
Aug 18 15:12:47 linux kernel: usbdevfs: USBDEVFS_CONTROL failed dev 7 rqt 128 rq 6 len 18 ret -110
Aug 18 15:12:47 linux kernel: usb_control/bulk_msg: timeout
Aug 18 15:12:47 linux kernel: usbdevfs: USBDEVFS_CONTROL failed dev 7 rqt 128 rq 6 len 18 ret -110
Aug 18 15:12:47 linux kernel: usb_control/bulk_msg: timeout
Aug 18 15:12:47 linux kernel: usbdevfs: USBDEVFS_CONTROL failed dev 7 rqt 128 rq 6 len 18 ret -110
Aug 18 15:12:47 linux kernel: usb_control/bulk_msg: timeout
Aug 18 15:12:47 linux kernel: usbdevfs: USBDEVFS_CONTROL failed dev 7 rqt 128 rq 6 len 18 ret -110
Aug 18 15:12:47 linux kernel: usb_control/bulk_msg: timeout

Last edited by xpucto; 08-18-2011 at 11:10 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer doesn't work Kyle Lionheart Debian 3 11-10-2006 10:18 AM
Printer used to work, now doesn't francisstp Linux - Hardware 4 09-12-2006 10:06 PM
The printer doesn't work luquino Linux - Software 2 08-08-2006 02:05 AM
Printer Canon S450 with SuSE 9.1 doesn't work bunkenburg Linux - Hardware 1 01-11-2005 06:04 PM
printer modules not loaded; parallel printer doesn't work blinux1 Linux - Newbie 7 06-24-2004 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration