LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2011, 07:26 AM   #1
konsolelover
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Arch, Ubuntu 11.04
Posts: 78

Rep: Reputation: 3
HP pavilion dv5-1106ax WebCam driver


Hello LQ Users,
I have installed Ubuntu 11.04 32 bit on my laptop. Everything works fine but my WebCam.Video chat option in Empathy 2.34.0 is disabled and webcam in Facebook doesn't seem out to work.From where can i get the driver for my WebCam ?
 
Old 08-07-2011, 08:36 AM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi konsolelover, Please post the output from the following.

Code:
$ sudo lsusb
Good luck. ;-)
 
Old 08-07-2011, 11:05 AM   #3
gary185
Member
 
Registered: Jul 2011
Posts: 113

Rep: Reputation: Disabled
my dv6 webcam
Bus 001 Device 002: ID 0bda:5801 Realtek Semiconductor Corp.
seems to be using uvcvideo as its driver
if that helps
 
Old 08-07-2011, 11:20 AM   #4
konsolelover
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Arch, Ubuntu 11.04
Posts: 78

Original Poster
Rep: Reputation: 3
thanks for your replies,
lsusb results,
Code:
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 0421:0208 Nokia Mobile Phones 
Bus 005 Device 002: ID 138a:0001 DigitalPersona, Inc Fingeprint Reader
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0408:03ba Quanta Computer, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
i think it is
Code:
Bus 001 Device 002: ID 0408:03ba Quanta Computer, Inc.
but could not find a driver for my device id
 
Old 08-07-2011, 08:27 PM   #5
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
After looking at the USBID list, I believe you're correct about the device. Quanta (0408) has a couple of webcams listed although your particular device id isn't on the list. Try modprobing the uvc driver.

Code:
$ sudo modprobe uvcvideo
Good luck. ;-)
 
Old 08-07-2011, 08:31 PM   #6
gary185
Member
 
Registered: Jul 2011
Posts: 113

Rep: Reputation: Disabled
yea that's it.
http://hardware4linux.info/component/38392/

seems like that should be working
do
lsmod

do you see something like

uvcvideo 54408 0
videodev 33792 1 uvcvideo
v4l1_compat 14852 2 uvcvideo,videodev

you could try
modprobe ucvideo

do you have a program or can get it from repository called
wxcam

it's just a capture gui that should just kind of work so it's a good way to test for basic functionality.
I don't know about the other thing you mentioned not working
is it possible they need some kind of external capture program ?
 
1 members found this post helpful.
Old 08-08-2011, 12:41 AM   #7
konsolelover
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Arch, Ubuntu 11.04
Posts: 78

Original Poster
Rep: Reputation: 3
Thanks for your help guys,
lsmod | grep uvcvideo gave,
Code:
uvcvideo               66851  0 
videodev               75143  1 uvcvideo
After watching some other forums, I've already executed modprobe uvcvideo.
Empathy still doesn't show the video chat option.
But after installing google-talkplugin_current_i386.deb , it enabled the voice and video chat option in Gmail.
Gonna install wxcam ,I'll tell u about it....
 
Old 08-08-2011, 01:20 AM   #8
konsolelover
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Arch, Ubuntu 11.04
Posts: 78

Original Poster
Rep: Reputation: 3
Code:
sudo dpkg -i Downloads/wxcam_1.1_i386.deb 
Selecting previously deselected package wxcam.
(Reading database ... 134745 files and directories currently installed.)
Unpacking wxcam (from Downloads/wxcam_1.1_i386.deb) ...
dpkg-deb (subprocess): short read on buffer copy for failed to write to pipe in copy
dpkg-deb: error: subprocess paste returned error exit status 2
dpkg: error processing Downloads/wxcam_1.1_i386.deb (--install):
 short read on buffer copy for backend dpkg-deb during `./usr/bin/wxcam'
Errors were encountered while processing:
 Downloads/wxcam_1.1_i386.deb
 
Old 08-08-2011, 03:25 PM   #9
konsolelover
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Arch, Ubuntu 11.04
Posts: 78

Original Poster
Rep: Reputation: 3
Just installed Camorama Webcam Viewer and yes its working fine......but Empathy is still not getting it right....
Opened omegle.com and selected the video chat option and its working n hope it will work with Skype as well

Last edited by konsolelover; 08-08-2011 at 03:37 PM.
 
Old 08-17-2011, 09:13 PM   #10
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Here are some suggestions for the Empathy problem.

http://live.gnome.org/Empathy/FAQ

Good luck. ;-)
 
1 members found this post helpful.
Old 08-18-2011, 11:07 AM   #11
konsolelover
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Arch, Ubuntu 11.04
Posts: 78

Original Poster
Rep: Reputation: 3
firstly thanks for your help Peacedog, i checked the site n checked the packages telepathy-haze and telepathy-gabble packages n it is already the latest versions. BTW you gave me direction now i'll find my way out.. :-) Marking this thread as solved because my cam's working.If i'll face some problem ,will start a new thread for Empathy..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Linux debian on hp pavilion dv5 1130 -ek tripleh Linux - Laptop and Netbook 2 08-15-2010 05:53 PM
Help! I want to install Linux on my HP Pavilion dv5-1125nr laptop mad34 Linux - General 4 04-18-2010 03:37 PM
[SOLVED] No Wi-Fi in Pavilion dv5 with Debian bocabits Linux - Hardware 2 12-04-2009 05:24 PM
Need Help in installing Fedora x86 64 on HP pavilion 1106ax laptop deepak1018 Fedora 2 05-25-2009 02:04 AM
Need Help in installing Ubuntu 9.04 on HP pavilion 1106ax laptop deepak1018 Ubuntu 1 05-24-2009 02:15 PM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration